FPS considerably lower since 5.2

Hi

I have a basic configuration 15" Macbook Pro Retina display. I have my game set on the recommended settings as outlined in the system options.

Ever since 5.2 was released my FPS have been cut in half. I deleted my WTF and my addons folder thinking that either two of them could be my problem but nothing has changed.

This certainly happened with the release of 5.2

Please advise.
Reply Quote
90 Worgen Hunter
9230
Mine have been fluctuating. I lowered some settings and it seems to be a bit better.
Reply Quote
90 Goblin Warlock
6955
Am experiencing the same problem. Disabling some addons and lowering graphic settings seems to help, but not eliminate the problem completely...
Reply Quote
I've also noticed that is basically cripples my entire system. Before I could alt-tab out and surf the web and whatnot but now even Chrome is becoming extremely unresponsive when WoW is running in the background.

Again, this was NEVER a problem pre 5.2
Reply Quote
- Technical Support
90 Human Mage
13340
A patch just dropped any out of date addons are going to cause very bad FPS drops and fluctuations. They made a significant changes to to the game Disable addons till you find the bad ones.

The worst ones right now are recount,dominoes to name a few there are many more that are not working corectly
Edited by Northernlite on 3/6/2013 9:56 PM PST
Reply Quote
Hi

I have a basic configuration 15" Macbook Pro Retina display. I have my game set on the recommended settings as outlined in the system options.

Ever since 5.2 was released my FPS have been cut in half. I deleted my WTF and my addons folder thinking that either two of them could be my problem but nothing has changed.

This certainly happened with the release of 5.2

Please advise.


Same problem on a recent Mac Pro, and an iMac. It appears the Mac client is also problematic.

A patch just dropped any out of date addons are going to cause very bad FPS drops and fluctuations. They made a significant changes to to the game Disable addons till you find the bad ones.

The worst ones right now are recount,dominoes to name a few there are many more that are not working corectly


I'm certain he said:


I deleted my WTF and my addons folder thinking that either two of them could be my problem but nothing has changed.


Reading helps. I digress however..
Reply Quote
Having some weird FPS problems as well.

I typically have normal frame rates of 60 (which i actually force cap it at) and before 5.2 I rarely saw it dip below 40 FPS in even the most extreme 40man BG scenarios.

I'm now seeing deltas of 10+ FPS just standing in one place and getting drops to as low as 20 FPS in simple 5 man dungeons, and as low as 5-10 FPS in typical 10-20 person pvp situations. Even in simple soloing activities I'm seeing deltas of 20 FPS (anywhere from 20-40) whereas before 5.2 soloing never dipped me below 50.

And honestly, the weirdest part is that i'm not seeing an increase in resource usage...

I've already tried the following to no avail:
1. completely removed all mods and fully reset UI (deleting cache, WTF, and interface folders)
2. made sure vertical sync and triple buffering were enabled (which i've actually always had on)
3. tried lowering graphics down to good, fair, and low*
*this bumps my avg FPS up by about 5 each but huge drops in combat still happen; and really on low settings my computer (which has specs above the blizz recommended system requirements) should NEVER be seeing it drop to 10 FPS when wow is set to UI defaults... that's just absurd.

Any help would be appreciated!
Reply Quote
Desperate - yet still shameless bump.
Reply Quote
I am seeing more and more posts such as this one come up. Has there been any response?
Reply Quote
90 Orc Death Knight
5025
Experiencing this problem as well, I don't use any add-ons... so its not that. Playing on a Mac Book Pro so it must be a Mac issue. Frame rate has been cut in half...even using recommended settings.
Edited by Dragonclaw on 3/8/2013 3:15 PM PST
Reply Quote
90 Tauren Paladin
10385
Not just Macs. I'm having the same problems on PC. Frame rates dropping to 1 for a few seconds, then it smooths out. The overall FPS has dropped a little, from 50 or so to mid to high 30s. I've updated everything I can, removed addons/WTF, and it still stalls on me.
Reply Quote
40 Draenei Mage
13095
In our case it is definitely server/client related and not a local settings issue, not a lua logging issue, WTF folder issue, Addon issue, or any of the sort. I play next to another Mac user in one state and my father plays on the same server but 500+ miles away from us. All three of us experience slow downs, freezes for several seconds, and times where the interface seems to lag significantly and stutter for some times 30+ seconds at a time and we usually all get it at the exact same time and recover at the same time.

This happens with us doing different things (dailys/pet battles/gardening usually) in different parts of Azeroth away from each other (we are not all in the same place doing the same things at the same time)

This is on a Macbook Pro and iMac both from different release times in 2009 and a Macbook Pro from 2012 (playing next to the iMac). Most Addons we use are not the same. We have 2 completely different Internet providers.
Reply Quote
90 Human Death Knight
10285
WTB blue post on this, badly, i mean seriously this is absolutely rediculous..
Reply Quote
90 Night Elf Rogue
9545
Same....went from 40-60fps pre 5.2

Post 5.2 10-15fps everywhere........ /cry
Reply Quote
90 Human Warlock
5975
from 60-130 fps pre patch down to 1-60 fps after patch.... wtf blizz
Macbook pro
Reply Quote
60 Night Elf Warrior
700
Having this issue as well. Pre-5.2, my graphical settings were configured so that I would rarely experience a drop in framerate below 60fps, and now I find it dipping as low as 25-30fps. I've been finding it happens to me in specific areas as well, such as the lift in Throne of the Tides.
Reply Quote
Support Forum Agent
Hey all,

Thanks for the reports on this. Since this is a new patch, try all the steps outlined in our World of Warcraft Performance Issues article first to see if this helps in anyway. This will help us out in eliminating other various factors that may cause performance issues.

If issues persist after you try all the steps listed, please post back here with your system information and what FPS values you are seeing.

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information: http://i45.tinypic.com/foodww.png
    4. Paste the contents of the copied system information here (Command-V)
Edited by Machkhan on 3/10/2013 12:42 PM PDT
Reply Quote
90 Night Elf Rogue
9545
Thank you so much for the response. We know you guys do your best to help and put up with A LOT of crap but I for one am grateful for all your work.
Reply Quote
90 Human Warlock
6510
I'm also having this problem. It appears WoW cripples my entire system performance. This is the support info for me. Currently running at 7 FPS.

Software:

System Software Overview:

System Version: OS X 10.8.2 (12C3012)
Kernel Version: Darwin 12.2.1
Time since boot: 14 minutes

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32

Graphics/Displays:

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
Reply Quote
90 Worgen Hunter
5615
Same problem, 7-12 FPS since 5.2

Software:

System Software Overview:

System Version: OS X 10.8.2 (12C3006)
Kernel Version: Darwin 12.2.1
Time since boot: 39 minutes

Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32

Graphics/Displays:

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
Edited by Kaelada on 3/11/2013 9:52 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]