When will the Auction House API data be back?

90 Tauren Paladin
1360
Has this feature gotten the silent patch axe like heirloom shields? If you aren't supporting this type of data anymore, could you please just let us know?
Reply Quote
90 Tauren Shaman
7390
was wondering why my auction db wasn't working......makes sense now
Reply Quote
6 Troll Mage
0
The european AH servers have been on and off after the realms came up. Currently they give the "(500) Internal Server Error", though they have been working occasionally today. And at some points they seemed to simply not update when expected.
Reply Quote
Battle.net Developer
We're working on this currently. There is always some hiccups in the AH servers on patch day and it looks like we have an extra error on the API end of things as well. We're hoping to get a fix out asap.
Reply Quote
90 Tauren Shaman
7390
Thank you very much for this info. Glad to see it is not my side that is broken.
Reply Quote
Battle.net Developer
It looks like AH data is working again, please let me know if you see any other errors.
Reply Quote
90 Pandaren Rogue
3915
The initial api respose for the AH is formatted differently, causing my crons to fail and I lost a chunk of AH data. Is there some mailing list we can subscribe to that might warn us about these changes so we can code around them?
Reply Quote
Battle.net Developer
The initial api respose for the AH is formatted differently, causing my crons to fail and I lost a chunk of AH data. Is there some mailing list we can subscribe to that might warn us about these changes so we can code around them?


The actual answer to the question is that there isn't a mailing list or anything for API changes.

As far as this particular problem, how is the format different? There should have been no changes to the format. During game patch deploys the game site (including API) can be put into maintenance mode which can mean the API returns html of the maintenance page. Other than that though the format of the AH data page shouldn't be any different now that it's back up and not erroring.
Reply Quote
90 Pandaren Rogue
3915
That was my mistake. I glanced at the errors in my logs and at the json response and assumed the "url" and "lastModified" were removed from their nested array [0]
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]