Launcher Gives "Unexpected Error"

90 Orc Shaman
10080
I recently had to do a fresh OSX Mountain Lion installation on my Mac Pro. Tried to install WoW afterwards, only to see the launcher give me an "Unexpected Error has occurred" message.

I googled the error and found out that this supposedly has to do with your drive either being case sensitive or FileVault being active. Neither of these situations apply to me. I have a case-insensitive HSF+ partition for the MacOS and FileVault is definitely turned off.

Launcher is still giving the error though and I can't install the game on my primary hard drive.

I also have a FAT32 formatted (also case-insensitive) HDD to store my documents. I tried installing the game on this drive as well, in the hopes of maybe moving it back under Applications after the installation. It produced the same error.

Would really appreciate some help.
Edited by Zebrimuri on 3/8/2013 3:53 PM PST
Reply Quote
90 Orc Shaman
10080
UPDATE:

http://us.battle.net/wow/en/forum/topic/8087928719

This fixed the issue. Posting here as reference to anyone else who ends up visiting my thread for the same problem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]