Diplomacy First

Cannot find Stormcaller Mylra. On the gunship but no npc on the ship.
Reply Quote
nvm they're back. Those mischievous npcs
Reply Quote
Ok left gunship, came back a few minutes later all npcs gone again.
Reply Quote
87 Draenei Shaman
6715
I think this is bugged, same problem, relogging doesn't work./
Reply Quote
90 Human Mage
12970
Could be a phasing issue. Try leaving the gunship and then going back. Or, even better, just try typing /reload to see if that clears up the problem.
Reply Quote
1 Blood Elf Hunter
0
The ship is also empty for me. Logging on and off doesn't have any effect. Someone else was having the issue at the same time as me. This is definitely a bug.
Reply Quote
90 Blood Elf Priest
17055
Did you abandon any quests on the ground underneath the gunship? You may be passing in and out of phases.

But then today was a wonky day for realms so maybe just bugged. Try again later.
Reply Quote
90 Blood Elf Hunter
7310
Happening on Malfurion as well. Zoned and logged out several times (once for over an hour) and nothing. I wouldn't be surprised if it had something to do with CRZ
Reply Quote
88 Worgen Death Knight
855
Tried everything but nothings worked :(
Reply Quote
85 Troll Hunter
800
Same problem here...
Reply Quote
90 Blood Elf Warlock
5230
also having this problem. blizz its time to take a look.
Reply Quote
87 Night Elf Druid
1245
Same issue here, the phase doesn't seem to matter as the objective NPC never appears on the ship itself, just a " ? " mark off in the distance
Reply Quote
90 Human Priest
6965
please fix or delete this quest ....ty
Reply Quote
90 Troll Warlock
4160
Having the same issue, logging doesn't help I've done it about 10 times so far and still no NPCs
Reply Quote
Neither does talking to Gms
Reply Quote
90 Human Paladin
1725
as of today still bugged. I guess blizzard doesn't listen to us. I've tried all of the suggestions. none work..:(
Reply Quote
90 Orc Warrior
16375
Try relogging.
Try leaving the ship then coming back.
Try coming back to her location after 10 minutes.

There is a bug with that dwarf where if your location changes she dissappears/phases.
There is also another bug with her in that the alliance can actually attack/kill her, since she is an NPC horde can interact with.

Basically once you finally get her to appear do not use any flying mounts to do the quests on the ship. Walk/run to do them. if you fly around the ship and you location changes, she will dissappear/phase.

I've done the quest 4 times this week. After the initial hurdle of getting her to actually show up after mulitple attempts, I found if I used my flying mounts to get back to her after fighting the ogre below deck, I had to repeat the process to get her to appear again. But if I walked back up the stairs to the top of the ship, I didn't have any issues other than when I first came to the ship from the temple of earth.
Edited by Grokironhide on 8/9/2013 12:39 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]