Retrieving Information ...

90 Night Elf Druid
9290
Is this ever going to get fixed? Over and over, log in, log out, I try to open a profession tab to create something, and I get this message.

Am I the only one, or is there some massive underlying problem? It's getting absurd when I have to log in daily to create an ingot/hide/what-have-you and CAN'T because of this stupid bug!
Reply Quote
90 Blood Elf Priest
8495
Its happening to me too. I have been just logging in and becoming afk for about 20 min and come bak. Just letting you know your not alone.
Reply Quote
90 Undead Warlock
13365
It's like I have to sit in queue just to use my profession cooldowns.
Reply Quote
90 Human Priest
6175
try just closing the menus and reopening them first. it may not be necessary to log out and relog.
Reply Quote
85 Goblin Death Knight
9485
Have you disabled your addons? Cleared your cache folders? Are you on a high pop server?
Reply Quote
This is also happening for many of our guild members when trying to view the Guild Professions panel (Guild Panel > Roster Tab > View-Professions).

This has been ongoing for quiet some time. Any suggestions?
Reply Quote
90 Human Mage
13350
Take it to the technical support forums.
Reply Quote
90 Tauren Druid
9355
Just close the profession tab and re-open it...Annoying but it fixes it everytime.
Reply Quote
90 Human Warlock
9045
i've had to reload ui to get it to fix.
Reply Quote
90 Pandaren Hunter
5895
Try deleting your cache/WDB folder. rename your WTF folder to WTF.backup... Login. Does it fix?
Reply Quote
43 Worgen Mage
3185
Just close the profession tab and re-open it...Annoying but it fixes it everytime.


Not for me. I always try that, and it has no effect.
Reply Quote
43 Worgen Mage
3185
Here's a possible clue. Lately after opening-then-closing any profession window, I get a message in the chat from the Armory add-on:

[Armory] WARNING: Profession data not saved. Please use the close button to trigger an update.

When I logged out out, disabled Armory add-on, logged in on another toon and opened Tailoring, I didn't get the "Retrieving" delay. Though it may be that, by then everything was loaded.

Note also that my Armory (like all my addons) is out od date, and I have the box checked to let me use out of date addons.

Maybe someone can research this further and determine if out-of-date Armory is really the cause. Meanwhile I'll update mine and then check if the problem is still around tomorrow.
Reply Quote
1: Out of date addons are NOT the main cause though they may cause some issues.

2: The "not saved" error from Armory is when you use hot keys to open prof lists/close them. You will not get this message if you physically open your prof and close it or use a hot key to open it and close it using the close button.

3: The issue with retrieving information on profs and items happens WITHOUT any addons even turned on. I have tested this (How hard is it really to turn all your addons off and log in anyways?) and it persisted but it only seems to do it on certain characters especially my scribe.

4: Closing then reopening profs, /reload ui, restarting, deleting cache ect may work for some but it does not work for all. Keep this in mind.
Reply Quote
90 Human Hunter
9260
I have the same problem with my Farm plow and seed bags. Its not just professions.
Reply Quote
90 Tauren Druid
7680
i've had to reload ui to get it to fix.


same
Reply Quote
90 Night Elf Druid
15810
Just close the profession tab and re-open it...Annoying but it fixes it everytime.


No it does not.
Reply Quote
8 Gnome Warrior
MIB
0
I have been having this problem for a while now. I have NO ADDONS running at all. Deleted the WFT and cache folder. Still takes up to 5 minutes... oh look there... it finished after 4 minutes this time!
Reply Quote
90 Orc Death Knight
13890
I have the problem too, it's happening for a while now.

I've tried:

1-) Cleaning Cache/WTF folders
2-) Cleaning Battle.net folder
3-) Removing completely all addons
4-) Doing a complete UI restart
5-) Have checked my internet connection, pathping, tracert, ping and no clue on network problems
6-) Have run repair on the launcher menu

The only think I have to add is when you delete the Cache folder, log in and try to access professions tabs and mouse over certain items (the Master Plow, specially) the problem
always seems to happen, but it also happens without doing this too.

Also, when the game is like that, I can't loot some corpses as well.
Edited by Orcba on 4/18/2013 3:08 PM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]