Guild still showing as Horde

90 Human Priest
7480
http://us.battle.net/wow/en/character/frostmourne/Drtriplex/advanced - When you hover my guild name - The guild is listed as a Horde guild. This causes our guild to show as horde on our WowStead site: http://evitusstultus.wowstead.com/ - They say they can't fix our guild showing as horde until our guild shows as Alliance on this page: http://us.battle.net/wow/en/character/frostmourne/Drtriplex/advanced

Our faction change to Alliance was completed on Feb 11, 2013.

This is causing us problems with people applying for our raid team thinking we're still horde. Can anything be done to fix this? Thanks for your time!
Reply Quote
90 Human Priest
7480
bump ... after 7 days...
Reply Quote
90 Human Priest
7480
Bump after 1 month......
Reply Quote
90 Human Priest
7480
Bump.... :(
Reply Quote
90 Human Priest
7480
Bump.... Still showing as horde even though we've been alliance for months.
Reply Quote
90 Pandaren Priest
12475
email wowarmory@blizzard.com
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]