Cannot connect to mobile armory.

(Locked)

90 Night Elf Druid
10135
Same here, haven't been able to connect since yesterday evening (AST). Glad it's not just me!
90 Blood Elf Mage
9210
Same issue here.

iPhone 4, AT&T service. Tried Wifi on + off. No deal.
100 Blood Elf Paladin
15130
Glad I'm not the only one. Doesn't work on either my iphone 4s (wifi or verizon wireless) or on my ipad mini.
100 Draenei Paladin
14295
Same here. I have Iphone 4, Verizon.
100 Night Elf Druid
16725
Same problem. I have a Google Nexus 4 (Android), doesn't connect over WiFi or Telus Mobility.
I've been having the same issue as others here. I've tried reinstalling several times but nothing seems to work. This has been an issue for the past 18 hours or so. Phone works on Android OS.
85 Human Priest
6075
Same for about 14 hours on iPhone 4S.
90 Undead Warlock
5275
I'm having the "Cannot establish connection" message every time I try to log on to the app on my Droid Razr Maxx (Verizon). Can we get a blue to weigh in on this? It's been non-working since Saturday night.
100 Pandaren Warrior
10180
Same here

on a

Galaxy Note II
90 Human Mage
11595
Same

Tried wifi and 4G

Samsung Galaxy Note (ATT)
90 Human Warrior
8905
Same issue since Sunday. iPhone 6 running most current update 6.1.3. AT&T network. Have attempted to connect through 4g, LTE and WiFi. I'm only having the issue when connecting to America's/oceanic. I have no issue connecting to Europe, but I live and play in the US. Missing my guildies and my auctions :(
90 Draenei Shaman
5130
Add me to the list. iPhone 4s and Nexus 7. I guess since I don't pay for this anymore it doesn't have to work.
100 Orc Hunter
14550
Having the same issue since Sunday afternoon. HTC EVO 3D
90 Draenei Priest
7815
Add me to the list.

HTC Droid DNA. (Verizon)
Edited by Fàde on 4/15/2013 8:24 AM PDT
90 Blood Elf Paladin
14695
Same

Samsung Galaxy Note II
90 Draenei Shaman
RK
7065
No connection on a Andriod OS.

T-Mobile
90 Orc Death Knight
9795
"Connection Error. Unable to establish connection to server."

I've received this error every time I've attempted to access the mobile armory for the last 36 hours approximately. I've attempted to access the armory on two different devices and get the same error. (Nexus One, Nexus 7).
98 Human Warlock
14065
Same here, been unable to connect since yesterday evening:(

Android OS
100 Blood Elf Warlock
14530
I have the same issue. Tried last night and it started doing that, this morning still the same thing. I tried uninstalling and reinstalling but that didn't seem to work. I have a Samsung Infuse on ATT.
90 Blood Elf Mage
4715
yeah im having the same problem i hope its fixed soon...would like some blue thoughts on this.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]