Possible armory achievement glitch fix

100 Human Mage
15350
Hello everyone, like many people I was having issues with my characters showing the right amount of achievements on the forums/armory. I was able to solve my problem a couple days ago, I went in-game and under Display I unchecked 'Display only Character Achievements to Others' on all of my characters, and then my achievements seemed to be working on the armory, the achievements on the forums didn't update until the next day, but yeah.

It appears to have worked for a couple other people on the forums.
Reply Quote
90 Worgen Mage
18815
what achievements were missing in particular? pet , title, mount rewards? because im trying to figure out if we have the same problem. if yes, then i hope unchecking works. props to you if doing this will fix my acchievement glitch ;)

EDIT: It worked thanks my friend!
Edited by Toncruz on 4/22/2013 9:35 PM PDT
Reply Quote
100 Human Mage
15350
Still seeing a lot of people posting with issues about their achievements.. bumping in the hope that this might be able to help someone.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]