Item restoration service broken?

90 Human Warlock
18040
hi, been trying for about 2hrs now to use the item restoration tool, and keeps giving me an error, saying that the server is currently unavailable, try again later.
I have been both logged in and out of the game not knowing if either affects it and tried to access all the toons on my realm, Caelestrasz oceanic.
Anyone have same issue or know a reason?
Reply Quote
20 Dwarf Hunter
12450
It is working for me, have you tried clearing your browsers cache? Have you tried a different browser?
Reply Quote
90 Human Warlock
18040
just cleared cache, and normally i use opera, but just tried IE and still same error :(
Reply Quote
91 Pandaren Priest
13570
Have you tried other browsers?
Have you utilized it for said character before?

If so, you'll want to post in the Website Bug Reports forum.
Reply Quote
100 Draenei Shaman
12590
I have seen others report this off and on...

Would work fine on all their characters, except for one, etc..

Really there was no fix.. but they left it a day or two, and it corrected itself... like there was some corrupt data or something, and just took time to flush out.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]