New default raid alert sound - turn off?

With the release of 5.3, there's some sound effect that gets played when you're targeted by abilities (for example, Jin'rokh targeting you with focused lightning).

Unfortunately, I find it extremely grating to listen to, but I've searched up and down the menus and searched through forum posts and I can't figure out for the life of me how to turn it off.

It is definitely not something from an AddOn, it's the default UI. It sounds like a mangled car horn or some kind of cheesy panic sound from a '50s sci fi flick.
Reply Quote
90 Goblin Priest
6610
I've gotten annoyed by this as well, working on narrowing it down.
Reply Quote
90 Gnome Warrior
12005
It appears to be PlaySound("UI_RaidBossWhisperWarning") near the end of RaidWarning.lua (RAID_BOSS_WHISPER event) doing that sound.

For testing purposes, the runty plants on the farm do that when they tell you to jump. (I jumped a little extra yesterday first time hearing that with sound turned way up)
Reply Quote
Is that something you can edit? I don't see any files in any of my WoW folders that are tagged as .lua (assuming it doesn't violate the ToS to remove a line like that or something - would it just cause WoW to crash, anyway?).
Reply Quote
90 Gnome Warrior
12005
Not something you can readily edit. Two ways to remove the sound:
1. Replace the sound file with a silent .ogg sound file. Not sure what sound folder the UI sounds are in and can't tell from this computer.
2. Or a small addon to hook or replace that section of RaidWarning.lua. I'm 95% sure it wouldn't taint anything to mess with that, but not 100% sure.

My previous post was to help Bob or someone narrow it down for a fix. I have to go to a meeting in a few minutes here but if nobody's posted a fix by later today I'll post one.
Reply Quote
90 Dwarf Mage
10875
We can't change the default UI's source code, but we can easily replace sound files.

Just create a new text file, rename it UI_RaidBossWhisperWarning.ogg (not .ogg.txt) and move it to your WoW\Data\Sound\INTERFACE folder (creating any subdirectories that don't exist).

Now every time it tries to play the sound, it should play your empty version instead (effectively muting it).

If this works, I can upload it to Curse/WoWI.
Edited by Choonster on 5/22/2013 6:41 AM PDT
Reply Quote
90 Night Elf Warrior
8305
For testing purposes, the runty plants on the farm do that when they tell you to jump. (I jumped a little extra yesterday first time hearing that with sound turned way up)

Haha! I was wondering what that new sound was; but, it only happened to me the very first time I had to fix a runty plant and never happened again. /shrug
Reply Quote
90 Goblin Priest
6610
Looks like the most efficient way is just to run

RaidBossEmoteFrame:UnregisterAllEvents()

That will kill the sound as well as the "Blizzard DBM warning text" as people may call it, or you can just unregister the event "RAID_BOSS_WHISPER" and that will take of it as well if I'm thinking correctly.

Also
RaidNotice_AddMessage( RaidBossEmoteFrame, "This is a TEST of the MESSAGE of EXTREME IMPORTANCE!", ChatTypeInfo["RAID_BOSS_EMOTE"] );
Just found a new way to spam people with addons :)
Edited by Bòb on 5/22/2013 7:59 AM PDT
Reply Quote
90 Pandaren Monk
16665
I really don't understand why UI elements like this get added without an option to turn them off. So frustrating to have to modify files to not be annoyed.
Reply Quote
90 Goblin Priest
6610
I really don't understand why UI elements like this get added without an option to turn them off. So frustrating to have to modify files to not be annoyed.


You can turn off sound and that will stop this sound
Reply Quote
90 Dwarf Mage
10875
Have you tried muting it as per my previous post? I can't test it at the moment.
Reply Quote
90 Human Paladin
16060
ARG... make it stop, whatever it is. Most annoying sound ever.

/script RaidBossEmoteFrame:UnregisterAllEvents()

gets rid of the announce text, but not the damn sound.
Edited by Brudarek on 5/22/2013 2:30 PM PDT
Reply Quote
90 Goblin Priest
6610
ARG... make it stop, whatever it is. Most annoying sound ever.

/script RaidBossEmoteFrame:UnregisterAllEvents()

gets rid of the announce text, but not the damn sound.


hmm figured it would...

I suppose I'll turn sound on for once and see if I can get a fix for it

EDIT:
try
/run RaidBossEmoteFrame:UnregisterEvent("RAID_BOSS_WHISPER")
Edited by Bòb on 5/22/2013 2:39 PM PDT
Reply Quote
90 Gnome Rogue
10430
Text gone, still the annoying sound of ear bleeding
Reply Quote
90 Gnome Warrior
12005
Choonster posted the fix in the 6th reply to this thread. No code, no script. Simply create an empty file and rename it to the right .ogg in the right folder:

http://us.battle.net/wow/en/forum/topic/8873728051#6
Reply Quote
90 Gnome Rogue
10430
Choonster posted the fix in the 6th reply to this thread. No code, no script. Simply create an empty file and rename it to the right .ogg in the right folder:

http://us.battle.net/wow/en/forum/topic/8873728051#6


Confirmed to work, file does not hot swap in (in case you thought it would) so it requires a restart.
Reply Quote
90 Dwarf Mage
10875
Thanks for testing that. I've uploaded that fix as an "AddOn" to Curse and WoWI. You can find it at the links below once it's been approved:

http://wow.curseforge.com/addons/raid-boss-whisper-warning-mute/
http://www.curse.com/addons/wow/raid-boss-whisper-warning-mute
http://www.wowinterface.com/downloads/info22328-RaidBossWhisperWarningMute.html
Reply Quote
MVP - Technical Support
90 Human Warrior
18100
DBM unregisters events to this frame automatically if you enable the "hide blizzard raid boss emote frame during boss fights" option

it should also disable sound effect in process

EDIT
Looks like bigwigs would also disable sound if you used their hide raidbossemoteframe as well since it also unregisters the events that'd trigger sound in first place.
Edited by Omegal on 5/22/2013 11:28 PM PDT
Reply Quote
We can't change the default UI's source code, but we can easily replace sound files.

Just create a new text file, rename it UI_RaidBossWhisperWarning.ogg (not .ogg.txt) and move it to your WoW\Data\Sound\INTERFACE folder (creating any subdirectories that don't exist).

Now every time it tries to play the sound, it should play your empty version instead (effectively muting it).

If this works, I can upload it to Curse/WoWI.


Confirming that this works - thank you so much!

I like playing with the game sound on, and I do like the raid alerts more than DBM or BigWigs or any of the other AddOns, but that sound effect was so incredibly awful that it was really interrupting my ability to play as well as usual. I'm glad there was a fix to JUST remove the new sound effect.
Reply Quote
90 Blood Elf Paladin
16810
Choonster posted the fix in the 6th reply to this thread. No code, no script. Simply create an empty file and rename it to the right .ogg in the right folder:

http://us.battle.net/wow/en/forum/topic/8873728051#6


Does this remove the sound from play entirely, or only from the farm?

I'd hate to lose this warning sound on boss fights.
Edited by Walls on 5/23/2013 11:48 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]