Keyboard not responding correctly (fixed)

90 Orc Shaman
10585
Starting to get real irritated that I don't even see this in the known issues.
Reply Quote
Starting to get real irritated that I don't even see this in the known issues.
http://us.battle.net/wow/en/forum/topic/6489880421

Using a modifier (shift/alt/control) that is bound on an external mouse or keypad may cause the modifer key to be stuck.
Edited by Arkesta on 5/22/2013 10:55 PM PDT
Reply Quote
90 Orc Shaman
10585
thank you
Reply Quote
Support Forum Agent
Try using this workaround and see what happens. Make sure WoW is closed.

In Terminal (/Applications/Utilities) type in the following:
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

Let me know the results.
Reply Quote
90 Goblin Warlock
6605
I just wanna say that this is affecting me as well. I tried the work around. This makes it almost impossible to play with my current keybinds. I'm using a Razer Naga and a cheap windows keyboard if it makes any difference. I haven't been able to play since the patch, and I'm starting to get aggravated.
Reply Quote
Support Forum Agent
Did the workaround not work at all?
Reply Quote
90 Pandaren Monk
14760
I just tried the workaround you suggested and my shift modifier still toggles on and off.
Reply Quote
90 Goblin Warlock
6605
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

I had set it to NO originally and none of the buttons would work on the mouse. I set it back to YES and I had the original problem.

I just tried setting it back to NO and it seems to be working atm. (I only did a 2 min test) I'll run some BG's and report back if I have any more problems.
Reply Quote
100 Human Mage
14680
Did the workaround not work at all?


I tried this fix just now in on my macbook pro and still no luck. Same issue as before, where the shift key stays 'stuck' once I use a command with my Razr Naga.

For example, I hit shift (on my keyboard) + 1 button (on my naga) and, whenever I hit any other number button on my Razr Naga it still acts like the shift key is pressed.

Something I did notice when playing with this though is that it works fine with just the keyboard and not the mouse. So if I try the above of Shift +1, but use the keyboard 1 and not the 1 on my Naga it functions correctly for the commands after that (the shift key isn't stuck).

I'm going to keep playing around with the Naga settings and see if I can find anything in there that would be causing it to stick. Let me know if you need any more information on my end.
Reply Quote
100 Human Mage
14680
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

I had set it to NO originally and none of the buttons would work on the mouse. I set it back to YES and I had the original problem.

I just tried setting it back to NO and it seems to be working atm. (I only did a 2 min test) I'll run some BG's and report back if I have any more problems.


You tried setting it back to NO after you ran it to turn it back to YES? I tried this as well, and after I set it back to NO after setting it to yes, I found that it completely ignored any modifiers with my Naga. For example, I would hit SHIFT + 1(on the Naga) and it just acted like I was hitting 1 (without SHIFT).

Setting it back to YES changed the behavior to how it was initially (where the modifier key sticks).
Reply Quote
90 Human Paladin
3545
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

I had set it to NO originally and none of the buttons would work on the mouse. I set it back to YES and I had the original problem.

I just tried setting it back to NO and it seems to be working atm. (I only did a 2 min test) I'll run some BG's and report back if I have any more problems.


You tried setting it back to NO after you ran it to turn it back to YES? I tried this as well, and after I set it back to NO after setting it to yes, I found that it completely ignored any modifiers with my Naga. For example, I would hit SHIFT + 1(on the Naga) and it just acted like I was hitting 1 (without SHIFT).

Setting it back to YES changed the behavior to how it was initially (where the modifier key sticks).


Likewise, same thing happened on my end.
Reply Quote
90 Goblin Warlock
6605
The fix seems to be working. The first time I tried it, it didn't work though. I made sure to reinstall synapse 2.0. Then I used synapse to download the latest driver for my naga. After I did that the fix seems to be working. Just a hint for anyone else with this problem.
Edited by Hówl on 5/23/2013 9:49 AM PDT
Reply Quote
90 Draenei Shaman
9560
Unfortunately, that fix didn't work for me. My laptop keyboard stopped registering shift, alt, and control, which made my problem worse. I use the laptop keyboard's shift, alt, and control keys. Those aren't mapped anywhere.

I even decided to try using a regular mouse 2-button with all addons disabled and ran into the same problem. It seemed if I was using the mouse at the same time I was accessing the keyboard with one of those modifiers, the modifier key would stick.
Reply Quote
Support Forum Agent
Thanks for the feedback. I'll send it on up :)
Reply Quote
100 Worgen Hunter
11705
The fix does not work for me. I tried the fix that you suggested

defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

but the "stuck shift" issue remained.

I then tried

defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool NO

Which disabled the ability to use the shift modifier at all.

Then using this again:

defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

Returned the ability to use the shift modifier again, and the "stuck shift" issue as well

Hope you can get to the bottom of this. my raid kept wiping last night due to this issue. It was not a fun evening.
Reply Quote
Same issue here.
Edited by Thehidden on 5/24/2013 6:00 PM PDT
Reply Quote
100 Blood Elf Priest
19855
Went into terminal and tried the fix; no dice. It was funny because I was trying to trade with a pal but the stuck modifier ended up in me dispelling them over and over and over and over until beating my keyboard (not really, but you get the picture) made it behave again.

And by funny, I mean sad :<

I get so tired of patches breaking something with the Mac machines. Machkhan, can we all just hug one another?
Reply Quote
90 Undead Warlock
16300
Having the same issue
Edited by Slashinwrist on 5/23/2013 5:07 PM PDT
Reply Quote
12 Draenei Shaman
60
Having this issue as well. It is fairly random when it occurs though, and also spontaneously fixes itself until it is triggered again. Initially it was with a shift modifier, now it mostly happens with a ctrl modifier.

Also using a naga where I have shift and ctrl bound to the side buttons.
Reply Quote
90 Night Elf Druid
8095
Are you saying that updating the drivers fixes it? Thats all it takes?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]