Launcher back to old version and cannot play

Hi Blizz,

I'm looking in many threads to solve my issue but it seems i can't find one so i decided to create one.

Initially the problem is my launcher stuck in 2/3 when updating from 5.2 to 5.3 so i'm looking around threads to solve the issues. One of thread told me to delete my Updates and Battle.net folders but after i follow the steps my launcher seems back to old version and cannot update anything.

Please help me to fix this. Thanks!
Reply Quote
Anyone can help me with this issue?
Reply Quote
Support Forum Agent
Gorkosh,

What happens when you start the game launcher? Are you seeing any error messages?

Make sure the launcher is being run as an admin by right clicking on the shortcut and selecting the 'run as admin' option.

______________________________
Got Feedback?
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
You say the launcher's reverted back to the old version.

Do you have a screenshot of your current launcher ?
Reply Quote
Already run as Admin. There is no error messages but when i start it seems that i get older version of launcher with install, manual and exit button. When i pushed install button i got "Data required to install this game could not be found". Here is the link that will show my launcher conditions, hope it can be used :

http://img40.imageshack.us/img40/663/mylauncher.png
Reply Quote
90 Dwarf Hunter
8725
mine did that too but did update the launcher just not the game
Reply Quote
Support Forum Agent
Gorkosh,

That looks like the installer. What is the name of the program are you running to pull that up?

Installer or not, it looks like something is blocking it's network connection. There are lots of things that can cause this.

Disabling or temporarily uninstalling firewall and anti-virus programs (Norton, McAfee, etc) can permit the launcher to run successfully. Of course, do not remove security software if you can't reinstall it, and always restore disabled security after patching.

Proxy settings on your system can also block access. Make sure to disable proxy settings from the control panel:
    Pull up your Control Panel and select Internet Options.
    Click on the Connections tab.
    Click the button called "LAN Settings"
    Uncheck all of the options on that screen.
    Then try again.


The launcher requires secondary logon service to be enabled in order for it to run properly.

______________________________
Got Feedback?
Reply Quote
Juranmok,

I did what you already suggested ( disable all proxy, disable firewall, disable windows defender ). I'm also make sure that windows secondary logon service is already in "started" condition.

But still no luck. I use "World of Warcraft Launcher" and prompted that screen. I'm also confused by that, usually the correct launcher shown up when i use the shortcut. Is it because i deleted my Battle.net folder? Because atm my agent folder name now is Agent.1040.
Reply Quote
Support Forum Agent
Gorkosh,

That folder is added back and then updated the next time you start the game. This isn't happening in your case. Something is blocking the launcher from updating.

Is your computer set to run in Offline mode? Try pulling up Internet Explorer to see.

What security program are you using?

______________________________
Got Feedback?
Reply Quote
100 Orc Warrior
9740
im also stuck ive done all this stuff as well and its still not working never had probs like this before
Edited by Jurannok on 5/22/2013 12:52 PM PDT
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
Find your battle.net folder.

In it go into the Setup folder.

Do you have a wow_enus folder there ?

Are there any programs in there ?

How big is your Data folder ?
Edited by Bluspacecow on 5/22/2013 12:22 PM PDT
Reply Quote
100 Orc Warrior
9740
yes the wow_enus folder is there
Reply Quote
I checked in my internet explorer setting and currently i'm running in online more ( offline mode disable ).

I use windows defender for security issues ( default anti virus for windows 8 ).

And same here wow_enus folder is there, my "Data" folder is around 25GB.
Edited by Gorkosh on 5/22/2013 8:07 PM PDT
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
Does the wow_enus folder have anything in it ?

Should only have a logs folder in there.
Reply Quote
90 Undead Warlock
5080
I just created a thread on a fix that worked for me that I haven't seen listed. Maybe it works for you
Reply Quote
Bluespacecow,

Yes its only Log inside wow_enus folder. Anything else i should checked?

Thyllis, i did some of your step :

I'm not going to sift through all of the threads, but I had the same issue where the launcher would be stuck at 66% 'Updating Blizzard Launcher'. I tried all the same stuff:
delete battle.net folder -> done
delete update folder -> done
uninstall Firefox -> done
turn off bit defender -> done
verify secondary login -> How to verify this? Is check the service enough?
run as admin -> done
download with chrome/IE etc.... -> How to download and what should be download?

On a whim I went back to IE 9 (I'm on windows 7 with IE 10) and I'm currently downloading the patch. Everything updated 1st try without deleting all that stuff again. -> since i'm using windows 8 it seems reverted back to IE 9 cannot be done

But the issue is still occur.. :(
Reply Quote
Bump
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
Well I'm off to bed now.

Before I go give this a go :

http://us.battle.net/wow/en/forum/topic/8796270709?page=1#6

Also is it attempting to do the migration process on you ? Might want to also delete any Temp or TempMig folders in your wow folder before starting the method I linked above.

That should work in restoring the proper launcher.

Also if your still getting the old Agent programs try using this mirror to download them :

http://patchup.info/blizz/tools/Win/

Sorry if I missed something but its kinda late (and cold :( ) here so I'm off to bed. Will check into things when I wake up tomorrow sometime.
Reply Quote
Hi guys, i finally solved the launcher problems. What i did is update my launcher manually. Now the new problem is coming, my launcher cannot download game client perfectly. I decided to patch it manually but it still requires around 16MB to download from internet.

the problem is my launcher can only download for 100-200KB and then stop working. Any suggestions?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]