[5.3] Major Input Lag Issues

MVP - Technical Support
90 Human Priest
6220
I haven't been able to pin down a cause, but my preferences have not changed since 5.2 where I had no appreciable input lag, and as of firing up WoW after the 5.3 patch, I now have a consistent and very noticeable 1/4th second input lag across the board. Clicking the action bars does not appear to be affected, but mouse movement (cursor), camera movement (both mouselook and movement), as well as all keyboard input is showing the exact same input lag.

It was very easy for me to see the lag and time it by how long it took for the letters to appear in chat. Unlike before when they would appear instantly, there is a .25 second lag time before the letters show up in chat. I can actually see the words I type appear one letter at a time after I've already finished typing the word (yes I can type that fast when warmed up).

I went ahead and tried Diablo 3 as well to see if the input lag was present there, but it is not. It is limited to WoW 5.3. This was not present during my PTR test runs.
Reply Quote
MVP - Technical Support
90 Human Priest
6220
Update: This issue appears to occur primarily in the Pandaria content area. The old world zones do not have the input lag issue.
Reply Quote
90 Night Elf Druid
9120
I'm having the same issue.

I disabled all my add-ons(Bartender, Recount, DBM) and it still continued.

Like above, it only seems to bother me in the Pandaria content(dungeons included).

The game is borderline unplayable.

I've had spikes where I've even had close to a full 1 second delay or worse.

edit: I saw that you're running 10.6.8 in one of the stickies. I am too. Do you think this is the first signs of it finally crapping out?
Edited by Petry on 5/26/2013 4:46 PM PDT
Reply Quote
MVP - Technical Support
90 Human Priest
6220
I've been able to reproduce the input lag in 10.8.3 as well, so it's happening in all OS versions. Even Omegal has noticed it.
Reply Quote
90 Night Elf Druid
9120
Hmm...weird.

I've noticed it varies from character to character for me too.

It's usually consistently worse with much worse spikes on my rogue compared to my mage, although it's fairly evident on my mage too.
Reply Quote
MVP - Technical Support
100 Human Warrior
21505
I really don't get any input lag, at least nothing that's different from 5.2. certainly nothing you two are seeing.
Reply Quote
MVP - Technical Support
90 Human Priest
6220
I really don't get any input lag, at least nothing that's different from 5.2. certainly nothing you two are seeing.


What about the lag you and I both noticed when we were typing late last week?

The input lag only seems to occur in Pandaria, and it doesn't make the game unplayable, but it does make it more difficult to make precise movements.
Reply Quote
90 Blood Elf Warlock
12190
Experiencing this too. Soloing warbringers is borderline impossible with this amount of lag. It's hard enough to raid this way, but doing fun things that require patience and precision are are right off the board because the game post-5.3 is too blunt an instrument to support them.

Blizzard, I'm getting incredibly tired of the shoddy Mac support. If it isn't system-killing bugs that melt down people's graphics chips unless we manually halt threads, it's idiotic things like this, which utterly destroy a person's ability to enjoy the game.

At this point, I'm beyond embarrassed on your behalf -- I'm actually annoyed.
Edited by Koshchei on 5/27/2013 4:51 PM PDT
Reply Quote
47 Night Elf Rogue
5185
It has been happening to me to, although mine are not just a few lag here and there. I log in and start combat, when everything just stops, I cast 1 ability and it takes about 5 min for it to catch up and then im dead. I only happens in Pandaria. It's not my computer, its new, and I running a really good processor. Didn't have this problem until 5.3 came out. It's really unplayable and really frustrating.
Reply Quote
90 Human Paladin
8105
It has been happening to me to, although mine are not just a few lag here and there. I log in and start combat, when everything just stops, I cast 1 ability and it takes about 5 min for it to catch up and then im dead. I only happens in Pandaria. It's not my computer, its new, and I running a really good processor. Didn't have this problem until 5.3 came out. It's really unplayable and really frustrating.
Reply Quote
90 Human Paladin
8105
Sorry didnt mean to post that twice.
Reply Quote
MVP - Technical Support
100 Human Warrior
21505
Different type of lag are getting mixed in here. action button lag isn't what tia is posting. nor is it network lag. input lag is for example if you are typing a sentence and characters are slow to appear, or your mouse seems very slow or unresponsive and not fluid like it should be.

Ability lag such as casting something and having it delayed or fps lag are two very different issues and require different troubleshooting and different thread.
Reply Quote
90 Human Warrior
9790
happening here as well. solid quarter second delay when im moving my character, using mouse, or typing. very annoying and almost impossible to play with such a bad keyboard/input delay to my game.

hope this is fixed soon.

edit:

NO LAG on main menu or character selection screen.

Only happens when out in Pandaria. Shrine of Seven Stars the lag goes away. When i fly between the two pandaria faction cities, it starts again.

Did not help: deleted the Cache, Interface, and WTF folders. Tried windows mode / full screen
running 0 addons.
tried windows mode / full screen

Specs:
OSX 10.8.3 (fully updated with latest software)
CPU: 2.5 GHz Intel Core i5
Memory: 8GB 1600 Mhz DDR3
Graphics: Intel HD Graphics 4000 768 MB
Edited by Swagasrsrex on 5/29/2013 8:27 AM PDT
Reply Quote
90 Blood Elf Warlock
12190
I'll be more specific:

- Mouse pointer moves at normal rate.
- Text input is delayed by a good 1/4 second.
- Camera movement is delayed by a good 1/4 second.
- Character movement is delayed by a good 1/4 second.
- Time between when key is pressed and ability is fired is a good 1/4 second.

What doesn't help:

- Turning off add-ons. This is a problem with the client.
- Changing resolution/reducing effect quality.

What I'm running:

- a 2011 15" Macbook Pro Quad Core i7 with 16GB RAM, 128GB SSD (WoW on this drive), 1TB FW800 drive, Radeon 6750 with 1GB at 1680x1050 resolution.
- OSX 10.8.3

Fix this asap. It's really frustrating to be handicapped by the game. This was not a problem in 5.2.
Edited by Koshchei on 5/29/2013 6:42 AM PDT
Reply Quote
MVP - Technical Support
90 Human Priest
6220
Just so you all know, turning off V-Sync does not solve this. That was my first troubleshooting step as V-Sync is known to increase input lag slightly, but in this case, the input lag is so bad it rivals my the lag from TV's motion smoothing feature, which clocks in at 120ms.

I have a metronome on my phone that also flashes during each pulse (I have it defaulted to 100 BPM for CPR rhythm maintenance), and I set it to 240 BPM, which is four times per second (1/4 second intervals), and I tested both typing and letting the mouse go while in flight (with camera auto-center on to see when movement started). I'd time the let go phase at one beat and the visual indication of my action didn't occur until exactly one beat later on my metronome.

This kind of input lag can get you killed very easily in a raid where precision is required.
Reply Quote
90 Draenei Warrior
13175
I came to this forum for a Blizzard answer, I guess thats asking to much. we only pay to play the game why should we have any confirmation on anything. lol
Reply Quote
MVP - Technical Support
90 Human Priest
6220
I came to this forum for a Blizzard answer, I guess thats asking to much. we only pay to play the game why should we have any confirmation on anything. lol


Blizzard isn't really going to be able to say much until they can at least reproduce the issue posted here. Until then we'll have to sit tight and hope there's a fix in the pipe. When there is, we'll hear about it.
Reply Quote
Support Forum Agent
Hey all,

Just wanted to touch base here and let you know this is being looked into. Once I have more information, I'll post back. Thanks!
Reply Quote
90 Night Elf Druid
9120
I tried disabling "Reduce Input Lag" in the System>Advanced menu and weirdly enough it actually improved quite a bit.

There's still a little bit of input lag, but much better than before.

I also reduced my resolution and went from Windowed(Fullscreen) to Fullscreen. I'm not sure if if it was the Reduce Input Lag, a combination of all three or even just a coincidence though.
Reply Quote
90 Blood Elf Warlock
21320
I came to the Mac Tech forums to report the same issue and it's good to see there's already a thread and I'm not the only one experiencing this.

Since 5.3 I've noticed a slight delay/lag in regards to typing and cursor movement. Particularly anytime there is a mouse over (example, when scrolling down the guild members listing or achievements listing window) the highlight lags a bit behind. When typing in chat there is a noticeable delay between key press and when the actual letters appear. As others have stated, this only seems to be an issue when I am in Pandaria. Old world zones seem to be ok.

So far I've tried turning off all add ons, toggling on/off the "reduce input lag" option, deleting the cache, adjusting resolution and nothing seems to improve the situation.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]