Browser Proxy :(

90 Gnome Warlock
5320
Since 5.3 came out every time I get in a group my latency slows to a crawl. I know all the steps and stuff to check for problems but I know exactly what it is. When I group my comp starts running some WoW Browser Proxy, in LFRs it runs it again after each boss, it is what is killing my latency. I know it is because when i kill it my Latency goes back to ok. Is there any way to stop this or do I just have to wait till my lag gets bad cntrl/alt/delete out kill the damn process and then go back and hope I haven't died?
Reply Quote
90 Gnome Warlock
5320
Any suggestion from Community it is the new BrowserProxy.exe I know it is.
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
This is the internal support browser.

It has a set of URLs its allowed to connect to , a black and a whitelist. Mainly connects to the support website.

But if can't start up it should just revert to the old system.

You could just delete it from the Utils folder in the Wow folder and see if it improves things.

I know it is because when i kill it my Latency goes back to ok


Wat :|

Hmmm. That makes .... no sense. It connects to the support website over port 80 IIRC.

This may be a bug !

Can you copy and paste the contents of your connection.log file from your Logs folder ?
Reply Quote
90 Gnome Warlock
5320
Yep Deleted it and no issues at all :) thanks for the info as to where it was. Anytime I run anything other than WoW I get lag only DBM as far as addons anything else I start to get bogged down just barely 2.7 cpu and HP crap screwed up my system a bit got all I can find killed/deleted/turned off but still issues with WoW and most Facebook games dunno what it is. Thanks for the assist can play now = happy customer!
Reply Quote
90 Draenei Hunter
12165
It does it to my boyfriend too. Same drop in latency when he ends the task.
Reply Quote
89 Human Mage
5685
I had a similar problem, to the point that when I did a /reload, the game wouldn't even finish the reload, it would just sit there... I am hoping that it won't reinstall when I run the game again, getting tired of stuff like this eating my authenticator codes...
Reply Quote
43 Pandaren Monk
11875
It does it to my boyfriend too. Same drop in latency when he ends the task.

You can kill the wowproxy in your running services. It is not a needed function for the game to work. You can also tell if killing this service stops the latency issue. If it does then I suggest posting your findings on the bug report forum so QA can look into these issues.

This is new since patch 5.3. It is highly possible it will have bugs and need kinks worked out. This is why it would be important to bring it to the attention of QA via posting in bug report, or click the support link at the top of this page, then choose the option to report a bug.
Reply Quote
90 Orc Shaman
4380
Same. was lagging as hell , i killed it and now it's good ! ;)
Reply Quote
90 Worgen Rogue
9390
I found this process when I had to search the task manager for something that didn't look right after pressing any key in WoW would just toggle various options on and off. Tried pressing M to look at my map and I just kept turning music off and on repeatedly instead. When I minimized WoW to check the Task Manager, I could not bring WoW out of its minimized state until this process (wowbrowserproxy.exe) was killed.

Just thought I'd chime in with my own experience that occurred seconds before this posting.

EDIT: I noticed no latency issues, however.
Edited by Veninrir on 6/6/2013 8:17 PM PDT
Reply Quote
90 Tauren Shaman
12665
what about for those of us like me? i killed the browser proxy.. and it didnt do a thing! ive been logging in with 100 home and like 30k world ms... i ran an internet speed test, and im not lagging. my net is running as fast as always, but ever since 5.3 i cant seem to do anything in game other than chat! what is this?!
Reply Quote
90 Blood Elf Priest
12685
i just found this crap running this makes so much sense as to why my wow bottoms out randomly. thanks blizz!
Reply Quote
87 Worgen Druid
10570
yep wow browser proxy is a pain. I would recommend getting rid of it.. as soon as ive finished reinstalling my game ( from a launcher issue which was resolved by unchecking ALL of the compat settings for the game on my os game works fine now..) the proxy has a tendency to run at the weirdest times and Blizz.. unless YOU guys were the ones to launch this on us.. then i'll forgo the use of it . I never did trust it.. and think it should never have been allowed in the first place . so. soon as my installs finished. that damn proxy is goners. marked for deletion and barred forevermore from my comp its redundant and I feel it just takes up extra bandwith that not all of us can spare. I COULD be wrong..but somehow I don't think so. my game was fine until the wowproxy started up and then ..well... no small wonder i'm deleting it!
Reply Quote
90 Human Hunter
6855
had the same problem, latency got me killed in arena a few times, made a bat file to end the process, now I'm going to delete it, thanks for infos
Reply Quote
90 Blood Elf Paladin
7100
same here >.< severe lag when it runs...
Reply Quote
90 Night Elf Warrior
10500
i have the same problem, when i log with one of my character a windows appear saying me that a wowbrowserproxy.exe error or something like that. what i had to do???,
When u said, kill the wowbrowserproxy.exe u refer to delate it ?
thank you.
Reply Quote
Support Forum Agent
Mizore

There is a bug that is affecting the WoW Browser. The bug is being looked into, but there is a workaround that you can use for now. Go into the World of Warcraft folder and delete the Utils folder, and you should have no more errors show up.
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback? https://www.surveymonkey.com/s/Dankorii
Reply Quote
90 Gnome Rogue
14080
But what exactly is it? Saying that it's a "support browser" doesn't really tell me anything. What does it do (in English) and why is it needed?
Edited by Jawaka on 8/11/2013 6:05 PM PDT
Reply Quote
MVP - Technical Support
90 Draenei Mage
6490
In game browser accessible from the "?" icon on your button bar that only lets you use the support site in game.
Reply Quote
90 Gnome Rogue
14080
I guess I just fail at understanding why I need this Blizzard Browser which appears to be always running and eating system resources in the background over my existing browser which I can start and stop as I wish.
Reply Quote
i stopped it and got rid of my utils folder so i should be ok with that happening no more right?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]