That Elegon fight...

Mac model aside — it does not matter what model of Mac I use, I have tried four of them, two iMacs, the Mac Pro tower, and a Mac mini, all 2010 models or newer.

In 5.2, the Elegon fight was smooth, everything flowed easily, and I could run it on medium without a hiccup.

In 5.3, when standing on the celestial platform (when your body turns into a celestial pattern), the whole damn screen stutters, even on absolute LOWEST settings. I'm lucky to get 4fps. It's virtually unplayable.

Anyone else have this issue? It's extremely annoying. I do not know if this was brought up or not, but I'm not going to search the forums and necro a topic just for this.
Reply Quote
90 Draenei Shaman
17740
It's not your computer. Every patch they either fix the area so it's smooth or revert something and it goes to absolute hell.
Reply Quote
Makes sense. Thanks.
Reply Quote
90 Draenei Shaman
17740
And to clarify, it also happens to me and a ton of other people. As far as I know this is something that is being experienced by Windows users as well.
Edited by Jooki on 6/20/2013 4:48 PM PDT
Reply Quote
Now that's interesting... I can only imagine that Blizz knows about this, but the engineering behind the programming must be a train wreck or something.

I wish I knew what to do.
Reply Quote
MVP - Technical Support
90 Human Warrior
18580
they do know about it, there are also numerous threads on it already including the easy work around. Set your shadows to fair, and problem is gone. very few macs should actually have any performance gain playing with blop shadows. The oldest of imacs with ati x1600 are about only ones that are stuck with this problem. Anyone else should be able to set shadows to fair and play on.

blob shadows on platforms cause severe lag. This lag will happen on chogal, elegon, primordius, or anywhere else with a removable floor.
Reply Quote
Thanks, Omegal. I believe I do have my shadows set to fair or less, but I'll double check to be certain.
Reply Quote
90 Draenei Shaman
17740
they do know about it, there are also numerous threads on it already including the easy work around. Set your shadows to fair, and problem is gone. very few macs should actually have any performance gain playing with blop shadows. The oldest of imacs with ati x1600 are about only ones that are stuck with this problem. Anyone else should be able to set shadows to fair and play on.

blob shadows on platforms cause severe lag. This lag will happen on chogal, elegon, primordius, or anywhere else with a removable floor.


So for clarification, this Elegon issue happens when shadows are on too low of a setting (blop shadows) and a temp fix is to actually raise shadow quality for the encounter (even though reducing shadow quality would otherwise generally raise performance)?
Edited by Jooki on 6/20/2013 6:00 PM PDT
Reply Quote
MVP - Technical Support
90 Human Warrior
18580
Yes. and actual the performance diff between blob and fair is so minor there is really just not much reason to use blob. fair only generates dynamic shadows under players near you. most vid cards can do this without really choking on it. except for the lowest of macs. you just need to avoid the "low" shadows setting at all costs in near platforms/elevators
Edited by Omegal on 6/21/2013 12:20 PM PDT
Reply Quote
Interesting. Thanks for your help, guys.
Reply Quote
90 Goblin Shaman
5250
I was having a great deal of problem with this FPS drop, like a 50FPS drop, and followed this advice and went to fair shadows and my FPS is back up.

Thank you Omegal for the tip
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]