One of My Spells stopped working

90 Human Paladin
4575
Hello there, I've never had this issue before so I'm not too sure how to explain it...Yesterday my Judgment Cast for my Paladin was working fine; today when I logged on the tab is grey, as if it were an unusable item on my action bar. I tried resetting my class, switching from my alt class specialization then back again, I've tried exiting the game then re-logging on, oh, and dragging the spell from the talent list back down to the action-bar does not help. I'm out of ideas and a little irritated at this sudden problem.
Reply Quote
85 Undead Warlock
13445
Make sure one of your seals is active. Judgement requires an active seal to be useable.
Reply Quote
MVP - World of Warcraft
100 Blood Elf Hunter
13090
Judgement requires a seal to be active before you can use it. Check your seal bar and make sure one is turned on. :)
Edited by Cerylia on 7/4/2013 11:49 AM PDT
Reply Quote
90 Human Paladin
7315
switching from my alt class specialization then back again


Whenever you swap specs, your seal goes inactive (so you won't be able to use judgement, it will look greyed out), so any time you change your spec, you'll have to click on whichever seal you'd like to use.
Reply Quote
90 Blood Elf Paladin
7570
You are now officially a paladin. Welcome to the club.

I STILL derp this, usually during arenas!
Reply Quote
90 Human Paladin
5930
Been there...I feel much better after reading its happened to others lol
Reply Quote
100 Human Paladin
17035
Swapping glyphs/talents does the same thing. Very annoying.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]