Sent 2 emails, and no response?

85 Gnome Priest
5785
I have sent around 2 emails in the past few months and NONE of them got a response; not even a macro that closes the ticket. It seems to me that my email adress was ignored or something because I am having lag issues with the game, that makes my MS go up to 350 which makes it unplayable for PvP.


I followed instructions and sent them a packet reports according to FAQ but it's been 3 days now and there isn't even a message about it was sent.
Reply Quote
87 Blood Elf Death Knight
13690
To which email address did you send it to?
Reply Quote
87 Blood Elf Death Knight
13690
- By E-mail: Blizzard's Technical Support team provides a Web Form for you to fill out which collects most of the information necessary to quickly and efficiently provide you with a solution. Email support is also available at wowtech@blizzard.com as an alternative to the web form. Mac users can contact our Mac specialists for support at macsupport@blizzard.com.

- By Phone: 1-949-955-1382 to speak to a live representative 7AM – 8PM Pacific Time, 7-Day Support. This form of support is offered at no cost to you from Blizzard Entertainment, though long-distance charges from your phone company may still apply. This same number also offers automated support for hours outside of standard operating times.

- By Forum: Our Technical Support Forum is moderated by members of our Technical Support Department 7AM – 8PM Pacific Time, 7-Day Support.


forumtech@blizzard.com doesn't seem to be a valid email address.
Reply Quote
87 Blood Elf Death Knight
13690
Ah, now I got it.

Emails sent to those addresses aren't guaranteed a response.
Reply Quote
Blizzard Employee
Forumtech@blizzard.com is a valid address, Deyadissa. Unfortunately that address is to be used if a tech rep specifically asks you to send in additional information regarding an unreslved issue.

I went ahead and forwarded the e-mail to a technical support representative and they will e-mail you directly. Keep an eye on your inbox. =)

=============================================================
Representante de Servicio al Cliente/CSF Rep.
Saving the World of Warcraft one forum post at a time!
http://twitter.com/BlizzardCS_ES
Reply Quote
Blizzard Employee
There will be no automated message sent, Deyadissa. Unfortunately I am not sure what happened, however you should receive a reply shortly. Please follow the steps provided and send back any information requested by the Technical Support representative.
________________________________________________
Representante de Servicio al Cliente/CSF Rep.
Saving the World of Warcraft one forum post at a time!
http://twitter.com/BlizzardCS
http://twitter.com/BlizzardCS_ES
Reply Quote
85 Troll Shaman
9775
I am having lag issues with the game, that makes my MS go up to 350 which makes it unplayable for PvP..


Are you using windows 7?

http://lifeandcode.net/2009/05/reduce-game-network-latency-in-windows-7-or-vista/

this link might help you
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]