Black login screen

85 Troll Druid
6620
I cannot login to my name with Firefox. I've updated ALL firefox addons (java etc..)

But for some reason when I press login, I get a small black blank box that I can't click or do anything with.

I'm posting this using internet explorer.
Reply Quote
89 Night Elf Druid
8635
I'm not sure if this helps any, but I'm posting this from firefox with no problems.

-Mavenore
Reply Quote
80 Troll Shaman
0
I have the same issue. I am able to log in by opening the Battle.net login in a separate tab. I have uninstalled and reinstalled Firefox, disabled all addons, and downloaded the latest version of Java. My friend who runs Firefox is able to see the pop-up login with no problems though.

I suspect it may be a firewall or router issue but I've not been able to track it down.
Reply Quote
85 Blood Elf Paladin
7605
Probably not either of those. The 'black box' is javascript, you might want to check the security settings relating to javascript or see if you've got an addon that blocks javascript actions.
Reply Quote
Javascript is enabled and the problem persists even if I uninstall or disable NoScript. My friend runs an identical software setup for Firefox and has zero problems with the login pop-up. It works fine in IE, but I'd not use the forums at all if I was required to run IE or Chrome.
Reply Quote
85 Blood Elf Paladin
7605
well they've probably (haven't taken the time to look) got a noscript there to redirect you if you're not allowing javascript. The fact that disabling it, logging in, and re-enabling it works, means it very likely IS a problem with some kind of javascript interception. A lot of plugins do that now by default. Including antivirus safe browsing plugins. might check those as well, and only click that box with it disabled (if you're using one) to see if that is your culprit.
Reply Quote
Blizzard Employee
Hi, all. We're investigating why some people can't see the login pop-up box, but what will help us is the following information:
  • What version of what browser are you using when you see the black login box?
  • Do you have any ad or popup blockers active?
  • Do you have any anti-virus software running?
  • Are there any JavaScript or security-related errors? (You can find this information in Firefox under Tools > Error Console > Errors)

In the meantime, you can log in by middle-clicking on the "log in" link or right clicking on the "log in" link and selecting "Open Link in New Tab".
Edited by Dvd on 11/6/2010 2:19 PM PDT
Reply Quote
Blizzard Employee
Hi, Swiftbane. I was able to reproduce the problem when I had AVG Internet Security 2011 anti-virus software running. Try configuring your anti-virus software exclude "battle.net" from web protection. If that doesn't solve the problem, you can try temporarily disabling the "Online Shield" functionality or all anti-viral programs to confirm if that's causing the problem.

We'll look into taking steps to automatically detect when the login pop-up fails to load and send users to the full login page instead.
Reply Quote
85 Blood Elf Paladin
7605
I re-enabled avg web security to test, adding it to the exclude list did work:

Advanced AVG Settings
Online Shield
Web Protection
Exclude host/IP/domain
Type us.battle.net in the box

There ya go, it should work after that. I'd post up screenshots, but I'm on my mac updating my client.
Reply Quote
85 Blood Elf Paladin
7605
Well, if you end AVG process with the task manager, the background service will just restart them (they're labeled SVChost.exe in the task manager). DO NOT try to stop svchost or your computer will just forcibly shut down. Not really an expert on windows services, but I know in XP, you had to right click on My Computer, Click Manage and then stop the service that way. Not sure how it works in Vista and 7.

The above instructions are the best way to fix the login box. On my mac, it takes about 4-5 seconds to load, so don't think it doesn't work because it doesn't work immediately.

Sorry I couldn't be more helpful. I'm a linux admin in the real world, so the workings of Windows is one of those things that only makes sense in the few occasions where its required.
Reply Quote
I'm having the same problem on my computer. Started about a week ago. I disabled all of my pop-up blockers, firewall, and virus protection software and I'm still having the same problem on Firefox. I even reset the cache.
Reply Quote
85 Worgen Rogue
7595
How I resolved this issue was to click on create a new account. A separate tab opened up to go to the creation page. Instead it gave me a security certificate error page. I added that certificate to the exception rules and then tested the log in again. Now it works fine.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]