Mac Technical Support

Feb 1 Cant install anything on MacOS 10.14.1 Im currently having trouble downloading Hearthstone or the Battle.net client onto my mac. I get this message everytime. "The application “Battle.net-Setup” can’t be opened." I tried to open the zip file with both winzip and unarchiver and neither of them worked.Chippington1 Feb 1
Jan 27 (Warcraft 3) game freeze after loading some custom maps As the title says, ive been playing with many mac computers, different settings, yosemite, el capitan, high sierra system, and whenever i play a custom game with friends with 4+ players the game just suddenly drops after loading, this happens to a random player each time (using the same map), even tried to se if it happened on windows (had 0 issues). After 1st player drops for the other players then someone else (mac user) get the freeze, until everyon has to drop but 1 or 2 players. Tried playing with video settings, LAN settings, but this only happens on certain custom maps (the bigger the map its easier this issue to happen). If i play the same map with the issue but with 3 players no one freeze. Sry for my bad english but i hope you can understand most of the issue im having Tested on macbook pro 2011, 2012, imac 2017, imac pro, etc. (computer store so not hard to test but many clients been asking for this game too)Leslita1 Jan 27
Jan 27 Bug Report: MacOS Night Shift and SC:R. OK - This is a WEIRD one... First, I'm on a Hackintosh, so I will list my Hardware Specs: [Hackintosh - Andromeda: Profile - iMac 18,3, 5K 27" Retina Display.] i7 7700K @ 4.2GHz Quad Core, 8 Threads CPU with Integrated HD-630 GPU. (GPU Disabled in BIOS) CoolerMaster Hyper212 EVO CPU Cooler cemented with Arctic MX-4 Gigabyte GA-H270-HD3 Motherboard 32GB Corsair Vengeance CL-14 DDR4 RAM at 2400MHz - Dual Channel (4 x 8GB Sticks) One Fenvi FV-T919 WiFi AC & Bluetooth 4, PCI-e x1 Card One Lite-On ATAPI DVD-Burner One Silverstone FS303B, 3-Bay Hot Swap Bay Two Samsung 860 Pro 1TB SSDs: One for MacOS High Sierra, APFS Format, - 17G5019. One for Windows 7 Pro SP-1 x64. One Western Digital Black 2TB SATA Hard Drive: One 1TB Partition - Games. One 1TB Partition - MacOS Time Machine. (Both Partitions HFS + MacOS Extended Journaled Format.) One MacVidCards' GTX-1070 8GB GDDR5 VRAM GPU One EVGA GTX-1050 2GB GDDR5 VRAM GPU One Corsair HX750i Platinum Rated 750W ATX Modular PSU One Rosewill E-ATX Case - 5 Cooling Fans all 140mm: 2 Front, 2 Top, 1 Upper Rear One ASUS VE278 27" 1920x1080 LED/LCD Monitor connected to GTX-1070 via HDMI One MacAlly ACEBTKey Bluetooth Keyboard One Logitech M510 USB-Wireless Mouse One Logitech USB Microphone One SabreNT USB Audio Device One Set Altec Lansing ACS-45 2.1 Speaker Set: 2 4" Satellites and 1 Subwoofer One 10-Port USB-3.0 Powered Hub One Logitech EXTREME 3D PRO USB Joystick (I think that's everything...) I've had the System running since December 27th, BUT, have been spending the last month restoring Software/Data from backups, installing all Software Packages, tweaking and streamlining the System. It wasn't until the last two weeks that I've been able to really get back into my Games. In High Sierra, I noticed something, (a feature), that my original Hackintosh, and even my real cMP 5,1 DID NOT have access to... "Night Shift"... I thought, "...well this could be a good thing....", so I turned it on. I noticed that at night it 'softened' the brightness and modified the colors of the Display to be 'easier' on the eyes. I really liked the feature. In the last week, I got to play StarCraft:Remastered THREE times! I noticed that EVERY time I played StarCraft:Remastered that I got 'Screen Flickering' FIERCELY!!! BUT ONLY in StarCraft:Remastered!!! It happened again tonight, (of course, right after sunset), so, I Saved my Game exited the Game, and started diagnosing the issue. This DOES NOT happen on the Desktop, in FireFox, in other Software Packages, OR EVEN in Battle.net App. So, I decided to try another Game - I launched StarCraft II. To my surprise and delight I found that this mad Flickering DOES NOT happen in SCII. SO, what was the issue??? This meant that it was Game Specific to JUST SC:R... It hit me tonight!!! "TURN OFF 'Night Shift'!!!" Once I turned off "Night Shift" the problem CEASED! (Sorry for all the 'Long Winded-ness of this, but I wanted to give the Blizzard Dev Team as much info as I could, AND to be able to help ANYONE else that's noticed this, but were afraid to Post about it...) So, is this a MacOS Bug, a Blizzard/SC:R Bug, or both??? I don't know, BUT this NEEDS to be addressed. I hope this helps others here. TLTimeLord041 Jan 27
Jan 18 D2 HS How's D2 on High Sierra 10.13.5? Is it still freezing/crashing?acidkiss2 Jan 18
Jan 15 Warcraft 3 Problems with Mac OSX 10.13.2 Hi, from time to time i used to enjoy some rounds of WC3 and WC3 TFT on my MacBook and was around march of this year where is was pretty happy with the game, supporting the native mac OS resolutions. Yesterday is started the Battlenet within WC3 TFT and was forces to install an Update. After the update was finished the migration of the profile data wouldn't work. After skipping this i mentioned the resolutions wasn't the native mac resolution and these wouldn't be able to choose anymore. As this wasn't sad enough every time i hit the "Battle.net"-Button in the main menu, the game instantly quits without any warning- or error-message. The OS im using is macOs High Sierra Version 10.13.2 and my WC3 /WC3 TFT Client is on version 1.28.5.7680. Are these Problems known and are there any hot fixes or workarounds? kind regards, ChrisGreenChris11 Jan 15
Jan 11 D2/LOD installer damaged I had D2 and LOD on my macbook pro 2 days ago and it worked. Yesterday i upgraded my OS to High Sierra 10.13.6 and now the installer is coming up as "damaged or incomplete" HELP PLEASE I MUST PLAYGoldenPants2 Jan 11
Jan 7 Warcraft III on MacBook Hey, I got W3 on my desktop computer, but I also want to play it on my macbook, is there a link to download it on mac? I`m on 11.1.2 OS X. I found on the web that it is possible, but I haven`t found a link to download.Tuân0 Jan 7
Jan 4 Missing OpenGL on MacOS High Sierra! OK - I got a new Hackintosh up and running. It thinks it's an iMac 18,3 27" 5K Retina Display System. [Specifications:] i7 7700K @ 4.2GHz with Integrated Intel HD-630 - (Disabled the HD-630) CoolerMaster Hyper212 EVO cemented with Arctic MX-4 Paste 32GB Corsair Vengeance DDR4-CL14 2400MHz RAM Gigabyte GA-H270-HD3 MOBO Lite-On ATAPI DVD-Burner Silverstone FS303B 3-Bay Hot Swap Bay Two Samsung 860 Pro 1TB SSDs - One for MacOS, One for Windows 7 Pro x64 One Western Digital Black 2TB SATA Hard Drive - (One 1TB Partition for Games, One 1TB Partition for Time Machine.) One MacVidCards' GTX-1070 8GB GDDR5 VRAM GPU One EVGA GTX-1050 2GB GDDR5 VRAM GPU Fenvi FV-T919 WiFi AC & Bluetooth 4 PCI-e x1 Card - Works in both Windows and Mac Rosewill E-ATX Case - 5 140mm Case Fans Corsair HX750i Platinum 750 Watt PSU MacAlly ACEBTKeyboard - Full Size with 10-Key Altec Lansing ACS-45 - 2.1 Speaker System with Subwoofer Since I installed High Sierra clean onto the new Samsung 860 Pro 1TB SSD, MacOS converted, (on the fly), the drive to APFS! I believe this to be the trouble, here. After HOURS of getting all my software installed, I turned to installing Blizzard/Battle.net App and all my games to the Games' Partition of the Western Digital Drive. All installed perfectly. Unfortunately, my luck runs out here! No matter what game I try to run, (I have SC:R, SC II, Hearthstone, and Heroes of the Storm), I receive a "Missing OpenGL" Error Message from the Battle.net App. I also installed BOINC, (Berkeley Open Infrastructure Network(ed) Computing), App for my Number Crunching Projects. Found here in Event Log that OpenCL was MISSING, too!!! At this point, I chose to reinstall NVIDIA Web Driver 387.10.10.10.40.113, (as I'm on High Sierra 10.13.6 Sec. Upd. 2018-003), AND THIS fixed the missing OpenCL, BUT NOT the OpenGL... So, did the Conversion to APFS on the fly during the Clean OS Install strip OpenGL from being used here??? How do I get OpenGL running again???TimeLord042 Jan 4
Dec 28 Download stops with error code BLZBNTAGT000008A4 Battle net downloader will not download WOW. It downloads for 2-10 seconds and then stops. I get error code BLZBNTAGT000008A4 I have tried every method for Mac, including restarting the computer, and uninstalling battlement and wow and reinstalling. I have even deleted all battlement and blizzard related folders. This still does not work.Simpatico2 Dec 28
Dec 28 Mac Game freezes when switching to desktop Hi, Mac User (Mojae 10.14.1) Most the time when i switch to desktop the game "freezes" and i have to restart again. I read about deactivating Spotlight but that dosn't help. Some ideas? regards Paulperrostar1 Dec 28
Dec 28 Дестени 2 Когда будет поддержка для игр в Mac x ???? Дестени 2 не работает, когда будут ответы????Shakalby1 Dec 28
Dec 23 Warcraft 3 and the frozen throne! Cant find any ways to download warcraft 3 or the frozen throne from this site and anywhere else. I got the game cd`s but when the update is done from battle.net, i get the message to restart the game but, nothing happens. Gets a warning message that warcraft 3 is allready running... pls help me somehow! getting frustraded af!CaparZo1 Dec 23
Dec 16 Mac touch pad or mouse plugged in not working Mac touch pad or mouse plugged in not workingKillBill1 Dec 16
Dec 15 Battle.net Setup not working on macOS Mojave (Version 10.14) Hi all, I'm trying to reinstall the battle.net client since I wasn't able to install any games on the client. Now however I am not even able to install battle.net. The setup bar is stuck on about 2% and won't download more. Thanks for any help in advance, MarcusMarcus17 Dec 15
Dec 15 Battle.net App Crashing w/ Older CPUs Good evening everyone, We've recently found that there is an issue with the app crashing on computers with older CPU's. We are working on a fix for this but until everything is fixed up we do have a work around for games that are currently up to date. Some of the CPU's we have identified with this issue are listed below. CPUs manufactured before 2008 may also be affected. There are too many to list them all here but here are a few common ones we are seeing: Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz Intel(R) Xeon(R) CPU X5365 @ 3.00GHz Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHzWe are targeting to hotfix this as soon as possible, when the fix does come out it will require players to reinstall. We will update this thread letting you know when it's safe to reinstall.Joynueer3 Dec 15
Dec 13 WoW: An update is available, but the game is running bug. I'm running on a macOS High Sierra Version 10.13.6 All realms are incompatible. I closed the game, and it says Game is running. An update is available and will be applied when the game closes. I checked my options and noticed the Scan and Repair, Check for Updates, and Uninstall Game are all grayed out. Reset In-Game Options under Game Settings is also grayed out while other games such as Hearthstone are blue and clickable. I looked in my blizzard application support folder and the WoW no longer has a folder. Diablo 3, Heroes of the Storm etc. are still there. What steps should I take? I'm not sure how to uninstall and reinstall since the option is grayed out.Nethermore4 Dec 13
Dec 11 Real Mac Pro WOW Players and Mojave Just tried to Create this Thread, and NOTHING Posted!!! :-O Trying AGAIN!!! As I do NOT have a Lvl10 WOW Character, I am UNABLE to Post this in the WOW Forum. It has come to my attention that the built in WiFi and Bluetooth Cards that came with the 4,1 and 5,1 Mac Pros WILL be DISABLED if you Upgrade to Mojave! MacVidCards, (though out of stock), has a solution to this! They have a newer WiFi AC/Bluetooth Combo Card that is Mojave compatible! I am mentioning this now; because even if NVIDIA Drivers are released for Mojave, I'd hate to see Mac Pro Users upgrade to Mojave and lose their WiFi and Bluetooth capabilities. To me this is NOT a good trade-off. ymmv Good luck and best gaming! TLTimeLord041 Dec 11
Dec 6 Diablo 2 LoD on high sierra Please fix the installer for high sierra, I wanna play with my friends but I just can't install the game anymoreDUBFIRE5 Dec 6
Dec 1 Blizzard Battle.net app in macOS Mojave is blurry Images and text seem blurry on my 2018 MacBook Pro. Is there a fix to this because it makes things hard to read?Ocular4 Dec 1
Nov 30 Where are the warcraft 3 replays on mac? Hi guys, I've just returned to the game and wanted to share some replays with friends but I'm on a mac these days and I cannot find the replay folder. I've check library/application support but theres no war3 or blizz folder in there. I have show hidden files on. I've checked users/shared/blizzard/war3 but there's no replays in there. I've check applications/war3 but they aren't in there either. I've tried searching in finder for any .w3g (google tells me this is the replay file type) on my mac but nothing can be found. I've tried saving replays with specific names and then searching for them through finder but nothing there either. I've opened a support ticket but that didn't help either and it was suggested I ask these forums, I've tried reddit too.. My replays do save because I can watch them through the client I just cannot find the files. I don't want to have to bootcamp just for war3, any help would be very much appreciated. I'm running a 2018 MacBook Pro 10.14.1oots1 Nov 30
Nov 29 Insanely slow download of Blizzard Launcher I'm getting impossibly slow download speeds for the Launcher. Not in the launcher; I'm trying to download the launcher itself, from https://www.blizzard.com/en-us/apps/battle.net/desktop. I'm currently getting 37 bytes/sec. BYTES. I let the download run all night and it got to 1MB. This is not a problem with my system; other things from other places download fine. Stopping and restarting the download does not help, nor does restarting the computer. What's going on?Calion5 Nov 29
Nov 28 MacOS Sierra Purgeable Space not freeing up With the addition of Purgeable space on the new Sierra operating system, I am unable to install games due to "Insufficient disk space". The Mac forums and support files state that purgeable space will be automatically deleted when free space is needed. I currently have 15GB of "free space" and 35GB of "purgeable space" on my hard drive. I am trying to install the Diablo 3 PTR, which is 16GB, but I am unable to free up space by deleting old files, old applications, etc. because these items are moved to purgeable space NOT free space. It seems the Blizzard installer only looks at free space when calculating the available space for game installs. Is there another way to install the game which would force the MacOS to free up purgeable space?HoosierDaddy6 Nov 28
Nov 22 Can't download mac battle.net installer When I click on the links found on the following page (https://www.blizzard.com/en-us/apps/battle.net/desktop) for mac I am given a modal that lets me save as or cancel. When I click save as I can see the download start, however, it just continues to try and download without any resolution. The message below it is, "Unknown time left — 496kb (11.8KB/sec). Originally I assumed this was an issue with my specific machine so I went over to a friends house using the same link above and tried to download the battle.net app on his PC with the same results. I have tried: Refreshing my IP Deleting any old battle.net and blizzard game files Finding a direct download link (this worked with a link I found on Reddit, but not for the mac since it's an .EXE sadly). Restarting my machine Trying other locations on Blizzards website to download from. Horseman2 Nov 22
Nov 21 Battle.net stuck on 48% Hi, having trouble installing battle.net on Mojave I have read every thread and no solution is working, it will install to the 48% mark and stop. I have admin rights on the mac and have tried to reinstall countless times but it won't install. I have also tried making another user on the mac with root enabled and tried to install but still nothing. Thanksbigbastrd3 Nov 21
Nov 19 Battle net installation stops - no error message Hi, as the title suggests, I'm trying to install the Battle Net application on my iMac. However, as it's installing, it just stops at a random percentage (either 7 or 48 - depending on how lucky I get). It just stays there and doesn't move. I've disabled firewall, anti-virus software, and have no apps running in the background. I've deleted the Battle net cache and started again. Tried logging into root user, and deleting there. No luck :( Any help?grumpykitten4 Nov 19
Nov 18 "Play Diablo 2" screen shows up after installer and all it does is makes noise. I recently bought diablo 2 on my computer to play. I played for a few minutes but it crashed. Diablo 2 wouldn't open so I deleted it and tried to reinstall it. When I tried to use the installer to play diablo 2, it shows play diablo 2. I clicked it and all it does is make noise. Currently playing on a mac. Any advice to fix this?MegaComplex4 Nov 18
Nov 17 DESTINY 2 GIFT I accepted the Destiny 2 key and the game still isn't showing up in my library. I reinstalled the Battle.net app twice, I'm not sure what else to do...Weyland1 Nov 17
Nov 17 Diablo II won't install on MacOS 10.13 Hi there, I guess answer might be "Use it on Sierra and not High Sierra", but HS will be out next week, so I ask: is installer working for anyone here on MacOS ? I can just see Licence agreement, I agree and thats it - nothing more happened after this. When run from Terminal, it says D2-1.14b-Installer-enGB/Installer.app/Contents/MacOS/Installer --help/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8 /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist' /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8 /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist' any advice please? Thank you MartyZmartyz375 Nov 17
Nov 17 Warcraft 3 install stuck @ "Updating Warcraft 3" 69% I purchased WC3 today, downloaded the game client, and opened "Warcraft 3 Launcher". I was away from my computer for some time, and returned to find it stuck at 65%. After restarting the launcher a couple of times, the install progressed to 69%, but its been stuck there for several hours after several restarts. Please help!GwatMagnus17 Nov 17
Nov 16 Mic Issues There is a problem with battle.net recognizing my voice from my headset. I have been using the headset fine for years but suddenly I have an issue with it. It works fine in the OS settings as well as other apps such as audacity and Skype. After doing all the settings in the battle.net app I can't get anyone to hear me or any sound during the microphone test. My primary headset is the Corsair H2100 but I also tried another headset I have with the same results.Morgano4 Nov 16
Nov 16 MOUSE UNRESPONSIVE IN SCII - Have installed Mojave 10.14.1. Now when I open SCII, mouse becomes unresponsive. Logitech M510 wireless.Torpor3 Nov 16
Nov 16 Blizzard Battle.net stops at 53% Hi, I recently got a new Mac and I wanted to install the Blizzard. Desktop app. I deleted. all files of Blizzard and I tried to install the Desktop Client but then once it reaches 53% it just freezes completely. Please tell me how do I fix this issue? Also: I have changed my DNS to Google's DNS and I have turned off File Vault and the login credentials. I have also tried switching between networks and yet there is no change in this matter.DarkFire1 Nov 16
Nov 16 Blizzard app and file access Hi, is there a way to install the blizzard.app without giving it access to my entire file system? Why do you need root access? Why not only write to application support and preferences and the actual .app package? There is just no way I'm granting that permission.vMachiel0 Nov 16
Nov 14 Can't install/patch games The Battle-net app seems to be broken on Mac atm. I cannot install games, since it will just be stuck in the pop-up after hitting the install button. I've had WoW installed for a bit now and twice the Battle-net app wouldn't let me patch the game, saying it was waiting for another installation, but there was none. The first time I figured it was something with the Agent, so I quit the Agent through Activity Monitor, and reinstalled the app. This worked for a while, but as soon as a new patch came for WoW I was back to square one. I have since tried deleting the files in Mac HD -> Users -> Shared -> Battle.net & Blizzard and reinstalling the app, but it still won't work. Also quitting the app makes it hang and I have to force quit it. The app used to work flawlessly in the past, so I think a recent update has broken something, at least on Mac. Would love to hear if anyone has got it working somehow. R.Tkay7 Nov 14
Nov 12 Destiny 2 I got destiny 2 from battle.net but when i clicked claim nothing showed up in my games tab.Darius7 Nov 12
Nov 10 Blizzard App refusing to update or install Blizzard App refusing to update or install after following technical instructions listed on this site. This started shortly after the small patch following the destiny 2 announcement a couple weeks ago. I followed the instructions listed as far as deleting files, stopping processes and even deleting the battle.net folder (which can't be done because "agent" is running in the background, even though i've disabled every agent file and restarted multiple times). As of last night the app will not even install. The plus is that with the app uninstalled i can now actually open blizzard games from my applications folder where i couldn't before (strange). What's going on? This is going to cause a major issue with the patch that's guaranteed to come in Tuesday after this past week's content patch. Without the app i can't update wow. Here is a link to the thread i commented in last night with the exact error code. https://us.battle.net/forums/en/bnet/topic/20756905611?page=1Stik43 Nov 10
Nov 10 [bug] BDA unable to find any games I removed BDA, then downloaded BDA from the website, installed BDA and ran BDA. It would not find ANY blizzard games (d3, hs, sc2, wow, wow: ptr) when it scanned. The settings correctly show the default install directory as /Applications/Games , but BDA can not find any games when I click the scan button. I have quit BDA and force quit the crashed Agent process and tried again, multiple times, but still no games can be found when pressing the locate button. Mac OS X 10.9.5 BDA 1.2.1.5134 BDA installer 1.11.4.2368Rooster3 Nov 10
Nov 7 Blizzard Agent went to sleep. Attempting to wake it up... Constantly seeing this error in 10.14. Mojave. Never saw it before the update. No idea why.Llew2 Nov 7
Nov 4 Battle net app won't let me play games. I recently download heroes of storm and the battle net app so I could get the overwatch skins since I play on console. However the app won't let me play the game. All it shows me is the background and two squares in the top left corner. Clicking on the other games gives me the same thing except these have the title and something I can click to buy the game or learn more about the game. I have uninstalled and installed the app and still nothing. Anybody know what I need to do?Cnerr7 Nov 4
Nov 4 OSX Battle.net Launcher Installer fails to run I downloaded the installer and it failed to run, so I opened it in terminal and got the error LSOpenURLsWithRole() failed with error -10810 for the file /Users/brad/Desktop/Battle.net Beta Setup.app. I am running OSX Mountain lion 10.8.4 on a Macbook Pro 15" Retina Display Early 2013bradc65 Nov 4
Nov 3 Will destiny 2 be for mac Os Just saying will be im not sure overwatch was not for so will destiny 2 be for macNycrap993 Nov 3
Oct 27 Problem with Battle.net installation on MacOS High Sierra 10.13 Hi all, last evening I wanted to play some good old fashioned Diablo III, but after several tries I was not able at all to install the Battle.net app. The error given is telling me that there is another instance of the program running, but it is not true. Anyone here had the same issue as me? Thanks for any help given Please note that I tried installing both the standalone game client and the battle.net application, but the same error occurs in the two situation. In addition to that, I tried deleting all the Battle.net application folders but I still got the same error. My Mac is up-to-date with the latest OS version. Regardsilsologheo17 Oct 27
Oct 26 WoW won't install on MacOS High Sierra - Insufficient Storage Space The game file is 55GB and I have 138 GB available to use. And when I choose a file location, it says insufficient storage. I'm using a 2017 MacBook Pro 15-inch on High Sierra. Has anyone experienced this issue and have any work arounds or solutions?waesas3 Oct 26
Oct 26 Battle.net launcher won't open no message [SOLVED] So my battle.net launcher does not want to open, it just pops up on the taskbar and disappears right away. Tried updating my operating software but to no avail, getting real pissed atm. Since as far as I can find nobody has had this problem before. I also don't get any messages at all, it just pops up and vanishes right away.Hantapanda10 Oct 26
Oct 18 Connecting to Americas not europe For diablo 3 I am constandly beeing connected to the Americas servers, although all of my options are set to europe... I have deinstalled both the launcher and the game but nothing worked. Is there anyway to fix this?DonGeiloTIm1 Oct 18
Oct 17 Battle.net App doesn't start to install WoW.. I just bought World of Warcraft and wanted to install it right now, but the Battle.net App doesn't start to install it... When I hit the install button, there's just the little icon spinning in the corner of the window and nothing happens. Any solutions? I have a new MacBook Pro...Fortuna2 Oct 17
Oct 11 Setup can't open Hi, i downloaded hearthstone and when i open the setup app it displays an error saying that the app can't be open. tried several times, but it keeps showing upAloonis0 Oct 11
Oct 9 Battle.net Launcher not displaying properly on Mojave When I open the Battle.net Launcher, a window opens up without any buttons for switching games or hitting play. I do see, though, when I hover that the right-click context menus can still be opened (as if the buttons are there but just not displaying on the window). Anyone else? (Restarted and reinstalled)Invisabit13 Oct 9
Dec 16 macOS Mojave font issue Fonts in the Battle.Net Launcher are pixelated - as though being stretched - on Retina displays (assumedly, I don't have a non-Retina Mac to test on) on macOS Mojave. Compare the "Challenge Rifts" pane to other text on the window. https://i.imgur.com/pYiYErP.pngwubsylol2 Dec 16
Sep 30 MacOS X 14 - Blizzard Agent doesn't run It shows the reference to some port problems. But I have tested different internet connections and the error is not dependent on the connection. The error within the WoW Installer shows this reference: https://eu.battle.net/support/de/article/13495 But it doesn't help.Fireflame1 Sep 30