stuck on "updating Battle.net Agent"

Bug Report
Prev 1 3 4 5
I've had this trouble for a couple of weeks but i opened task manager close the battle net update agent and tryed several times to open battle net repeating the process ti'll i made it, but this night i've been trying to open it for 2 hours and after all this mad search i found that if u open your battle.net on or (C:) or (D:) (depends where u have it instaled and if u simply delete the Blizzard.error file the problem will stop and you will open the app no problem at all.. Hope this solves ur problem! and please blizz i dont spend more than 1000 € on the company in games to have this kind of problems and being unable to play when i want to! So start sorting ur !@#$ cause this trouble is a pain in %^-! Thank you and have a good work
Worst experience I have ever had.

Same problem here. Still no fix after searching the forums and trying out everything mentioned. Every other online game and installer works flawlessly but not this one.

Worst company and installer ever!

Years have gone by and they can't make this battlenet accessible.
Tried many of the recommended solutions in this thread. None worked until I first deleted everything in the Agent folder, then followed these instructions:

https://us.battle.net/support/en/article/6989

Make backups first!
C:\ProgramData\Battle.net\Agent

Delete battlenet.error

Worked a charm - straight to install.
12/05/2016 11:58 AMPosted by LabGecko
Tried many of the recommended solutions in this thread. None worked until I first deleted everything in the Agent folder, then followed these instructions:

https://us.battle.net/support/en/article/6989

Make backups first!


THIS. THIS IS THE FIX. IVE TRIED FIXING THIS FOR 3 DAYS AND YOU'VE DONE IT! PRAISE BE YOU!
Happens to me too, just comes up with blizzard error and never opens tried everything, contacted blizzard support. Nothing has changed.
Hi people, i had similar issues with this and fixed it just now by closing battle.net apps after they failed to get past updating stages. Then going into program data, deleting the two agent folders and opening the overwatch launcher. it seems to have worked for me, maybe it will for you?
Hello! I hope i can help some of you guys with this. I was having the same problem, I was having trouble even uninstalling cause my battlenet was not updated and would not update cause of the issue with it not even launching and staying on the client update screen. So after trying everything in my desperate attempt to get it to run so i can play world of warcraft i was looking through all my anti virus apps and found something that was irrelevant of antivirus. IOrbit Uninstaller. This is where i looked at the files and shredded, deleted, and redownloaded. Get IOrbit Uninstaller and find battlenet, then uninstall then scan and shred all files related to battlenet and any other blizzard game you are trying to launch. Next, reinstall battlenet and the game that you are trying to play. I hope that helped! If not then band up with other people and head to blizzard and riot until they fix the problem. :D
Last night my computer just had a series of errors, and nothing would run, no youtube no wow that sort of thing. Today I open up battle net to try and play wow and legion needs an update but it wont manually update, i follow the instructions in the error message link. Rename the folders as old, clear stuff that sort of thing , get up to the reinstall part and it is just a blue bar thats about 70% done saying updating battle.net. Would love to be able to load up any game
Same problem, tried everything. Deleted b.net folder, deleted registry keys, compability mode, secondary login is on, wired 100/100 connection w/ google dns, uninstalled antivirus, booted multiple times. I'm out of ideas now really...
Same problem, tried everything....


Same problem.
I had this problem several times now. I suspect that some circumstances corrupt some kind of cache.

Did these steps to resolve the issue:
- go to c:\users\all users\ and delete battle.net and blizzardEntertainment\battle.net
- go to %appdata% and delete battle.net directory
- press windows key + r and type regedit
-- go to HKEY_CURRENT_USER > SOFTWARE > Blizzard Entertainment and delete the entire directory

then reinstall battle.net to restore the corrupt files.
Let's start with some information from you if possible. Would it be possible for you to gather and send us a copy of your Battle.net Logs? It will help us to better understand the cause of the issue.
yep i feel the same pain yall are only for overwatch.. stuck on battle.net agent.
02/19/2017 04:14 AMPosted by BlackAnthrax
I had this problem several times now. I suspect that some circumstances corrupt some kind of cache.

Did these steps to resolve the issue:
- go to c:\users\all users\ and delete battle.net and blizzardEntertainment\battle.net
- go to %appdata% and delete battle.net directory
- press windows key + r and type regedit
-- go to HKEY_CURRENT_USER > SOFTWARE > Blizzard Entertainment and delete the entire directory

then reinstall battle.net to restore the corrupt files.


I did this and it worked! I had to look into all of my users and delete everything. I even went and deleted the registry key as directed.
07/01/2017 05:41 AMPosted by Godspeed
02/19/2017 04:14 AMPosted by BlackAnthrax
I had this problem several times now. I suspect that some circumstances corrupt some kind of cache.

Did these steps to resolve the issue:
- go to c:\users\all users\ and delete battle.net and blizzardEntertainment\battle.net
- go to %appdata% and delete battle.net directory
- press windows key + r and type regedit
-- go to HKEY_CURRENT_USER > SOFTWARE > Blizzard Entertainment and delete the entire directory

then reinstall battle.net to restore the corrupt files.


I did this and it worked! I had to look into all of my users and delete everything. I even went and deleted the registry key as directed.


will this delet all games?
I am having the same problem. The blizzard downloader is chewing up all of my bandwidth but is not progressing at all, even after hours of being left to use all the bandwidth it wants. I have uninstalled Blizzard, reinstalled it, tried copying my sons files who isn't having any problems, nothing is working. Don't ask me to send you my logs, because I don't know how to get them.

Join the Conversation

Return to Forum