Battle.net launcher not responding/agent crash

Mac Technical Support
I posted this in the Diablo 3 mac support forum but I am going to move the issue here because I did not find a resolution (going to copy paste it straight over)

The battle net launcher worked fine for me at the start and then one day while playing WoW I crashed and it has not worked for me since. At the time it would start up and crash, but since then I have uninstalled everything blizzard related, updated my computer completely, made sure permissions were set correctly, made sure all the files were in the right spot, checked my security(firewall) permissions, checked my wi-fi proxies, and repaired my disk permissions. As of now:
If I download and install the battle.net beta client alone it installs>allows me to type in login name and password>hit enter> blizzard icon moves then stops and freezes...... (except one case where I could type in the authenticator after a restart but then it stopped responding again)
If I reopen the installed client afterwords it just bounces then freezes before I see anything

**A tech support responded and asked me to elaborate further and I responded with this**

Before I did anything I followed every possible step given by other posts; and the general technical support area for these issues including permissions. I gave up for a week or so (having deleted battle.net launcher and just played WoW from the app itself) and decided to update Diablo 3 which was the update that wanted you to have the Battle.net beta launcher and so I arrived at the issue again. I read a post saying that deleting/uninstalling diablo and the launcher solved the problem.. so i proceeded to do so. After this did not work; I uninstalled the launcher, Diablo 3, Hearthstone, Starcraft 2, and World of Warcraft. Having uninstalled and deleted all remaining folders, I checked to make sure everything was updated and restarted my computer. With nothing blizzard related left on my computer I attempted to download and install the battle.net launcher; the first time it let me type in my username and password and proceeded to the authenticator... I typed in the authenticator key and it froze up *not responding*; in my activity monitor "Agent" shows not responding before the battle.net launcher. I force quit the application and attempt to re-open and it stops responding before any window pops up; only opening if I uninstall and reinstall and only for the one time before not opening again. I gave up afterwords deleting everything and installing WoW and now I have no other games ;_; because the site requires you to use the launcher.
I have this very same problem on my windows 10 pc. The only difference is that I can launch the Battle.net launcher and have about 3 seconds to select and start a game from the menu before it crashes. I was recently logged out from the client and now can't get back in because it crashes before even displaying the window to enter my authentication code.

Join the Conversation

Return to Forum