Diablo 2 Not running UNHANDLED EXCEPTION: ACCESS_VIOLATION (C0000005)

Support
Hi I've been trying to get d2 to work but when I try to start it up It goes fullscreen and then gives me this error (I never reach the menu) I tried compatibility mode and it gave me
"Error 1: Diablo II is unable to proceed. Please run D2VidTst and try again."
When I try to run d2vidtst it looks as if it's going to load but then stops and nothing happens
I tried sending blizzard a support ticket but every form of support is giving me an error for some reason :(
I have the same problem! Please help us!
Does your vid test run? mine refuses to and I haven't found anything to fix it :(
Norferzlo,

Right click on the game shortcut and go to properties. In the target line, add -w after the ". It should look similar to this:
...\Diablo II.exe" -w

This will start the game in a window. See if that resolves the error.

______________________________
Monday - Friday, 7am - 4pm Pacific Time
Rate me! Click here!
Ok so diablo is running now but it is in a small window how can I make it run fullscreen? Also d2vidtst still doesn't run

edit: Ok so I connected to bnet it patched the game and d2vidtst runs now I changed it from the 3d option to 2d and it loads up fullscreen now though my second monitor everything is shoved to the right is there a way to fix that? thanks a bunch :)
Norferzlo,

When run in Full screen the game needs to resize the resolution of the monitor. This will push things around on the desktop, as you see on the second monitor.

Since Diablo 2 has only two resolution settings, there isn't any way to avoid this besides running in a window.

______________________________
Monday - Friday, 7am - 4pm Pacific Time
Rate me! Click here!
ah ok thanks for the help :)
First, thank you so much for answering this -- my game is running fine now.

However, my laptop cannot be set to a resolution of the appropriate aspect ration, so although the game itself runs perfectly well, there are margins of desktop on either side of the game window which allows my cursor to leave the game. Do you know of a way to lock the cursor to the game window?

EDIT: After running the video test and switching to 2D, the game will start in fullscreen -- however, it takes nearly 5 minutes to do so, slowly cycling through several dozen text characters one at a time in a small black box in the upper left of the screen before launching.
Thedurka,

There aren't any in-game options for locking the cursor to the game screen when it's run in windowed mode.

You can however add another tag command that will let the screen "stretch to fit". Personally, I'm not a fan of how it looks but perhaps it will suit you.

All you need to do is add -nofixaspect to the line you added the -w to above.

Your finished target line would then look like this:

...\Diablo II.exe" -w -nofixaspect

_________________________________________________________
I'm available in the forums Tuesday - Friday, 11 am - 8 pm Pacific Time
Saturday 10 am - 7 pm Pacific Time
Feedback? - https://www.surveymonkey.com/s/Omrakos
Alright, thanks for the help! And thanks for still offering support for such an old game -- you guys (and gals) are awesome!
Thedurka,

Just noticed your edit above:

EDIT: After running the video test and switching to 2D, the game will start in fullscreen -- however, it takes nearly 5 minutes to do so, slowly cycling through several dozen text characters one at a time in a small black box in the upper left of the screen before launching.

This will be caused by having the disable Desktop Composition compatibility option enabled. (or disabled, I forget as it's been a while since it's come up)

Right click the desktop icon used for the game, select Properties, then open the Compatibility tab. Toggle it off if it's on and on if it's off.

_________________________________________________________
I'm available in the forums Tuesday - Friday, 11 am - 8 pm Pacific Time
Saturday 10 am - 7 pm Pacific Time
Feedback? - https://www.surveymonkey.com/s/Omrakos
I have the same problem but with no solution!. I've created the shortcut link with the -w option, also running as admin and tried any combination in the Compatibility tab. I've installed the 3dfx glide but i keep gettin the same error message.
hey guys... im facing the same problem! just played diablo 2 and it worked fine ....
then installed the "lord of destruction" part... and this error appears! :(
I've tried the solutions listed here allready .... nothing seems to work... any tips?
I just get a black border around the game in full-screen and it gets very dark when windowed. Other than that, it seems to work fine. Also the "-nofixaspect" doesn't seem to have any effect at all. I used that wrapper a long time ago and remember it being very nice, but unnecessary. I think I'll try it again. Maybe it'll do something wonderful.
BTW, I used both the digital downloads(1.12a) and patched them to 1.13d(LOD)
Yup, http://www.svenswrapper.de/english/downloads.html fixed everything. You can choose between all 3 just by running the video test. So, it can't hurt anything.
Thank you so very much man it did work
do the vido test and run it in 2D, worked for me full screen ;)
I am having the same problem. My computer will not allow me to add the -w after the target line. But, I have had this problem once before. The person at Blizzard had me download a downloader exe. for both Diablo II and LOD. They no longer work. Not sure what to do at this point. I have every Diablo made from the first one to the Reaper of Souls. Including Hellfire put out by Sierra/Sienna? I love this series and I really hate to think I will not be able to play these anymore. Any help at all would be greatly appreciated.

Join the Conversation

Return to Forum