Cannot Click on Battle.net App

Technical Support
Prev 1 3 4 5 8 Next
I sent in my logs, hope you guys at blizzard got them.
Somehow the issue has been fix for me ...

Pointer problems frequently happen to me with the Battle.Net app. Most often I could only click certain sections of the Battle.Net (i.e moving the game icons in the list to the left) and could not start any games. They happen usually around once or twice a week for the last few months. Usually restarting or clicking on the Battle.Net icon (bassicly finding the only icon of the app that was responsive) fixed it. It usually felt like my cursor was stuck in click mode in a certain region of the apps.

Tuesday, when I posted here and sent my log, none of the above worked but when I tryed to logging Friday, I had no issue and it is still working to date.

10/04/2014 07:11 AMPosted by TIZAR
I got it to work! But now my Hero list is gone? Do i have to start all over now?

The -launch thing is just an argument to pass in the command line (resolving as without launcher). It should not have any effect inside the game. If I were you I would check If I logged In same region I usually log on (the region appear just below the login icon). If it's not written "Region: The Americas", for example, you can switch region by going in option/account.

In either case, keep sending logs if you have the issue, no matter if the -launch workaround works for you or not.
Ive send my logs yesterday and they sent me back a new batlle.net app build to try. So far the new one is working great, exept for a window. But now i can play.

I dont know if the new battle.net app build can work for everyone but keep sending your logs so they can find a solution for everyone.

They are working hard to fix the bug. Im sure its going to be fix soon.
"7. in the properties window, add the following to the end of the "Target" box after the final quotation mark: -platform windows:verbose=3"

I get an error telling me this action is invalid.

Any updates on this situation?
Hey all,

From the logs we've received so far, it appears that windows is reporting that the mouse button 4 is pressed down (this is the back button on most mice). This is causing issues with our ability to recognize the mouse clicks.

I've come up with a partial solution but it doesn't seem to be working in all cases. I'm trying to work around the problem in a way works for all of the UI and doesn't cause other problems, but I don't know the source.

Here is my question for you:
Do you have any kind of mouse automation software installed?
Any kind of third party software that tampers with mouse buttons?

I'll continue to investigate but without knowing how this mouse button event is being triggered it'll be hard to come up with the correct fix.

Thanks!

Note: We'll be patching in this fix this week as well. This fix is only necessary until then if you're affected by this issue.
I'm using Razer's Synapse Framework for my Razer DeathAdder2013.

I wish you guys further luck on finding out what's causing this issue.
same as above, I'm using Razer's Synapse 2.0 Configuration for my Razer DeathAdder
Just uninstalled the Razer software and installed my logitech mouse and got some positive results on battle.net application. I can click on everything again.

I hope this narrows down the cause of this problem.

I'll check back later if there's any solutions yet for Razer so I can switch back to my Razer mouse again.
I 'm using CMstorm Sentinel Advance II, even with or without his application i still have the issue.

Besides, i can say i have played this morning(hearthstone), but after a break i was facing the same problem.
Hello everybody,

I've put together a build that should fix this problem. Please download version 1.2.0.5133 of Battle.net from this link here.

Extract this zip file into your Battle.net installation directory (default c:\program files (x86)\Battle.net" such that you have the Battle.net.5133 folder next to other Battle.net.xxxx numbered folders.

After you have done this, start Battle.net up, and click around. Please let me know if you're still encountering issue after this.

Thanks.


Got it to work.

Thanks!
HOLY !@#$ THANK YOU.
Yes! It worked. Thank you.
i have been trying to fix this same problem freezes up on battle net page. I cant click on play it is frozen. I have tried everything I can think of nothing fixes it. please help us all! Thanks!
Wow, it seems to work. Thank you.
Thanks 5133 build fixed it for me (razor mouse again).

Note : i had to launch the battle.net from within the 5133 folder , i initially tried my desktop icons but of course they were not updated. and point to the broken version.
Confirmed working with the new folder!

Thank you so much!
It works!!!! Thank you so much
Thanks so much!
yeah it works thanks a lot

Join the Conversation

Return to Forum