White Screen Issue [UPDATED]

Technical Support
Hello,

For some it might have been obvious, was not for me:
$ LIBGL_ALWAYS_SOFTWARE=1 wine ~/.wine/drive_c/Program\ Files\ \(x86\)/Battle.net/Battle.net.exe

Battlenet is visible now, Hearthstone launched, stuck on welcome screen with some utilities missing - reinstalling it now.

What I've noticed is that graphic performance is extremely low right now, as mentioned welcome screen is pixelated & low fps? - based on TMMs post, I've grasped the idea behind LIBGL command. Bit ashamed as of now ;)

What caught my eye is:
err:module:import_dll Library Qt5Svg.dll (which is needed by
L"C:\\Program Files
(x86)\\Battle.net\\Battle.net.5134\\imageformats\\qsvg.dll") not found

// EDIT: Downloaded Qt5Svg.dll from web, pasted in some random locations, seems like it's been loaded, but hs still stuck.

Any ideas? Also, quite nooby question, how can I ulpoad the full log here without destroying the page? :D

I think we might be getting somewhere, thank You very much Wolfje!
Thank You TMM!

// EDIT 2 - Launching HS without the LIBGL command brings up black battle.net & HS client, but still some utilities missing - performance is back to normal. Executed the HS from terminal to see if anything pops out, but reading that log is way over my current knowledge.

// EDIT 3 - Libs pasted as suggested below, Battle.net client is still black. HS utilities not found. Log does not suggest any readable solution for me.

Cheers!
There is more than one issue here:

  • It appears that Blizzard may have made some mistakes when packaging/deploying a QtQuick 2 application for Windows, forgetting to include Qt5Svg.dll (as OneUp mentioned) as well as any libraries their build of Qt5Svg might depend on.

    By copying Fedora's (mingw32) builds of Qt5Svg.dll, zlib1.dll. libstdc++-6.dll and libgcc_s_sjlj-1.dll into Battle.net.5134/, I was able to run the Battle.net client using Radeon graphics on a Linux/wine/mesa stack. (As a convenience, I've mirrored these files at http://tomasm.tk/qt5winfix/.) Blizzard uses msvc builds of Qt libs for their launcher, which don't require libstdc++-6.dll or libgcc_s_sjlj-1.dll; you can probably remove those files following whichever Battle.net update resolves this issue.
     
  • Intel IGP drivers (Windows AND Linux) choking on ANGLE conversions or the Qt5 scene graph. This is more likely to be an Intel driver or ANGLE problem than any fault on Blizzard's (or Qt's) end. (Wine users: note that the launcher UI effectively ends up doing OpenGL(ES)→DirectX→OpenGL on your systems ☹.)

    As Wolfje suggested, you can try forcing software rendering for the launcher only - or run once to see where the 'launch' button for your game is located, then blindly click on that area with software rendering disabled.

In the event that there is a problem with the launcher, or a decision is made to add a workaround for certain systems, I'm keen to see how Blizzard deploys any relevant updates.
As a further note, if you have Intel IGP and you run battle.net launcher with LIBGL_ALWAYS_SOFTWARE, do not run games from within battle.net! For games to run with 3D acceleration, they need to be launched separately from battle.net. LIBGL_ALWAYS_SOFTWARE will propagate through all launched sub-programs from the program you define it in.

You can leave battle.net chilling in the background, just make sure that you launch the games themselves separately by clicking on the icons, or from a terminal.
Just
LIBGL_ALWAYS_SOFTWARE=1 wine ~/.wine/drive_c/Program*/Battle.net/"Battle.net Launcher.exe"
Installing Ubuntu/wine/b.net for first time think everything went well however when i launch b.net app i see everything name friends list blaa blaa but soon as media loader in midle would usually load b.net disapers and i get a blizzard error box with some code... any answer pl keep in mind first time ubuntu user 3 days lol
CPU TYPE:
Intel® Core™ i5-4460 CPU @ 3.20GHz
CPU SPEED:
3.22 GHz
SYSTEM MEMORY:
8.54 GB
VIDEO CARD MODEL:
NVIDIA GeForce GTX 750 Ti
VIDEO CARD MEMORY:
4.21 GB
Edit: had wine 1.6 not 1.7 Solved
and how would I go about starting them seperately? because when I start by clicking the diablo3.exe or doing so within a terminal, it will just open Battlenet in the diablo 3 tab and would want me to click on play.. which somehow i have been unable to click blindly so far..
also when the battlenet app is already running I will still just get to the diablo 3 tab when starting the exe via clicking or terminal...

so far none of the posted solutions have done anything for me.

·linux sabayon 14.10
·VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV770 [Radeon HD 4870]
·CPU AMD A8 5600K (APU series, but graphics disabled in uefi) (I'm actually gonna try enabling it and using the APU outlet.. maybe there is a difference then)

EDIT:
changing my primary graphics adapter to the APU integrated graphics card which would be
·Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7560D]
and uses the proprietary drivers, did not help.
Same problem with the intel card here. I am using wine. I understand linux/wine is not supported but the game was working perfectly before the update of the launcher. If I try the launch the game directly, it goes to the launcher anyway, so I am stuck.
Same problem with Intel and strange angle glitchs
Im with the same problem. After that update, i was able to play Hearthstone, even with the battlenet client all black, i just needed to click on the Play button area.

Some days ago, i cant even play hearthstone that way. I can launch the battle.net client, but when i click the play button it doesnt launch the game. I noticed on ps -e that the hearthstone process is there, and if i click more times on play button, more processes hearthstone will show up.

i already switched the version of wine (i was on 1.6.2) but no luck.
There is also no way to launch Hearthstone separately. Will always to battle.net launcher.

Btw, is there a way i can run LIBGL_ALWAYS_SOFTWARE from playonlinux?

When using that command, my battle.net client shows up, but no game or option shows. Only the loading battle.net symbol, that goes nowhere.
I'm getting the white screen issue too.

LIBGL_ALWAYS_SOFTWARE causes it to either crash or gives a black screen.
I believe I'm experiencing the same issue.
I'm on debian/testing (kernel v.3.16-2-amd64). Running wine-1.6.2 in 32-bit mode

System specs:
CPU: Intel Core i7-2620M
GPU: Intel HD 3000
RAM: 8Gb

The screen of the battle.net launcher is not blank or white but a rather skewed image of the rendered interface. Looks like this: https://yadi.sk/i/VhzSD0ERcJNZz
The areas of the application, where the different buttons should be are clickable and I can see that the interface reacts on mouse hover when the cursor is over the area where the Games tab is for example.

The launcher is running fine if I switch to software rendering.
can you play at all? i click on Play button, but game is not launched.
Protection, I can play. I just have to click in the area where the start game button stands usually. For me it's just a rendering problem for the Battle.net launcher. I can live with it but it's annoying.
If you want this to get fixed in the Intel driver, feel free to throw in some cash to the bounty I created:

https://www.bountysource.com/issues/5642959-distorted-graphics-or-black-window-when-running-battle-net-app-on-intel-hardware-via-wine
10/15/2014 12:05 PMPosted by TMM
t appears that Blizzard may have made some mistakes when packaging/deploying a QtQuick 2 application for Windows, forgetting to include Qt5Svg.dll (as OneUp mentioned) as well as any libraries their build of Qt5Svg might depend on.


I suppose its because the qsvg.dll plugin was included in imageformats. Fortunately we aren't using any svg so all it really means is that the svg plugin will fail to load.

edit: New releases will include the missing Qt5Svg library.
This is all rather Interesting. I'm running Battle.Net and World of Warcraft on an Ubuntu laptop with CrossOver for Linux. The previous update (the last 5.x.x) was the beginning of my Battle.Net launcher going all distorted. I never got the white screen problem. I can move my mouse around the screen and based on what distorted image lights up, I can tell what game is ready to click. That doesn't work for the Play button, but I've got its location pretty much memorized. All my games play fine. The launcher "works" but it's a bit of a strain on the eyes.
Thanks for looking into this Vexis.

11/03/2014 08:52 AMPosted by Vexis
I suppose its because the qsvg.dll plugin was included in imageformats.

Where, how and when the Qt Quick runtime tries to load support libraries - versus where Qt's deployment tools decide to stick them, if they even pick them up - can be a right royal pain (except when they give me an excuse to play StarCraft). Thankfully, this is mostly fixed in later versions of Qt.

11/03/2014 08:52 AMPosted by Vexis
Fortunately we aren't using any svg so all it really means is that the svg plugin will fail to load.

edit: New releases will include the missing Qt5Svg library.

Glad to hear that. When the svg library failed to load, the launcher failed to display anything (black screen) on a few systems I tried it on. Presently, I've no idea why I didn't see the behaviour you described instead.

edit: fixed formatting mistakes and typo
Hello!

Have the same "white screen" problem on my Gentoo/linux. Integrated intel i5 - 3000 graphics.

The solution for me is the same: since I see no "Play" button, but I know where is it supposed to be, I just click this area and play.

However (FOR BLIZZARD GUYS HERE), the Hearthstone is supposed not only to be a nice game but also kind of a bait to trap players for DIII, WoW, SCII with shiny buttons in the B.net client, am I not correct?

When I have a white screen problem I don't see those buttons and you loose all the linux gamers (their number grows each day) untill you fix it!
I tried Wolfje's solution and now instead of a white screen I have a black screen and after some time Failed to create graphics context pops up.

LIBGL_ALWAYS_SOFTWARE=1 unfortunately doesn't work for me.

I have radeon HD8500 series and I use wine 1.7 on playonlinux. Please help

Join the Conversation

Return to Forum