Battlenet Launcher(and Blizzard games) won't run possible solution?

Bug Report
I've been having this problem for awhile. I've been looking through a bunch of forum threads regarding the launcher not running. Specifically with what I encountered is the launcher will not come up, nor does it show in the taskbar, but it does show up in task manager.

I found that I can sometimes run the launcher if I open it as soon as I log into my computer after a reboot.

I decided to try running it when it wouldn't work. While the process was present in task manager, I proceeded to end other processes one by one. The moment that I ended one of my Wacom tablet processes, the battlenet launcher opened.

As this is a pretty frustrating problem, I thought I'd share my experience and success in finding the problem. I haven't repeated this yet to confirm, but others with this issue might want to consider trying this. It was more painless than I'd anticipated. It also might be nice to have a list of programs that may be interfering with the launcher for other unfortunate folks to use.

I'll update this post when I figure exactly which tablet process solved the problem for me.

EDIT 10/29/2014:

So, after messing around a bit, it seems the Battlenet launcher will not show up until I have ALL of the following processes ended:

pen_tablet.exe
pen_touchuser.exe
wacom_tablet.exe
wacom_touchuser.exe
wacom_tabletuser.exe

This is kind of annoying since it forces me to reboot or otherwise locate these processes when I want to actually use my tablet. I don't know how these interfere with the launcher and obviously don't know which, the pen tablet processes or the launcher, is at fault in creating this interference. Anyway, I hope this helps somehow.
Hello Oraiatoxotis,

Excellent proactive approach! Thank you very much for this. That kind of information can go a long way to helping us track this down and get it fixed. Since you've managed to get your Desktop App both in and out of this state now we'd love to get some more information from you to take a look at what might be causing this.

Would it be possible for you to gather and send us a copy of your Battle.net Logs? It will help us to better understand the cause of the issue.

This may not result in an immediate fix for your individual issue, but it will go directly towards getting this sort of issue fixed in general. That being said, if we can find anything in your logs that will help us to better troubleshoot your issue, we will do so.

You can email those as a zip archive to this address: toolsupport@blizzard.com

Use this line for the subject: [Oraiatoxotis] [attlenet Launcher(and Blizzard games) won't run possible solution?] [15006381165]

Thanks!
Did you get a fix for this I am having the same problem.

Cheers

Riddare Kato
Thank you so much Oraiatoxotis for finding a solution for this, have been driving me crazy for months! But it really sucks to have to reset the computer each time I want to use my tablet.
I literally just resubmitted a ticket to resolve this issue and this fixed it.

To clarify: Wacom applications are directly interfering with the battle.net app. I uninstalled all my Wacom products via the control panel and the app popped up right as the uninstall finished.

ALSO: If you're having "access is denied" errors in trying to kill tablet processes, you must uninstall the tablet drivers.

thankyousomuchiloveyou
Also, another thing that may help -

In thinking about when the battle.net app problems started versus my tablet updates, it would seem that this started about the time I upgraded to a newer tablet (the Intuos CTH-480, if that matters)
I had just purchased the Intuos Pro (PTH - 651) earlier this year and suddenly had the battle.net issues. It didn't click until I had gotten around to doing more trial and error on getting the app to launch correctly. I discovered my wacom services were causing a problem and searched to see if it was common or if there were any fixes. I just wanted to go ahead and post here to say that I, too, am having this problem.

Hopefully we will get a fix on this sometime soon!

Thanks.
I just purchased an Intuos as well. I would have had no idea it was the tablet that caused my launcher to not open if I hadn't found this thread.

It is super weird that a wacom tablet would interfere with the battle launcher/games from opening.
Hello FoxTrix,

Would it be possible for you to gather and send us a copy of your Battle.net Logs by following the instructions on this page: http://battle.net/support/article/6662? It will help us to better understand the cause of the issue.

This may not result in an immediate fix for your individual issue, but it will go directly towards getting this sort of issue fixed in general. That being said, if we can find anything in your logs that will help us to better troubleshoot your issue, we will do so.

You can email those as a zip archive to this address: toolsupport@blizzard.com
Use this line for the subject: [FoxTrix] [Wacom Tablet Issue] [15006381165]

Thanks!
I have the exact same issue, wacom tablet interfering with battle net desktop app. it'd be nice if this got fixed.
same problem here, shut down my WtabletServicePro service and battle net started, it would be nice to get a solution since a sometimes play the ocassional HOTS game in between breaks at work and have to do a reboot afterwards, not practical.
So glad I found this after 1 month of frustration with my Wacom Tablet...... just started doing this as well and have tryed every bit of research/solutions/forums. Not worth it for me to disable all those things on my tablet for this..... I hope there is a fix soon cause I like the game...

cheers
This just started happening to me too. I just got a brand new $100 tablet and would like to not have to choose between overwatch and art lol. Any more permanent fixes yet?
There is a solution that helps me to open both wacom tablets and battle.net app

first go to run > services.msc > find wacom consumer or wacom professional service

Set up first the startup in manual and stopping the wacom service:

right click wacom service > properties > there is a drop down menu at the center that says startup type > change the automatic to manual > click OK button > right click wacom service > then click Stop (Don't close services.msc tab yet)

if you change the startup type of wacom service in services.msc during the startup of your OS the wacom will not startup and you will be able to open the battle.net app smoothly

When the battle.net app opened:

Go to services.msc again> find wacom service > right click > click Start > Open photoshop or drawing apps to see if the wacom tablet will work

I hope this procedure will help

Join the Conversation

Return to Forum