SOLVED : Can't INSTALL ALL blizzard Games OS X 10.11

Mac Technical Support
Marked As Solution
Hello,

If you can't install blizzard game, this is a simple solution for you.

Why can't i install games ?

1) Because, Blizzard don't support CASE SENSITIVE File System ( https://eu.battle.net/support/fr/article/configuration-minimale-requise-pour-world-of-warcraft )
2) Because you format your Hard Drive in Case Sensitive mode
FYI : It's more secure to have Case Sensitive File System

How can i fix the issue ?

You can create a dedicated partition in Case Sensitive mode
To do it, follow this steps :

1) Create a dedicated Partition
    a) Start Disk Utility ( located in /Application/Utilities/ )
    b) Select your hard drive
    c) Select "Partition"
    d) Add a partition ( click on "+" )
    e) Choose the size ( 15Go for D3, 2Go for HS, 6Go for HOTS, 21 for SC2, 30 for Wow ). In my case, i choosed 75Go
    f) Name the partition "Blizzard" for example
    g) DONT CHOOSE SENSITIVE
    h) Choose "Apply" and wait for the partition to be created


2) Make a link from "Blizzard" partition to your "Application" folder if you want

3) Download Ballet.net
    a) Install it on your new partition "Blizzard"


4) Launch Battle.net and Install Games on "Blizzard" partition
    a) When installing the games, choose the location "Blizzard"


Best Regards, Have Fun and Shame on Blizzard Developers who knows the issues from years and do nothing !

Ps : Make replies from time to time to put this post on the top to help others please
Still same issue! this is NOT THE SOLUTION!
Forgot step G) DONT CHOOSE CASE SENSITIVE
Shouldn't need to repartition my drive just to play a game
i created a second partition in Not case sensitive and tried to install it there and it doesn't work.

This is exactly how i tried to download and install Battle.net:

Firewall - off
Safari: allowing apps downloaded from field to Anywhere.
created second partition - (jurnaled) (so its NOT case sensitive)
delete the Battle.net and Blizzard folders from Users shared and everywhere else
stopped the Agent process
restarted the computer
connected directly to Fritzbox (exact same settings for old mac (Yosemite) where b.net works fine)
tried to run the installer app after i opened it with Unarchiver and also tried it with the default program.

....no luck
This issue is far from being resolved. I followed the steps quite diligently and still have yet to be able to set up battle net or download SC2 .
I tried everything and followed all steps it didn't work..but as soon as i tried to download it being in a different internet connection it did! even with every security settings on!
So just try it in a different house..at friends place where it works guys! hope it works for you
Same issue here (file system NOT in Case sensitive)... very disapointed with such a crappy answer. All my security settings are off and no luck.
Listen my Battle net app was working fine. Then I tried to download Overwatch, and it said I had to update the app first.

Tried that, got stuck at 12%. I figured I'd just reinstall the app. Now, when I try to reinstall it, I just get stuck at Updating Battle.net...

I can't even play any of the numerous games I have on my account.

Are you guys gonna fix that soon or are you gonna pay me back or what's the deal?

Seriously sick of those overcomplicated apps with heavy/bad coding.
Worked for me.... Thank you so much! After weeks of looking, I finally found the answer :-)
That is not a simple solution and it is not even a good solution. Don't give Blizzard room to ignore this with a "solution" like this. They need to up their game and design for Apple OS per Apple specifications.

Come on, a lot of Blizzard players are mac users and they brag about their great QA. This sucks.
I was having issues getting Diablo 3 to install in El Capitan. It would complain about not being able to run the application. I looked at the package contents and it looks like the executable flag was off on the actual installer file. Adding that permission via the terminal made everything work just fine.
I know a lot of people have critized this solution, but it works! First time. It was not hard.

However, Blizzard, really? Just fix this will you. Fair dinkum! It's lousy to have to do a work around to install a blizzard game on a Mac.
Doesn't work for me.. I open the Battle.net application, it pops up on the Dock and then just disappears. No, I did not select Case Sensitive, I chose Journaled.
The problem is not only where the app is installed... it's probably on file that the app uses that is called using the wrong (case sensitive) name. This file can be in your home catalog, in the Applications folder, in the OS folder, or in the game folder. Good luck finding out which file causes the problem. I installed a new OS on a case sensitive disk, no luck; and on a case insensitive disk, where it works once the permission problem described in every other thread is fixed.
For what it's worth, I wasn't able to install Battle.net either for a different issue.

This is random, but I was opening the battle.net setup ".zip" file using an extractor called "Keka"

When I opened it with OSX built-in "Archive Utility" it worked fine.

An alternative is running this on the *unzipped* file in the Terminal App

chmod -R a+x ~/Downloads/Battle.net-Setup

The -R is required.
I've read about 50 posts on this issue

I just bought a brand new iMac

First thing I did was try and install battle.net app
after about 20 minutes of loading this happened

https://us.battle.net/support/en/article/4100042

I was connected via wired internet.

I've read all these forum post and linked post and still nothing..any help?

Join the Conversation

Return to Forum