Battle.net Launcher Not showing up in the start menu on Windows 10

Bug Report
Same..
06/03/2016 04:38 PMPosted by CBRMitch

To clarify: Battle.net installed fine, runs fine, but is not indexed in any of Windows functions, so I cannot search on it. It does appear correctly in the Uninstall A Program control panel applet.


I can't find the .exe anywhere... I can't even uninstall it in the programs and features menu.
Same issue as well. Fresh Windows 10 Pro Build 1607.

Battlenet launches from taskbar as many have stated and it does provide a message saying "We've detected a newer version of Battle.net than the one you're attempting to launch. You may need to fix your shortcuts."

Nothing wrong with the shortcuts, install or version of Battle.net.
Same thing happened to me with my new Windows 10 laptop. I had to delete the whole Battle.net folder (moved my games out first), then reinstalled Battle.net running it as Administrator and leaving the shortcut box checked.

Fixed my shortcuts and shows up in programs/search now.
Partial Fix:
If you uninstall then reinstall the Battle.net desktop client, and in the installer check the "create a desktop shortcut for Battle.net" box, it will also now appear in the start menu (as well as creating a desktop shortcut).

This was tested on Windows 10 with anniversary update.
So it seems that you can just manually add the launcher to the Windows 10 Start menu.

I don't like to pin things to the start menu, because I find just searching for programs easier and faster with my laptop. That being said, the Battle.net launcher doesn't natively appear in the search results for Cortana. Here's a way to fix that.

So first things first: if you don't want to do all this, a simple workaround would be just to type in the names of the Battle.net games you want to play, and that'll just pull up the Battle.net launcher vicariously.

1. Navigate to C:\Program Files (x86)\Battle.net using your Windows Explorer.
2. Right click on the Battle.net launcher and create a shortcut.
3. Drag that shortcut to your desktop.
4a. Navigate to C:\ProgramData\Microsoft\Windows\Start Menu\Programs using Windows Explorer.
4b. If you don't want to do step 4a, you can also type in the name of a Battle.net game you have installed (like Overwatch or World of Warcraft) using Cortana, right click it and choose "Open file location." Then click the back button in the top left corner of the window that pops up.
5. Drag the shortcut you made in step 2 into that directory.

After all that, when you type Battle.net into the start menu, it will pop up with the launcher you can also rename the shortcut to whatever you want, and that will correspond with the search, so I had simply named my shortcut battle and now all I have to search with Cortana is "battle" and the launcher pops up.
Typing the name of any Blizzard game opens the Battle net app. They should have a name for it though, something like "Blizzard" if they are doing away with Battle.net. I don't type Fallout4 to open Steam for example, ha!
03/15/2016 06:06 AMPosted by Rathgor
OKAY EVERYONE

I got the answer for all of you boys and gals.

Navigate to your start menu folder (C:\Users\(YOUR USER NAME)\AppData\Roaming\Microsoft\Windows\Start Menu\Programs)
(You may need to enable the viewing of hidden files)

Right click in this folder and select "New" then select "Shortcut".

Navigate to your battle.net folder and Select "Battle.net Launcher.exe"

Click "Next"

Enter "Battle.Net"

DONE!


This worked for me!
Same problem here, need to restart my computer before I get the battle net launcher windows 10. This is very sad because it is also doing that if I need to get out of the game for some reason and need to restart wow so it is taking a long time before I can go on.

Are you close in fixing this problem?

The answer above me I can not do because I don't have that line....
09/19/2016 06:22 PMPosted by ClassiCorey
1. Navigate to C:\Program Files (x86)\Battle.net using your Windows Explorer.
2. Right click on the Battle.net launcher and create a shortcut.
3. Drag that shortcut to your desktop.
4a. Navigate to C:\ProgramData\Microsoft\Windows\Start Menu\Programs using Windows Explorer.
4b. If you don't want to do step 4a, you can also type in the name of a Battle.net game you have installed (like Overwatch or World of Warcraft) using Cortana, right click it and choose "Open file location." Then click the back button in the top left corner of the window that pops up.
5. Drag the shortcut you made in step 2 into that directory.


Why didn't I think of this :D Excellent fix!
Problem still exists...
Still have to hunt down work arounds to get any blizzard games to work. Windows 7, but sounds like that doesn't matter. Same problem for several years now. I open WoW by opening hearthstone deck tracker which has a "Launch Battle.net" button and then from there I can access my games. Sad that I have to go through a third party program for a game I also haven't played in ages just to get a completely different game to work.

Oh, also, pinning to taskbar for battle.net doesn't work as it disappears in a day or two on it's own. Quite a nuisance blizzard, thanks!
Having the same problem, having to click on the download for the apps to run every time is pretty annoying, guess I'm just gonna have to not play blizzard games anymore... well until its fixed at least
FOUND A FIX:
[I found this on another reply but I don't know who found it so I can't credit]
-Go into control panel, Uninstall a program, uninstall Battle.net
-Download "Battle.net-Setup.exe" (or just find it in your downloads folder if you already have it downloaded
-Right click "Battle.net-Setup.exe" and click Properties, Compatibility, run this program in compatibility mode for:, windows 8
-Go back to downloads and right click "Battle.net-Setup.exe", Run as administrator

Hope this helps, it was so annoying beforehand :)
FOUND A FIX:
[I found this on another reply but I don't know who found it so I can't credit]
-Go into control panel, Uninstall a program, uninstall Battle.net
-Download "Battle.net-Setup.exe" (or just find it in your downloads folder if you already have it downloaded
-Right click "Battle.net-Setup.exe" and click Properties, Compatibility, run this program in compatibility mode for:, windows 8
-Go back to downloads and right click "Battle.net-Setup.exe", Run as administrator

Hope this helps, it was so annoying beforehand :)
11/07/2018 10:53 AMPosted by Wynexdra
FOUND A FIX:
[I found this on another reply but I don't know who found it so I can't credit]
-Go into control panel, Uninstall a program, uninstall Battle.net
-Download "Battle.net-Setup.exe" (or just find it in your downloads folder if you already have it downloaded
-Right click "Battle.net-Setup.exe" and click Properties, Compatibility, run this program in compatibility mode for:, windows 8
-Go back to downloads and right click "Battle.net-Setup.exe", Run as administrator

Hope this helps, it was so annoying beforehand :)


You know when you chose compatibility mode, if you want to run as Administrator, just click the checkbox for that, then no need for the right click.

Although this is an old thread, I am having this issue now, and your suggestion didn't work. I can manually add a shortcut so it's not really a big deal.

Also, you posted it twice.
I just uninstalled and reinstalled, and it appeared. Weird.
Hello to all.

I faced same problem and it was easy to make solution, as first I just reinstalled app with run as administrator. Even I am on admin account but still. Still it did not appear anywhere so I gone in to C:\Program Files (x86)\Battle.net and everything is there. Right click on Battle.net Launcher and say pin to task bar , it will show it down on task bar and it will stay there. Or right click and select send to desktop as shortcut and you will have icon at your Desktop.

This working for me and it stays like that after restart.

Cheers all.

P.S.

I am on 64 bit win10 , if anyone using 32bit version , above will not work, your battle.net folder will be in c:\Program Files\

Join the Conversation

Return to Forum