Can't interact with Client

Technical Support
I just got a new gaming laptop. It has Windows 10 64-bit, and I ordered it with a clean install - no bloatware.

The Battle.net client keeps (seemingly) crashing - except everything LOOKS fine. It's just when I try to interact with it - to click something or try to type something, that I realize there's a problem. The bnet client shows as launched, but I can't actually use it. Doesn't matter if I use the trackpad or an external mouse. I can't even close the client - I have to go into task manager to kill it, and task manager doesn't show it as "not responding" as one would expect. Oddly, I can click and drag it and it's components (separate chat window and friend window) around my screen.

Has anyone seen this issue before, and if so, is there a fix?
Hello Fhina, let's see if a Flash update helps.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
Sorry for the delay in getting back. Sadly, that didn't help. :(

I can alt-tab between the various chat windows, but can't get them to actually accept any input from keyboard or mouse.
Can you try reinstalling the Battle.net app?

Let's also delete these folders from the C:\ProgramData folder:

________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
That didn't fix it, either. :(

I've run HDD tests and memory tests, and those passed.
01/20/2016 05:23 PMPosted by Fhina
I just got a new gaming laptop. It has Windows 10 64-bit, and I ordered it with a clean install - no bloatware.

Are all of the latest Windows updates installed?

I'd run the System File Checker just to verify Windows as well.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
Marked As Solution
Win10 was fully updated. Decided just to do a "refresh" of Windows, reinstalled the Battle.net Client, and so far, so good.

Thanks, Velnrak!

Join the Conversation

Return to Forum