Running Glide with Diablo II Patch 1.14

General Discussion
It took me a little messing around to get it, but I got Glide working again on the new 1.14 patch. I use the wrapper from here:
http://www.svenswrapper.de/english/

I initially had issues with crashing (on windows 10) and flickering (both windows 7/10). I had to fiddle with the options in the Glide wrapper to get it to work. Here's what I did to get it working on two different systems.

The wrapper can be installed into the OS's system folder, although some would recommend copying it to the Diablo II folder. The wrapper does not modify the game, so I expect no worries about getting kicked for that (I haven't had any). It just translates 3dfx Glide to OpenGL, since Glide was originally based on OpenGL.

The version 1.4e zip file will need to be downloaded and files extracted (system32 or diablo II). The "glide3x.dll" file will then to be replaced with the hotfix version from the homepage.

Open the"glide-init.exe" file as Administrator to configure the wrapper. Things get a bit complicated from here. I will refer to the column of buttons under the "Main Menu" section as "tabs."

The program defaults to Deutch (German?) as its language. Press the "English/Deutch" button on the left to switch to English if necessary.

Click the "OpenGL-infos" button on the left. Next, click the "Query OpenGL-infos" button. You'll see a pulsing infinity symbol appear in the corner of your screen for a few seconds, just wait for it to go away.

On the "settings" tab, It may be recommended to check the "captured mouse" option, but may not be necessary.

On the "renderer" tab, Set the "texture-memory" to "64 MB".
Set "buffer-texture-size" to "2048x2048" (May not be necessary).
Check "32-bit rendering," "texture for videos," "bilinear filtering," and "shader-gamma." Ensure that the "Keep desktop Composition" box is NOT checked.

On the "Extensions" tab, check the "WGL_ARB_render_texture" option.

Click "test." You should see two horizontal lines each for all three primary colors (red, blue, and green), and a quit button. If it looks ok and you can see the mouse cursor, click on the quit button.

Click the "Quit" button.

==============================

Next step is to configure your Diablo II shortcut. Right-click the shortcut and select "Properties."

On the "Shortcut" tab, at the end of the text in the "Target" box, type "-3dfx" without quotes.
("C:\...\Diablo II\Diablo II.exe" -3dfx)

The next part is different. On the compatibility tab, you'll have to do one of two things:

On windows Vista/7, select "Disable Desktop Composition" and that's it, click apply and you're good to go. (This works no problem on my Windows 7 machine.

on Windows 10, Select run this program in compatibility mode for Windows Vista (Service Pack 2). I used this option on my Windows 10 laptop no issues, and there is no admin prompt. If it still doesn't work and you're not worried about non-admin users, select windows XP mode.

Click Apply/Ok. Launch the game and enjoy.

And I gotta say, the Glide mode still looks better than Direct3d, I wish they hadn't tried to force that on us.

Suggestion:
It would make sense to perhaps modify the Glide code to run as OpenGL in a later patch so wrappers won't be needed? I don't know if its possible.

P.S.
The "Gamma" and "Contrast" controls in the game work too.
Confirmed. It is working. Big thanks! Glide indeed looks better
Thx!
No longer need compatibility mode with 1.14b!
I didn't have any luck with DGVoodoo 2 or Nglide but this actually works and offers much better image quality. The only thing I'm missing is a framerate improvement. FRAPS still shows 25FPS and it doesn't feel any smoother than the D3D version. What about that 200FPS cap the patch claims to have?
Single player games are always capped at 25 fps. Multiplayer games used to not have a cap, but are now limited to 200.
I didn't have any luck with DGVoodoo 2 or Nglide but this actually works and offers much better image quality. The only thing I'm missing is a framerate improvement. FRAPS still shows 25FPS and it doesn't feel any smoother than the D3D version. What about that 200FPS cap the patch claims to have?

I see. I guess I'll just host a TCP/IP game for single player although I'm not sure if there's actually an increase in smoothness or if it's somewhat imaginary. I can usually tell the difference between 30&60 quite easily but with this it looks almost the same (maybe?).
Just need to remember that the hotfix is on the main page, not included in the download section zip (but you still need to download this first)...can be confusing.

I'm not sure about the FPS, here shows 25 and sometimes with "skips" but I can't compare with pre-patch anymore.

The image itself is like day-night, the ground textures with glide look sooo much better.
Since the new patch 1.14b, the wrapper hotfix is not necessary anymore.

As stated above, the framerate cap at 25 fps only appears in single player. So if you want to have higher framerates, choose 'Multiplayer2'->'TCP/IP'->'host game' to start a local game.
Does this get you banned in multiplayer? I just reinstalled Diablo 2 today and I am curious if the resolution can legitimately be improved to how it used to be in the old days
04/13/2016 11:27 PMPosted by Basia
Does this get you banned in multiplayer? I just reinstalled Diablo 2 today and I am curious if the resolution can legitimately be improved to how it used to be in the old days


You may use it in Multiplayer. Have fun slaying demons.

-Clásico
This doesn't work. Still only the same low resolutions available after installing this.
04/24/2016 05:23 AMPosted by oldskoolguy
This doesn't work. Still only the same low resolutions available after installing this.


The wrapper doesn't enable higher resolutions. It lets you emulate Glide, the original graphics API Diablo 2 was written for, using OpenGL.

The gives you better image quality, and smoother gameplay.
Holy crap! Thank you so much!

I played D2 years ago, and after recently playing D3, I missed the "relatively to D3 at least" complexity of D2, so I bought it now.

On stock settings with vsync force enabled, its really not a good experience!

But using your guide, its now butter smooth! (I disabled vsync in the utility, and set a max fps of 100) Thanks!! Playing on a GTX980 btw, hope it can handle the load ;)

Thanks again!!
Regards
Hi, I followed the instructions and installed the program, except for the hotfix download on the main page of the website... can't seem to find that anywhere?
This worked perfectly when I followed the instructions exactly how you typed them. Thank you so much!!! I cannot wait until the remastered version comes.. it will reclaim the ARPG Crown
setting the buffer-texture size to a value lower than 1024x1024, as 256x256, will increase the frame rate for older graphic cards.
The version 1.4e zip file will need to be downloaded and files extracted (system32 or diablo II). The "glide3x.dll" file will then to be replaced with the hotfix version from the homepage.

where do i find the hot fix on the home page on the website cause when i try to launch it blue screens
I followed these instructions to a T and got a critical error when trying to start D2. I have an MSI GTX 760 https://www.amazon.com/MSI-DisplayPort-PCI-Express-N760-2GD5/dp/B00DIH8OW8
Will glide work with my card?
Worked for me without having to turn on Compatibility settings. Running Windows 10. Using Intel HD 3000 mobile (integrated in my laptop).

Actually lowered Gamma a few clicks, raised contrast all the way up. May still meddle with it.

I'm playing Windowed as well, just preference.

*Update* after some playing I'm still fairly laggy so I'm looking into ways to clean this up :/

Join the Conversation

Return to Forum