Warcraft III: "Unable to Initialize" on Mac

Support
So I recently tried to play Warcraft III and was unable to launch it. (I got an error message of "Warcraft III was unable to initialize.") I was able to play it on this computer before I updated to El Capitan, does anyone know how to get it to work again?

Oh, and I don't want to use the installation disc, because it currently isn't here. Please help, thankchu.
Bump. Help would be appreciated.
i'm having the same issue
I've looked all over the place, a few other people have had the same issue, but nothing has worked yet. :/

Also, turns out it's not only on El Capitan. I can't run Warcraft III on El Capitan or Snow Leopard. Both could run it only a few months ago, so perhaps it's a patch error? Anyway, I'm really annoyed with it, does anyone have ideas?
Asked on a few other forums, no reply. Does anyone know what to do? I really wanted to start playing this game again. Should I contact Blizzard at this point? :/

Join the Conversation

Return to Forum