Overwatch waiting on another installation or update..

Technical Support
1 2 3 5 Next
First time trying to download overwatch and it is stuck on "waiting on another installation or update" in the battle.net launcher even though this is the only blizzard game that I own.

I've tried exiting the agent.exe in task manager after closing the application and restarting it and its not worked.

What do i do? :S
Marked As Solution
fixed

Found a solution from an admin post for anyone else having this same problem:

Pull up your Control Panel and select Internet Options.
Click on the Connections tab.
Click the button called "LAN Settings"
Uncheck all of the options on that screen.
Then try again.
This !@#$ doesn't work for me...

I paid £30 and i got nothing!!!!!!!
SHAME!!!!!!!!!
THIS WORKED! I tried the 2 or three other options blizz game to try and fix this, but this is the only one that helped! Thank you!
how to do this on windows? I searched and I have no LAN settings place
I've been trying tons of different solutions posted and nothing is getting overwatch to update... I'm not sure what to do at this point, is it a problem on blizzards end? Wouldn't mind seeing a blue answer
Thank you flare worked for as well. :-) Or it was because I did an update of the driver of my graphic card. And at the same time I unchecked the one box in the internet options when the update of the driver was done. Who will tell??? Another wordly mistery.
Where do you find "Internet Options"?
I am running on Windows 7, and the closest thing is "Network and Internet" on the control panel.
Nevermind, I figured it out and it worked like a charm!
how did you figure it out on windows 7? I'm have this same issue
Hello i am having trouble updating the PTR update. My problem is that it just wont update. It says "waiting on another installation or update...". I paused all the other updates and it still wont update. PLEASE HELP!!!
05/24/2016 03:48 PMPosted by Flare
fixed

Found a solution from an admin post for anyone else having this same problem:

Pull up your Control Panel and select Internet Options.
Click on the Connections tab.
Click the button called "LAN Settings"
Uncheck all of the options on that screen.
Then try again.

your'e a legend man
i truly love you, you are an angel in this soddom and gomora
may your soul be blessed with a thousand blessings
Didn't work
Hey LordSliceX13, another program running in the background may be interfering with the patching process. Can you boot into a Selective Startup and see if that helps?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
I was having this problem and while I was looking for answers left it up and running and eventually it fixed itself. (At least for most recent patch)
07/21/2016 11:55 PMPosted by NoStopGoNoT
I was having this problem and while I was looking for answers left it up and running and eventually it fixed itself. (At least for most recent patch)


Same thing happened for me.
Thanks. I think it works for me.
I have tried all the things above and still yet have had no working solution. It's really annoying how I played the new patch one time then it locked up like this. If anyone finds anything else please reply back.
Did the selective startup procedure as mention and now steam doesn't work for me

Join the Conversation

Return to Forum