Overwatch not updating

Technical Support
When i go onto the overwatch tab in the battle.net thing it tells me to update overwatch.
I press update, it stalls, tells me "We're having some trouble transferring data" and then tells me to check my internet and try again.

I have done literally everything i could find including resetting my internet, it still does not work.

Anybody know what is going on?
Had same issue, turns out (for me) hamachi was the cause... uninstalled and the game started to download at full speed!
Exactly that for me too! Uninstalled Hamachi, restarted Battle.net and I was able to download it.

Thanks Waah!
I'm having this problem, but I don't even have Hamachi. Anybody have another solution?
it isn't working for me either. and i don't have Hamachi is the ANY SOLUTION TO MY PROBLEM I WANT TO PLAY OVERWATCH!!!
Wow is the same way BUMP!
Cant log in to any games wow diablo starcraft. Awaiting update..!!..(>,<)
halp me to
"Downloading: 29.50MB remaining @ 0 B/s"

it's stuck like that now
anyone know what to do?
I just forced my firewall to release it IP from my ISP. And it worked, so I'm guessing that certain download servers are !@#$ed atm.
please help its not updating "Downloading: 29.50MB remaining @ 0 B/s" it says but my internet is working fine
Hi Minato, I would first try disabling or even temporarily uninstalling any security or antivirus software you might have, and see if the download gets going.

If that doesn't help, these steps might. Let us know how it goes, and we can work from there.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

“Today, we retake our homeworld, and with it, our Legacy.”
I have been trying for 3 day's now, to fix this issue. I have tried about everything, and I am still having the issue, I have a 30 meg update for Overwatch, but I still get 0 Bytes download speed.
I have turned off my antivirus, checked my firewall to see if it was blocking it (It wasn't). I even uninstalled battle.net and reinstalled it, still nothing. Kind of making me angry. It's why I wish developers would just put their games on steam, because then I have to deal with this crap. Not to say battle.net is abyssmal, but it is irritating.
I had all the issues from https://us.battle.net/forums/en/bnet/topic/20752075014?page=18 and only managed to get back on to battle.net when I deleted every part of it from my computer but every time I get back on only a few applications update then the others get stuck waiting for an update the never comes. I have tried disabling the firewalls and suspending avast, uninstalling and reinstalling games, the proxy fixes, secondary login enabling, reinstalling battle.net and yet it hasn't worked properly since I started using it on the 11th December.

After a fresh resinstall I am back to being stuck on 'Starting Battle.net' This is ridiculous I can't believe such a terrible issue has been allowed to go on for so long, I have contacted support twice and they haven't helped, now they are telling us it's fixed but the same issues persist.

Fiddler keeps telling me that there is "no-cache, must-revalidate" when running the process agent:12060 trying to update Heroes of the Storm or WOW, so I'm pretty sure that the issue is with the agent.exe.
I went into task manager and closed Blizzard update agent. I then closed battle.net and reopened it. My download immediately began. Try that.
It says to update the game but when I try to it just an error occurred and to restart the Blizzard app but nothing happens I just get the same glitch
Whenever I try to update, it starts the update but then says, "Something went wrong with a file. We're not sure what caused it etc.". I went to the wesbite of the error code, done all the steps, and my game still won't update.
I just fixed mine by going into the settings and increasing the future patch download speed to unlimited.

Join the Conversation

Return to Forum