Can't disable video autoplay on Battle.net App

Bug Report
I recently installed the flash Firefox - NPAPI file to get videos to play in the battle.net app. I am now very annoyed that certain videos will play automatically as the app cycles to different news about each game. No option exists to disable video autoplay in the app or to disable it completely. I have uninstalled every trace of flash I can find on my system, I even tried uninstalling the b.net app. But the stupid videos still play automatically! It's an eyesore. I've already spent a solid 3 hours trying find out why.

I need to know how to disable the video play feature in the b.net app again, at a minimum an option is needed to disable the autoplay.
Bump. I would really like a way to stop the annoying video autoplay or disable the videos.
Bump. This is the single most annoying part of the b.net app. I'm not going to stop wanting a solution that allows me to turn off video autoplay.
bump
The videos just keep crashing the battle.net launcher and I can only play hearthstone directly through the battle.net launcher. with othe blizzard games there are workarounds.

Also as a general option I want the videos gone due to system strain.
bump this, High AF.
Annoying GIF's and App Lags.

Really annoying for people running on 3G!
It's ridiculous this still hasn't been addressed/fixed.
Autoplay gifs defo needs a disable button. What a horrible lag feature. Since I don't own diablo, I just linger on that page while in-game. I feel sorry to the folk who don't have that option.
So worth Necroing this thread. Blizzard please for the love of all you do, give us an option to turn this autoplay off!!
If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net
It has worked for me so far, with no adverse side effects!

Here's how my launcher looks now: https://imgur.com/a/aCQ9c
Would appreciate if this option was added. Thank you.
Stay strong friends and keep bumping.
Bump Time as the videos autoplaying after an OW update is BSOD crashing my PC
Please Blizzard help us!
I'll second this. Please add an option to disable auto play of videos and also event streams (like currently HGC autoplays in launcher in the Heroes tab).
the post from Khadgar
worked like a charm if from the eu simply change the us with an eu
i put in both eu and us just for savety :)
Nov 8
 (Edited)
1

If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net

It has worked for me so far, with no adverse side effects!

Here's how my launcher looks now: https://imgur.com/a/aCQ9c
11/07/2017 04:50 PMPosted by Khadgar
If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net
It has worked for me so far, with no adverse side effects!

Here's how my launcher looks now: https://imgur.com/a/aCQ9c

Legend!

Took a few minutes for my host file lookup to take effect - I restarted bnet a few times but it looks like it's working. Cheers bud.
BUMP
there is a workaround, but you will lose the entire functionality of the browser in the bnet client, including the store.
but if you dont mind, it is easy to revert, just exit the client, go in the folder where the battle.net client is installed, locate the latest version, probably the one newer or with the biggest version number and rename a file called "Battle.net Helper.exe".
if you want to have it working again, simply rename it back.
11/07/2017 04:50 PMPosted by Khadgar
If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net
It has worked for me so far, with no adverse side effects!


This helps with some of the stuff in the launcher, but unfortunately not with the Starcraft 2 "live" stream in the launcher. The other tip (renaming the helper exe) does work, but I'll have to do this whenever the launcher updates.

Does anyone know the URL or IP that the SC2 auto play video comes from? I'd rather not block all of twitch.com in my Hosts file.

edit: I sorted it out. It's actually ttvnw.net, not Twitch, luckily, so my Hosts file now looks like this and I no longer have SC2 auto play videos in the launcher (I nearly uninstalled the game over this):

127.0.0.1 cache-us.battle.net
127.0.0.1 cache-eu.battle.net
127.0.0.1 *.ttvnw.net ttvnw.net

Blizzard, we really need an option to turn this off, without having to block connections. Not everyone has a fast, unlimited connection even in 2018.

Join the Conversation

Return to Forum