Can't disable video autoplay on Battle.net App

Bug Report
Sorry to necro this thread but I need to say two things:

First, thanks for the workaround! Worked great for me.

Second, there absolutely needs to be an option in the launcher to stop autoplay (or just default to not autoplaying). This is absolutely ridiculous and frankly feels kind of exploitative, as the goal seems to be artificially inflating view counts at the expense of the user experience. After all, if it was just for advertising the stream all it needs is a a pic with a link, which is what it used to be.
Just going to add that rather than modifying your hosts file, some routers will let you do this from their UI. In my case, there's a "URL filter" option under the router's firewall.
up on this post again, we need this on our app
auto play is abusive and give "visions" liikes or whatever on content we DONT CHOOSE, NOT play NEED be the default option, by the way, i dont know how go in this folder.
bump, WANT the option to turn off auto play in the blizz client
Need an option to disable this, kinda stupid to just assume whatever connection I'm on is fine streaming video.
Bumping. This !@#$'s ridiculously annoying.
having the same problem in Heroes of the storm
Bump.
disable this crap, my bandwidth is limited enough as it is already.
I stopped opening b.net so it doesn't get consumed even more and immediately close it after playing.
this launcher is like these websites filled with ads that start videos automatically, it's garbage and If I could avoid using it, I would, so fix it...
I don't even know how it's possible that nobody in your team thought about that...
I actually found this thread via google looking for a fix to this problem after lagging out in HotS just now.

Jesus how long will they let this be a problem.
Bump.

Agree 10000% with all above. Game crashes so much when video is streaming / playing. I have to click the next arrow to get the video off to launch a game, often game crashes after.
I can't believe this thread is 2 years old. Blizzard, please. I like to be told if I'm missing HGC or WCS or WoW Arena or whatever. Just stop the autoplay. More often than not I'm watching (on twitch, second screen) and playing something but the battle.net launcher is playing also. Makes no sense. You can't full screen your little window anyways and I doubt anyone watches through there. Especially when you click 'watch now' it takes you to Twitch.tv.

STOP THE MADNESS BLIZZARD. I'm not a programmer but it can't honestly be that hard to add a check box for autoplay or not.
DING DONG! Hello Blizzard? Anyone working on it? Is it a upcoming feature that you will add in the settings where you can uncheck it? Autoplaying the stream on the app is annoying for ANYONE. Please?

Thanks
This is infuriating and using up CPU needlessly. +1
They're prob not gonna let you block their own ads

How else could they spam vapid cosplay crap and nobody streamers at you?
Yeah. similar issue here. I'm just sick of seeing the same dumb image spammed endlessly into my brain. I'm a terrible man, but i don't deserve that.

And as it's been stated before, it's shady. I pay my monthly. Please don't shove your adverts down my neckhole.
Bump. I'm very tired of seeing that stupid cosplay video every time I go to start the game up.
my data is limited get rid of this bull!@#$!
07/28/2018 03:47 PMPosted by CrunchBoat
I can't believe this thread is 2 years old. Blizzard, please. I like to be told if I'm missing HGC or WCS or WoW Arena or whatever. Just stop the autoplay. More often than not I'm watching (on twitch, second screen) and playing something but the battle.net launcher is playing also. Makes no sense. You can't full screen your little window anyways and I doubt anyone watches through there. Especially when you click 'watch now' it takes you to Twitch.tv.

STOP THE MADNESS BLIZZARD. I'm not a programmer but it can't honestly be that hard to add a check box for autoplay or not.


NOW! not 40 years from now!
11/07/2017 04:50 PMPosted by Khadgar
If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net
It has worked for me so far, with no adverse side effects!

Here's how my launcher looks now: https://imgur.com/a/aCQ9c


a work around isn't a proper solution to an easy fix.
Still no option to disable. I've found a better method, or at least one that doesn't require screwing with the hosts file and potentially preventing other applications from accessing Twitch.

Twitch's IP space is detailed at ARIN: https://whois.arin.net/rest/org/JUSTI-19/nets

The range the battle.net client might potentially connect to starts at 52.223.216.0 and ends at 52.223.255.255. So what I did is create a custom Windows firewall rule to block all outbound connections to remote IP addresses within this range for C:\Program Files (x86)\Battle.net\Battle.net.exe only.

This has the effect of not blocking any other functionality of the battle.net client, or potentially blocking legitimate connections to Twitch addresses, but completely strips the battle.net client's ability to connect to Twitch. I tested it out a few times and all auto-playing Twitch videos just sit at a black screen now. Looks like it works!

If Twitch's IP space ever changes, the changes should be reflected at the page I listed above, or you can just do a whois search for their IP space on ARIN's website if ARIN changes how their site works and the URL breaks. Twitch owns other blocks of IP, but the bnet client doesn't seem to connect to them as far as I can tell.

Join the Conversation

Return to Forum