Can't disable video autoplay on Battle.net App

Bug Report
This is a problem that desperately needs to be addressed
Please, Blizzard, please. It would be an easy option.
Thank you all for the work around. Editing the host file to include:

127.0.0.1 cache-us.battle.net
127.0.0.1 cache-eu.battle.net
127.0.0.1 *.ttvnw.net ttvnw.net

worked like a charm.

Blizzard --> Thank you for being useless tools and not doing anything about this. Jerks.

-Azyal
Good solution. Works fine for me.
Also, bump.
These creepy videos and flashy gif annoy me too. Thanks for domain block solution.
I don't care how old this thread is. Blizzard, your decision to continue doing this is purely exploitative of your users. Apparently you do not care that you are providing an experience that is not only worse, but in the case of people with limited bandwith, data, or PC hardware, ACTIVELY DETRIMENTAL. There is a real, measurable, negative impact of auto streaming video in your client, and you have chosen to ignore this for the purpose of artificially inflating view counts. It sucks. You should do better.

09/16/2018 03:30 PMPosted by twocows
Still no option to disable. I've found a better method, or at least one that doesn't require screwing with the hosts file and potentially preventing other applications from accessing Twitch.

Twitch's IP space is detailed at ARIN: https://whois.arin.net/rest/org/JUSTI-19/nets

The range the battle.net client might potentially connect to starts at 52.223.216.0 and ends at 52.223.255.255. So what I did is create a custom Windows firewall rule to block all outbound connections to remote IP addresses within this range for C:\Program Files (x86)\Battle.net\Battle.net.exe only.

This has the effect of not blocking any other functionality of the battle.net client, or potentially blocking legitimate connections to Twitch addresses, but completely strips the battle.net client's ability to connect to Twitch. I tested it out a few times and all auto-playing Twitch videos just sit at a black screen now. Looks like it works!


This. This is PERFECT. Exactly what I wanted. Blocks the video and nothing else, affects nothing but the BNet client. Thank you for this!

For those who might have found this confusing, here is a slightly more step-by-step approach:

0. Close BNet app.
1. Open Windows Firewall (from control panel if on Win7).
2. Click 'Advanced Settings' on the left side menu.
3. In the Advanced Settings window, Click 'New Rule' from the upper right menu.
4. The first screen is Rule Type. Select 'Custom', click 'next'.
5. This is the Program screen. Select 'This Program Path' and browse to your BNet installation folder and select Battle.net.exe (default is C:\Program Files (x86)\Battle.net\Battle.net.exe). Click 'next'.
6. In the next screen (Protocols and Ports), make sure the option at the top is 'Any' (everything else should be grayed out) and click 'next'.
7. You should now be on the Scope screen. For the top box (Local IP addresses) leave it on Any. For the bottom box (Remote IP addresses) click 'Add'.
7a. In the window that pops up, select 'This IP address range'.
7b. In the 'From' box, put 52.223.216.0
7c. In the 'To' box, put 52.223.255.255
7d. Click 'OK'. In the Remote IP Addresses box, it should look like this: 52.223.216.0-52.223.255.255
7c. Click 'next'.
8. You should now be on the Action screen. Select 'Block the connection', and click 'next'.
9. On the Profile screen, all three options should be checked. Click 'next'.
10. On the Name screen, name this rule something you'll remember (BNet block Autoplay, for example). Click 'finish'.
11. Restart BNet app. Check a tab with video active. The video player should just remain black.

Congrats! You've accomplished something Blizzard could have done with a simple checkbox in their app settings, if they didn't care more about inflating their view counts than about your user experience, PC performance, bandwith, or data caps.

Thank you again to @twocows for figuring this out. MUCH appreciated.
04/21/2018 08:03 PMPosted by Murr
11/07/2017 04:50 PMPosted by Khadgar
If in the us, try blocking the following url in your windows hosts file:
cache-us.battle.net
It has worked for me so far, with no adverse side effects!


This helps with some of the stuff in the launcher, but unfortunately not with the Starcraft 2 "live" stream in the launcher. The other tip (renaming the helper exe) does work, but I'll have to do this whenever the launcher updates.

Does anyone know the URL or IP that the SC2 auto play video comes from? I'd rather not block all of twitch.com in my Hosts file.

edit: I sorted it out. It's actually ttvnw.net, not Twitch, luckily, so my Hosts file now looks like this and I no longer have SC2 auto play videos in the launcher (I nearly uninstalled the game over this):

127.0.0.1 cache-us.battle.net
127.0.0.1 cache-eu.battle.net
127.0.0.1 *.ttvnw.net ttvnw.net

Blizzard, we really need an option to turn this off, without having to block connections. Not everyone has a fast, unlimited connection even in 2018.

It helped me so thanks to you traveler!
Thanks for this topic

These domains are now permanently blackholed on my PC

Join the Conversation

Return to Forum