Keeps asking me to enter my password

Bug Report
When trying to log in to battle.net, I enter my username and password. Then after attempting to log in, it seems to delete my password and ask for it again and again, making it impossible for me to log in/play.
have your problem been solved? i´m experiencing the exact same thing "/
I have the same problem, but you can log in offline and the games work.
Same thing keeps happening to me and it's annoying.
I'm having this issue now. Was there ever a fix?
Computer experienced a hard shutdown and then started seeing this issue. Resolved by uninstalling and reinstalling the battle.net client.
same issue, deleted authenticator and everything
Turned off firewall, uninstalled bnet app, logged into facebook, logged into blizzard, literally everything. Terribly, terribly sad I could play this in the 90s and not now lol...jesus guess I'll get back on steam in my free time
windows 10, continues to happen
still happening
I'm having the same issue. Did anyone ever figure this out?
Same here, bump!
I had this problem as well. Mac OS, 10.13.5.

I tried launching the battle.net.setup.app too: it reads "updating blizzard agent", and once that finishes, it opens up the battle.net Login window, which is where I enter my bnet pass and then authenticate. Upon entering correct password and approving with authenticator, I am returned to the exact same window (asking me to enter password to log in to blizzard).

Very odd. Worked yesterday.
We had to Login to battle.net offline (use the "Settings" Icon to do that) and once in battle.net, clicked "connect". It then asked first to accept a new EULA. Once we accepted it, the problem disappeared.
Good luck,
Cap'

Join the Conversation

Return to Forum