Battle.net launcher holding high GPU/memory clocks for AMD cards

Technical Support
I have an AMD RX 480 graphics card which downclocks its GPU and memory core clocks when idle.

Tonight I ran into an issue where even when idle my memory and GPU clocks were remaining either maxed or high, causing the card to run hotter, consume more power than it needed, and for the fans to spin when they shouldn't have been needed.

After going slightly crazy trying to figure out the cause, it turned out to Battle.net. With the launcher closed, the card downclocks as normal. With Battle.net running (even with the --disable-gpu option - I tried and it had no effect) my memory clock sits at 2000MHz, with the occasional dip to 300MHz, and my GPU core dodges around 1000-1100MHz. This is with no patching taking place, just the client idling in the background and nothing else occurring.

With Battle.net closed, my memory clock drops down to 300MHz, and my GPU core drops to ~400-600MHz, as they should.

I'm unsure why, but Battle.net for some reason is causing this abnormally high usage.

Pic: https://imgur.com/rQotqOw
i have an RX 480 as well and have the same issue, a friend of mine said that its been known for awhile about this issue. He reported it to blizzard when he was running crossfire 290s. hopefully blizzard can correct this issue rather then ignoring it
Hey guys,
came here from a Google search, because the exact same thing is happening to me on my new GTX 1070. It doesn't seem to be an AMD-specific thing.
I have this same issue. Though battle.net is actually making my computer run at 100% disc usage as well.
Definitely not limited to the RX480, my R9 390x is experiencing the same problem. The card runs 5c hotter with Battle.NET open, would be nice if Blizzard could fix this.
Or even just post here acknowledging the issue...
I am experiencing the same issue with my new GTX 1060. Coreclock skyrockets to 1300 MHz up from 300MHz and Memory clock up to 2000Mhz from also ~ 300Mhz. It is a bit ridiculous...
Same issue as well on a nvidia 1070. Make sure you enable the "exit battle.net after game launch" toggle in the settings. I don't leave battle.net running anymore at anytime except to launch a game.

Maybe it's a bug with the hardware acceleration toggle not working properly? I know hardware acceleration in chrome causes the same issue, but you can turn that off without issues.
just noticed this on an RX 470, couldn't figure out why the thing wasn't spinning down the fans (it does that thing where they will stop spinning at low enough temps).

I've found the speed goes up when the app is visible, but if I close it, minimize to tray, the GPU speed goes back to normal.

It also seems to be preventing my system from sleeping overnight, but again, only if I leave the app visible. If I close it and it minimizes to tray, it behaves as expected.
GTX1070, same issue.
Hey, zzz!

Do you happen to use any specific Overclocking hardware? If so can you please post the program you are using? If anyone else has this exact same issue, please post what Overclocking programs you have installed.

Thank you. :)
I have this same issue.

I use MSI Afterburner
I have no overclocking apps or hardware installed, and it's eating 15-20% of my GPU.

The Blizzard Updater process is also eating up my bandwidth. It's supposed to be updating Battle.net and Destiny, but I don't see any progress on either progress bar.

Did you guys insert a bitcoin miner into battle.net?!?
Same, gtx 1060, even in tray battle.net lock GPU to 1569mHz clock with 0% usage, back to 139mHz after close process. No overclocking app, check clock in gpu-z and power meter - running battle.net adding extra 30watt.
GTX1060 here, never noticed it before today, but using 20% GPU, even when Battle.net is minimised, only way to stop it is to close completely.
Does seem to be related to whats on display in the mini screen, clicking Diablo reduces to about 5%, but still using GPU even though its a static screen.
Firstly try switching from beta battle.net launcher to stable version. It helped me with memory leak and massive ssd usage.

Join the Conversation

Return to Forum