[Solved] Fix Almost any Battle.net bugs with these 9 quick fixes!

Technical Support
Prev 1 3 4 5 6 Next
I did everything including restarting my computer and reinstalling battle.net. And still can't go online :(

Request Count: 1
Bytes Sent: 334 (headers:277; body:57)
Bytes Received: 172 (headers:145; body:27)

ACTUAL PERFORMANCE
--------------
ClientConnected: 21:04:06.369
ClientBeginRequest: 21:04:06.370
GotRequestHeaders: 21:04:06.370
ClientDoneRequest: 21:04:06.370
Determine Gateway: 0ms
DNS Lookup: 115ms
TCP/IP Connect: 186ms
HTTPS Handshake: 0ms
ServerConnected: 21:04:06.671
FiddlerBeginRequest: 21:04:06.671
ServerGotRequest: 21:04:06.671
ServerBeginResponse: 21:04:08.401
GotResponseHeaders: 21:04:08.401
ServerDoneResponse: 21:04:08.401
ClientBeginResponse: 21:04:08.401
ClientDoneResponse: 21:04:08.401

Overall Elapsed: 0:00:02.031

RESPONSE BYTES (by Content-Type)
--------------
~headers~: 145
text/html: 27

ESTIMATED WORLDWIDE PERFORMANCE
--------------
The following are VERY rough estimates of download times when hitting servers based in Seattle.

US West Coast (Modem - 6KB/sec)
RTT: 0.10s
Elapsed: 0.10s

Japan / Northern Europe (Modem)
RTT: 0.15s
Elapsed: 0.15s

China (Modem)
RTT: 0.45s
Elapsed: 0.45s

US West Coast (DSL - 30KB/sec)
RTT: 0.10s
Elapsed: 0.10s

Japan / Northern Europe (DSL)
RTT: 0.15s
Elapsed: 0.15s

China (DSL)
RTT: 0.45s
Elapsed: 0.45s
I found this bug at Fiddler. What will I do?
Hi pingutingu,

Thanks for posting this howto guide up. But my problem doesnt seem to be fixed, though im not very tech minded, ive tried several times just to be sure.

Ive d/l the battle.net set up and try to install it, but after going through the permissions tabs it just opens a small dark grey window that has "starting battle.net..." then just hangs there....for eternity...mocking me at my incompetence with PCs...as though its better than me...like maybe it has won the lotto and doesnt care what i want in life....i hate that small window...
Bnet and WoW install fine for me using these methods. But three times in a row doing this, Hearthstone gets stuck at exactly 923.10 MB download remaining and then 'loses' internet connection (red/yellow triangle periodically pops up by the download bar). This is using Fiddler. It basically gets hung at 923.10 MB and never goes past that. :(
01/21/2017 08:56 AMPosted by halflotus
Bnet and WoW install fine for me using these methods. But three times in a row doing this, Hearthstone gets stuck at exactly 923.10 MB download remaining and then 'loses' internet connection (red/yellow triangle periodically pops up by the download bar). This is using Fiddler. It basically gets hung at 923.10 MB and never goes past that. :(


halflotus this happened to me too! i just left battle.net running. The red/yellow triangle stays there and the numbers don't change but in the background they actually are. If you restart battle.net you should see that the numbers changed unless it sais the speed is 0b/s then its a problem
01/21/2017 08:56 AMPosted by halflotus
Bnet and WoW install fine for me using these methods. But three times in a row doing this, Hearthstone gets stuck at exactly 923.10 MB download remaining and then 'loses' internet connection (red/yellow triangle periodically pops up by the download bar). This is using Fiddler. It basically gets hung at 923.10 MB and never goes past that. :(


halflotus this happened to me too! i just left battle.net running. The red/yellow triangle stays there and the numbers don't change but in the background they actually are. If you restart battle.net you should see that the numbers changed unless it sais the speed is 0b/s then its a problem
01/13/2017 02:52 PMPosted by pingutingu

To fix some network issues:
1. Make sure Battle.net or Battle.net installer is closed.
2. Download fiddler:
https://www.telerik.com/download/fiddler
3. Install fiddler.
4. Open fiddler.
5. Open Battle.net / Battle.net installer.
6. Check if bug is still there.
7. Have fun xD!

How it works:
Fiddler creates a proxy server (data filter) to analyse data. This data filter helps Battle.net connections run smoothly in case a program is interrupting it. I hope this works! Thanks.


Man, you save my life. Thanks a lot for this bright solution and program. It really helpful which gives me an opportunity to have max ping in all game and browser cross.
01/23/2017 02:23 PMPosted by GIGAMOLE

Man, you save my life. Thanks a lot for this bright solution and program. It really helpful which gives me an opportunity to have max ping in all game and browser cross.

No problem man, I had nothing to do so i spent hours of research creating 8 fixes for bugs that Blizzard completely ignores.
24-01-2017: I have the same freaking issue!! Error: BLZBNTAGT000008A4

HotS wanted to upgrade again, and surprise surprise!! IT CAN'T.

I solved with the same steps, using the first download, and running fiddler.

If this is going to happen every.freaking.time. am going to lose my s#@t.
01/21/2017 11:11 PMPosted by pingutingu
01/21/2017 08:56 AMPosted by halflotus
Bnet and WoW install fine for me using these methods. But three times in a row doing this, Hearthstone gets stuck at exactly 923.10 MB download remaining and then 'loses' internet connection (red/yellow triangle periodically pops up by the download bar). This is using Fiddler. It basically gets hung at 923.10 MB and never goes past that. :(


halflotus this happened to me too! i just left battle.net running. The red/yellow triangle stays there and the numbers don't change but in the background they actually are. If you restart battle.net you should see that the numbers changed unless it sais the speed is 0b/s then its a problem


This doesn't work for me. No matter if I stop and start the download, or restart Battle.net it doesn't go past 923.10. It often says 0 KB/s. Sometimes flashes VERY slow dl speed like 8 B/s. But still stuck. :(
01/24/2017 08:10 AMPosted by halflotus
01/21/2017 11:11 PMPosted by pingutingu
...

halflotus this happened to me too! i just left battle.net running. The red/yellow triangle stays there and the numbers don't change but in the background they actually are. If you restart battle.net you should see that the numbers changed unless it sais the speed is 0b/s then its a problem


This doesn't work for me. No matter if I stop and start the download, or restart Battle.net it doesn't go past 923.10. It often says 0 KB/s. Sometimes flashes VERY slow dl speed like 8 B/s. But still stuck. :(

did you try using fiddler?
Hi, my problem is that Agent.exe uses 3 Mbps of my connection downloading nothing. That causes the latency to grow from 160 msec to 950 msec. To kill the process doesn't work because in a few seconds it restarts and the problem still remain. In that time latency go bak to 160 msec. It's impossible to play Diablo III.
I've looking for a solution, I've found some topic regarding the same problem, but not solved.
It's ok that Agent.exe starts together with battle.net client, but when I kill it, I want it to stay dead until I decide other way!!!

Regards,
PeoZio
01/24/2017 02:39 PMPosted by pingutingu
01/24/2017 08:10 AMPosted by halflotus
...

This doesn't work for me. No matter if I stop and start the download, or restart Battle.net it doesn't go past 923.10. It often says 0 KB/s. Sometimes flashes VERY slow dl speed like 8 B/s. But still stuck. :(

did you try using fiddler?


Yes
I Was able to download battle.net with fiddler. yeay!
Now I have countered a new problem. None of my games won't update and an error will always pop up. If I try to use fiddler it just stucks in fetching encoding table. Have tried LITERALLY all other methods but none of them work. Getting a bit frustrated... It has been like this for 2 days now.
Any advice?
Hi,

I have the same problem like many of you. I tryed to install hearsthone on my computer Yesterday. But I had the error : "We encounter a data transfer problem. Please check your internet connection, in case and then try again."

I tryed to uninstall and reinstall battle.net but now it is sooooo long to just install it. It stoped at "Update of agent in process..." the half of it. I just let it end. After 1 hour waiting for it, battle.net was working but slowly. But it didn't work. I can't install Hearsthone or any other games like overwatch.

I tryed all the things in the topic.
After I tryed to use the BnHotfixupdate, it is working faster. But I still have the same problem. Nothing worked for me. When i watch Telerik working when I try to install a game or even battle.net it seems like the agent is having trouble, a lot of error including "patch" and the "agent" happens. I don't know what it means... I know computers but i'm not an expert at all... so, can someone help us ?

Keep working on it guys, we will find a solution !

(Sorry for my english)
Hola Pingu. Find myself back here once again :) All going again once I cleaned everything and reinstalled Bnet after the patch releases - I get the connection error as soon as Bnet is installed (it looks like it doesn't finish, but is actually does) then all I do it shift right click in the Bnet folder as you suggest and paste in "battle.net.exe --game=heroes --install" without the quotes and it installs.

I can't use Bnet conventionally though and require "battle.net.exe --game=heroes --play" once it is installed to launch the game properly.

For some reason using your batch file to delete the files doesn't have the same success as when I do it manually.

N.B. The original post has grown!
hello , i have a question too , my battle net get stuck in searching for games, worked fine before that update almost a week ago , i used the exe from wow to play but now an update or quick fix was added and now when i log realms are incompatible .I did almost all i we seen here succesfully install / reinstal de battle net but the error with scanning for games persists . i am running windows XP :)
I have the solution , at last... my problem with the last update the app wont start after login, after doing that its working fine.

Go to C:/Program Files or Program Files (x86)/Battle.net/ and delete the dir Battle.net with a number and replace/copy the dir with this version :

https://drive.google.com/file/d/0Bxfh8tDtjtbaRkdQcnZFeUltWjA/view
01/26/2017 07:27 PMPosted by Mosthated
hello , i have a question too , my battle net get stuck in searching for games, worked fine before that update almost a week ago , i used the exe from wow to play but now an update or quick fix was added and now when i log realms are incompatible .I did almost all i we seen here succesfully install / reinstal de battle net but the error with scanning for games persists . i am running windows XP :)


Same problem here, look my post.
Same problem here, look my post.[/quote]

i did it and it worked i succesfully patched Wow and runs, but if the bnet updates to the newer version it crashes instant :d so i ll just keep this old one , many thanks Alentejanus !

Join the Conversation

Return to Forum