Glide DiabloII patch 1.14d

General Discussion
The goal of this post is to share with other users my configuration on GLIDE WRAPPER to be able to play DIABLO II on a wide screen with the correct ratio (4:3 instead of 16:9).

NOTE: I try the solution in this discussion ( https://us.battle.net/forums/en/bnet/topic/20743026092 ) but it didn't work for me, might work for you.
----------------------------------------------
My configuration:
-Diablo: version 1.14d
-OS: Windows 7 64-bit SP1
-Windows resolution: 1920x1080
-Glide: version 1.4e
----------------------------------------------
1) download GLIDE WRAPPER ( http://www.svenswrapper.de/english/ ).
2) extract file in the Diablo 2 folder, where the 'Diablo II.exe' is.
3) launch glide-init.exe.
4) Click on 'English/Deutsch' to change the language to english.
5) Click on 'OpenGL Info', then 'Query OpenGL info', wait for the query to finish.
6) Click on 'Setting':
-uncheck 'windows-mode'.
-check 'captured mouse'.
-uncheck 'keep aspect ratio'.
-uncheck 'vectical synchronization'.
-select 'no' for 'fps-limit'.
-select '1600x1200' for 'static size.
-uncheck 'window extra'.
-select 'auto' for 'refreshrate'.
-check 'desktopresolution'.
7) Click on 'renderer':
-select '64 mb' for 'texture-memory'.
-select '2048x2048' for 'buffer texture size'.
-uncheck ALL box EXCEPT 'shader-gama'.
8) Click on 'Extension':
-check ALL box.
9) Click on 'Quit'.
10) Create a Shortcut to Diablo II, then open the properties.
At the end of the TARGET add ' -3dfx' without the quote.
exemple : "C:\Program Files (x86)\Diablo II\Diablo II.exe" -3dfx
11) Launch Diablo with this shortcut.

Good luck
THANKS SO MUCH!
thx
Thank you! :)
Thank you :D
doesn't work for w10 ?
Hahahahaha, look at the phony alt posts with 1 post each!

Get a life.

No one cares about glide wrapper. Stop posting with alts.
I care i am not a bot. I actually used this and it worked. Sure its my first post but i have had his account since 2011. So thank you. And the other guy shut the fbbb up 67 barb solo in nm harrogate atm
04/16/2017 03:42 PMPosted by FoldUp
I care i am not a bot. I actually used this and it worked. Sure its my first post but i have had his account since 2011. So thank you. And the other guy shut the fbbb up 67 barb solo in nm harrogate atm


@FoldUp Have you ever encountered a crash with this wrapper? I had twice, in Act 2, and I was just running around Dry Hills, nothing more.
AWESOME! Thanks man!!! <3
Using Windows 10:

When I attempt to add -3dfx to the Target location in the shortcut, I receive an error:

"The name '"C:\Program Files (x86)\Diablo II\Diablo II.exe"-3dfx' specified in the Target box is not valid. Make sure the path and file name are correct."

It seems like no one else had this problem and I'm completely lost.

Hope someone can help.
@HugeNuge

copy and paste this exactly into the target box. This of course assumes your .exe file is in program files (x86).

"C:\Program Files (x86)\Diablo II\Diablo II.exe" -3dfx
@Croustillant

I tried your settings but the game is now unable to connect to bnet.
05/03/2017 02:08 PMPosted by Foolishly
@Croustillant

I tried your settings but the game is now unable to connect to bnet.


If you mean just this moment, USEast and USWest are in maintenance. Try again in like 2 hours.
Dude thank you so much!
I'm surprised this was never stickied...
Wow thanks man, it looks beautiful. But u do not need to uncheck vsync, it is good.
any ways to get it widescreen? i got 2 black bars :/
This is really nice and is great for computers that can handle a load on the graphics memory but for the few of us who have a lower end graphics card this will not work

here is mine and as you can see my graphics memory is low end
Glide-Wrapper settings export

wrapper.opengl.renderer:GeForce 7100 / nForce 630i/integrated/SSE2
wrapper.opengl.memory:256
wrapper.opengl.max_texture:4096
wrapper.opengl.poly32:253
wrapper.opengl.poly16:280
wrapper.opengl.poly8:280
wrapper.opengl.texture_mem_estimated:256
wrapper.opengl.texture_speed[]:{77,117,128,134,131,130,131,132,134,135,136,137,136,134,132,131}

wrapper.language:English

wrapper.settings.aspectratio:1

wrapper.renderer.texture_mem:82
62 was recremended but went up to 82 for some breathing room

wrapper.renderer.texture_size:10
the buffer texture size which is 1024x1024

wrapper.renderer.keep_aero:1
this is the desktop composition

wrapper.stats.corner:2
lower left corner for infos

wrapper.stats.show_fps:1
this is for showing the fps which is better and more out of the way then /fps

wrapper.stats.show_time:1
great way to tell time in full screen mode i set mine to digital

wrapper.stats.show_tex_built:1
this shows the mb of memory you are currently using and lets you know your limit of your texture memory

the following wrapper extensions are on for me to give me some decent fps some of these are turned on by default and are not shown under the extensions an extra 1 will be next to the ones that are shown for me
wrapper.extension.GL_ATI_fragment_shader:1
wrapper.extension.GL_ARB_fragment_program:1 1
wrapper.extension.GL_EXT_paletted_texture:1
wrapper.extension.GL_EXT_shared_texture_palette:1
wrapper.extension.GL_EXT_packed_pixels:1 1
wrapper.extension.WGL_EXT_swap_control:1 1
10/31/2017 02:34 PMPosted by ВУРТЕ
any ways to get it widescreen? i got 2 black bars :/
You'll need to adjust your decktop resolution through your graphics card until Blizz releases the D2 HD patch that puts the game on the Blizzard app. With that there will likely be a full screen feature like there is with SC RM. Here is how I do it. https://youtu.be/gCrQ3Cz3i0Q


10/31/2017 09:19 PMPosted by cyber15001
This is really nice and is great for computers that can handle a load on the graphics memory but for the few of us who have a lower end graphics card this will not work here is mine and as you can see my graphics memory is low end
Blizzard just made some adjustments to SC RM to allow the game to run smoothly on 2 gb of memory. We can likely expert the same when D2 gets it HD upgrade.

Join the Conversation

Return to Forum