B-Net app opens in VERY LOW resolution and covers most of screen

Technical Support
after downloading the most recent Battle.net desktop app update. Opening the application gave me this HUGE pixelated version of it. I tried everything i knew to try and fix it and nothing worked. Is there atleast a setting that lets you change this? because it's really starting to get me mad
same here
This is also a problem for me. Windows 10 x32bit
I'm also having this problem, same setup as Commonspree above. The [x] buttons on the main app, the chat app, and settings also doesn't work - the only way for me to close out is to close it by right-clicking on my taskbar or, sometimes, by manually closing through task manager.
I'm having the same issues, my setup is Windows 10 x64bit, standard resolution 1920x1080.
Hey folks,

It sounds like something's interfering with the way the Blizzard Application (we're rebranding) interacts with your graphics drivers. Can you make sure your graphics drivers are updated?

Could also be the application's hardware acceleration. This has caused a couple graphical issues like this in the past. Can we try turning that off?

    1. Open the Blizzard Application and click the Blizzard logo in the top left
    2. Choose Settings.
    3. Scroll down to the bottom of the General settings tab and uncheck Use browser hardware acceleration when available.
    4. Click Done and restart the application.
Could also be the application's hardware acceleration. This has caused a couple graphical issues like this in the past. Can we try turning that off?

    1. Open the Blizzard Application and click the Blizzard logo in the top left
    2. Choose Settings.
    3. Scroll down to the bottom of the General settings tab and uncheck Use browser hardware acceleration when available.
    4. Click Done and restart the application.
[/quote]
This would be helpful if I could get there in the settings menu, but the window is to big to see all of the options.
This is just what I'm experiencing. I couldn't see a hardware acceleration option in the General Settings. The Play button was off screen. I couldn't use the [X] to close the window and resize arrows didn't work. It was very hard to start my games, and it had been working fine until recently. I'm using Windows 10 on my laptop with 1920 x 1080 resolution (recommended setting).

Here is what I just figured out: In Windows Settings >> Display Settings, I had the app/text display size set to 150% for better readability. (Hey, I've got older eyes. I crank my chat box settings up in WoW, too.) This makes the icons and labels as well as browser text readable without having to change settings in each and every program.

This has never been a problem before, but apparently, the Blizzard app does not play well with this setting any more.

Setting it back to 100% changed the amount of screen occupied by the Blizzard app. It did NOT fix the resizing or inability to close the app window from the X. In fact, the X doesn't show. The down side for this is that my icons and text everywhere else are impossible to read, but I can change this setting when I play WoW. I hope this helps someone.
====================
ADDENDUM: The real fix. From my Windows desktop, I right clicked on the Blizzard launcher shortcut icon, then on Properties. Under Compatibility, I disabled the rescaling option. This fixed the problem, and I was able to resize my desktop icons in display settings again. I read this solution in another Blizzard forum topic. https://us.battle.net/forums/en/bnet/topic/20742986302 Thank you!
02/18/2018 12:14 PMPosted by Protlinkka
ADDENDUM: The real fix. From my Windows desktop, I right clicked on the Blizzard launcher shortcut icon, then on Properties. Under Compatibility, I disabled the rescaling option. This fixed the problem, and I was able to resize my desktop icons in display settings again. I read this solution in another Blizzard forum topic. https://us.battle.net/forums/en/bnet/topic/20742986302 Thank you!


Opened battle net to day to find I had this issue randomly.
This was the real fix I needed. Windows 10 Creators Update has it as "override high DPI scaling".
Reinstalling, updating to beta client, disabling hardware acceleration all didn't work.

Bump for those who has this issue.
Thanks for the bump Thanwa. I just encountered this too. I just love the company gaslighting though. "We did a thing, but it's probably your fault it's not working. Now bend over backwards and fix it yourself."
07/12/2019 04:07 AMPosted by Thanwa
02/18/2018 12:14 PMPosted by Protlinkka
ADDENDUM: The real fix. From my Windows desktop, I right clicked on the Blizzard launcher shortcut icon, then on Properties. Under Compatibility, I disabled the rescaling option. This fixed the problem, and I was able to resize my desktop icons in display settings again. I read this solution in another Blizzard forum topic. https://us.battle.net/forums/en/bnet/topic/20742986302 Thank you!


Opened battle net to day to find I had this issue randomly.
This was the real fix I needed. Windows 10 Creators Update has it as "override high DPI scaling".
Reinstalling, updating to beta client, disabling hardware acceleration all didn't work.

Bump for those who has this issue.


Steps:
Right-Click Battle.Net in Start menu
Choose More
Choose Open File Location
Right-Click Battle.Net Shortcut
Choose Properties
Choose Compatibility tab
Choose Change high DPI settings from the Settings group
Check box for Override high DPI scaling behavior from the High DPI scaling override section
Leave default option Application selected
Press OK

The default option, Application, worked for me in the Override High DPI Scaling option at the bottom of menu that pops out once you click Change High DPI settings from the Compatibility menu. I did not try System or System (Enhanced) options.
This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.

Join the Conversation

Return to Forum