Blizzard app freezes/lagging

Technical Support
Ever since the recent update of Battle.net to Blizzard app, i have been experiencing freezes/lag on the launcher itself.

e.g. Whenever i want to switch to another game by clicking the game icon the launcher freezes for 1-5 seconds then runs back normally

Anybody else experiencing this?

PS: No problems running the games just the blizzard app
Yes, mine is doing this as well! I uninstalled and reinstalled but it is the same lagginess.
yup
Marked As Solution
Nsj,

Which OS are you on? If you're on Windows 7, please try the following:
  • Press Windows Key + R
  • Type inetcpl.cpl into the Run Window
  • Click Okay
  • Click the Connections tab
  • Select Never dial a connection, if you have the option
  • Click LAN settings
  • Uncheck Use a proxy server for your LAN
  • If "Use a proxy server for your LAN" is already unchecked, try to select Automatically detect settings. (IE - If it is checked, uncheck it. If it is not checked, check it.)
  • Save changes, exit and try the app again
  • If you're not on Windows 7, or the steps above do not help please try reinstalling the app:
    • Open Control Panel.
    • Click Uninstall a program.
    • Right-click on Battle.net/Blizzard App and select Uninstall. This will begin the uninstallation process.
      • If the client is not listed, manually uninstall the Blizzard App:
      • Click Start ( Windows Key + Q in Windows 8), and select All Programs.
      • After locating the Blizzard App, right-click the file and select Open File Location.
      • Move one folder up and delete the Battle.net folder.


      Next let's delete the saved files for the app:
    • First go into Start > Search and type in %LOCALAPPDATA% and look for Battle.net, Blizzard and/or Blizzard Entertainment folders. If you don't have all 3, that's okay just delete the ones you do have.
    • Next same thing only this time type in %APPDATA% look for those same 3 folders and delete the ones you do have.
    • Next same thing only this time type in %TEMP% look for those same 3 folders and delete the ones you do have.
    • Last type in search %PROGRAMDATA% look for those same 3 folders and delete the ones you do have.
    • Finally go ahead and reinstall the app HERE.
    I was experiencing the same issue (since the last BNet app update).
    In my case, I was running Win 7. Updating to Win 7 SP 1 didn't help.
    Turned off Hardware Acceleration, but that didn't help either.

    Finally, I searched again today and saw this post.

    In my case, I didn't have any proxy set, but had 'Automatically detect settings' checked. Deselecting the option fixed the issue.

    I find it strange that this would be the cause.
    I cannot consider this a fix, but a workaround till the App gets fixed (hopefully...).
    Same here although I was able to play a game last night. I go to launch StarCraft 2/Heroes of the Storm and the screen goes black with cursor timer showing. I end up having to reboot my computer.
    I am also having the same problem and I just reinstalled the client. I'm on windows 7 x64. This didn't happen before until the recent update.
    As I stated in my own post afte having that problem, it was caused by a LAN/WLAN-manager, just like Game First from ASUS or the LAN-optimizer from gigabyte.
    The problem is, that the clients, battle.net-app and even diablo 3 are not recognized as priority, so they are set to the end of the chain, just getting a minimum of bandwidth, causing lagging and all the stuff you guys explain.
    Uninstalling the software will help at first.
    Second is, updating it to the latest version and configure it manualy to give the clients a high priority.
    go to my post https://webcache.googleusercontent.com/search?q=cache:EtOCkOhiUkMJ:https://us.battle.net/forums/en/bnet/topic/20752501530+&cd=1&hl=en&ct=clnk&gl=au and try the remove ads to reduce cpu usage method
    Halkriel, you are a Genius, for some reason... I hate network stuff... Anyway, thanks to you my 'Battle.net' / 'Blizzard app' isn't slow anymore.

    ◾If "Use a proxy server for your LAN" is already unchecked, try to select Automatically detect settings. (IE - If it is checked, uncheck it. If it is not checked, check it.)
    Hi there,

    Thanks Halkriel!!

    This line worked for me :
    try to select Automatically detect settings. (IE - If it is checked, uncheck it. If it is not checked, check it.)


    I unchecked the box, start again battle.net app desktop and it worked flawlessly!
    Same for me, no more freezes after unchecking "Automatically detect settings" in the LAN settings. App is now as responsive as it used to.

    OS: Windows 7 x64 SP1
    Same issue as OP, starting at the same patch, unchecking "Automatically detect settings" fixes it.

    OS: Win7 x64 SP1

    What changed in this application that broke standard compatibility with Windows? Seems like a bad way to do things when it was working fine before.
    03/26/2017 01:56 AMPosted by killerkooki
    I was experiencing the same issue (since the last BNet app update).
    In my case, I was running Win 7. Updating to Win 7 SP 1 didn't help.
    Turned off Hardware Acceleration, but that didn't help either.

    Finally, I searched again today and saw this post.

    In my case, I didn't have any proxy set, but had 'Automatically detect settings' checked. Deselecting the option fixed the issue.

    I find it strange that this would be the cause.
    I cannot consider this a fix, but a workaround till the App gets fixed (hopefully...).


    This worked in my case!
    Works. Thanks.
    But how the f*** was that setting a problem 0_o
    I have this problem, and the solutions do nothing. It started after an update, so I'm pretty sure it's a problem with the app.
    It happened when you changed from Battle.net to Blizzard App, how did you screw this up when all you had to do was a simple name change
    I just have this problem tonight for no reason.

    If "Use a proxy server for your LAN" is already unchecked, try to select Automatically detect settings. (IE - If it is checked, uncheck it. If it is not checked, check it.)

    Doing this solved the issue of mine. You can check the bluepost about how to do it.

    It appears that i don't use proxy server for LAN. Automatically detect settings were checked, so i unchecked it. It works fine now.

    Apologizes if this is some huge necromancy thing. I was looking for the fix. Found it, i hope this will be of help to some people.

    cheers
  • If "Use a proxy server for your LAN" is already unchecked, try to select Automatically detect settings. (IE - If it is checked, uncheck it. If it is not checked, check it.)
  • Thanks, Halkriel, unchecked automatically detect settings and it worked like a charm!

    Join the Conversation

    Return to Forum