We (classic game users) will not stand for this!

General Discussion
04/06/2017 09:12 PMPosted by Fatality1983
I am a programmer, and I can tell you from VAST experience that coming in and trying to change someone elses code is probably one of the most challenging things someone can do. In some cases, it would be faster to just rewrite the code yourself using their product as a template.


Agreed. And that's exactly why you have to take a more conservative and careful approach in such cases. That's also why careful planning and extensive testing are required.

04/06/2017 09:12 PMPosted by Fatality1983
Obviously WC3 and TFT can't be rewritten. So we have here a product that is so beyond EOL. Blizzard for what ever reason decided they are going to assign some programming resources to the project once more


If the products cannot be rewritten, and if they are beyond their EOL, as you are saying, then there is absolutely no reason to make bold updates. Especially when they are working just fine as they are.

But, as you can see, Warcraft III is still on digital sale on Blizzard's shop:
https://us.battle.net/shop/en-gb/product/game/legacy-games

That means it's still before its LOD (Last Order Date), and far from its EOL (End Of Life). Have you ever seen a product being sold on the official company's site after its EOL?

04/06/2017 09:12 PMPosted by Fatality1983
Well, do any of you think for one second that the programmers they are throwing into this 15 year old game are going to be the original coders who are familiar enough with the code to competently work on it with out breaking things? Do they still have the quality assurance department resources available to be able to sufficiently test any patches they are pushing with all ranges of hardware compliance like they used to when the game was in full swing? I would be genuinely surprised if the answer to any of these questions were yes.

They probably have 1 programmer trying to fix some old issues, maybe a designer as well for the new patcher system, and maybe a few QA resources, but no, I highly doubt they are running test cases across different operating system platforms, nor do I believe they are devoting sufficient time towards testing if they even do have any resources assigned.


The fact that Warcraft III is still alive, is not because Blizzard kept updating it. The main reason is that hundreds of independent developers have invested millions of hours on the Warcraft III platform, for free, working miracles that by far exceeded Blizzard's intentions and expectations (see, for instance, the birth of a whole new game genre, MOBA)

Assigning insufficient resources to the Warcraft III platform, is, at the very least, disrespectful to all these independent developers and their efforts.

If you can't do something properly, then don't do it at all. Especially when it's working just fine as it is.

04/06/2017 09:12 PMPosted by Fatality1983
One thing is for certain though; they certainly should have some sort of rollback procedure prepped and ready to go for situations like this. I am quote shocked that this hasn't happened yet to be quite frank. That is programming 101. Always have a versioning system, and always have a tested rollback procedure prepped and ready to roll in the event anything catastrophic occurs.

Or at the VERY least, put out some sort of public test server where people can opt in and test on it for a month or so before rolling it out to the production servers like they did here.


Totally agreed.
Although I agree with Fatality1983, I cannot overlook the fact that "Unable to validate game version" error when trying to connect to Battle.net was caused by their decision to move some files to Documents without realizing the fact that there are more characters in the World than those in English alphabet. The idea was good - any user in the system would have his separate maps/saves/replays, but the implementation has failed.
My Windows user folder contains non-English characters, for better or for worse (for latter in this case) and because of that I'm unable to connect to Battle.net after update and play the game without using separate Windows user account that's got only characters found in English alphabet. As you may guess it isn't very convenient.
Don't waste your money on another computer. I have a Windows10 PC and I get the same error...

04/06/2017 03:05 PMPosted by Mpro
I want to play Warcraft III: The Frozen Throne. I don't want to play WOW, I don't want to play HOTS, I don't want to play Starcraft 2 or Diablo 3 or Hearthstone. Why is it out of all the classic games that TFT is the one with the most problems and issues, especially for Mac users? I just can't understand this in 2017. Am I really going to be forced to purchase a PC in order to play a 15 year old game? How is it that a patch that has been in the works for months is released without proper review for Mac users? How is there no response or fix from the classic team for this ''Unable to find a CD Key'' error?
All of these issues some here are experiencing would weigh in way less if there would be a successor. Bring out Warcraft 4 already or make another Warcraft 3 Expansion Pack. ;-). Tell Sc2 guys to take off a few days and program a good game not the !@#$ Sc2 is now.

Btw. my patch works flawlessly. :)
No one has figured out any work arounds for the Mac problem?
Nah we mac users get the raw bone end of the warcraft shaft.
04/07/2017 10:26 AMPosted by yatusabe
No one has figured out any work arounds for the Mac problem?

https://us.battle.net/forums/en/bnet/topic/20753916468?page=3
That is the link to the forum for mac problems but even with everyones "fix" i still can't get it to work.

its annoying because they DIDN'T EVEN DAMN TEST THE PATCH.... they don't care about this game, they don't make any money from this game, the obviously don't give two !@#$s about this community so WHY TRY AND CHANGE THINGS... let us be, we love this game and have so much passion for wc3. we understand there is never going to be wc4 and its fine just leave us alone please.
Thank you.
Well at least we've received a response from the team about new Mac installers on the way, but when will that be? None of the 'fixes' work for me. I always end up back to the same problem "Unable to find a CD Key" even though my CD Keys are all correct in their w3k format. It's pretty crazy that a patch caused all of this. I hope the new installers are coming sooner rather than later because I haven't had any progress in about a week. I'm dying to play some WCIII but it seems like that won't happen for a while now, lol. Mac users get the shaft, huh?
All i want is no more adBots in Diablo2
CAN WE JUST ROLL BACK UNTIL IT IS FIGURED OUT. Why are we the testers?!
For a game this old, no patch should be implemented that breaks existing custom maps. It simply destroys the game. No one asked for such a patch. What people are asking for is perhaps an HD or Remastered version, and this is fine, just make it a separate game or separate version branch on Battle.net. Older maps must be preserved, do employees at Blizzard not realize this?

1000's of custom made creations become broken and obsolete and can never be played online again with a patch like this. Do you not understand the gravity of your errors?

P R E S E R V E
W A R C R A F T 3
04/07/2017 03:04 PMPosted by Komalt
For a game this old, no patch should be implemented that breaks existing custom maps. It simply destroys the game. No one asked for such a patch. What people are asking for is perhaps an HD or Remastered version, and this is fine, just make it a separate game or separate version branch on Battle.net. Older maps must be preserved, do employees at Blizzard not realize this?

1000's of custom made creations become broken and obsolete and can never be played online again with a patch like this. Do you not understand the gravity of your errors?

P R E S E R V E
W A R C R A F T 3


While I'm aware there are plenty of important maps that are broken, could you provide specific functionality that's not working in 1.28? This might help the team track down these issues and fix them sooner. They do read threads even if they don't have time to reply to them.
There are several topics describing the issues. For example here is one having to do with ability order ID's that received very little attention but seems to be quite a major root cause of these issues.

https://us.battle.net/forums/en/bnet/topic/20753817742
04/07/2017 04:26 PMPosted by Komalt
There are several topics describing the issues. For example here is one having to do with ability order ID's that received very little attention but seems to be quite a major root cause of these issues.

https://us.battle.net/forums/en/bnet/topic/20753817742


Greetings Komalt,

The reordered order IDs are being investigated. :)

This should be addressed in the next patch.

-Ramius
Has any mac users had success with blizz's solution, below?

https://us.battle.net/forums/en/bnet/topic/20753836697
04/07/2017 05:44 PMPosted by Ramius
04/07/2017 04:26 PMPosted by Komalt
There are several topics describing the issues. For example here is one having to do with ability order ID's that received very little attention but seems to be quite a major root cause of these issues.

https://us.battle.net/forums/en/bnet/topic/20753817742


Greetings Komalt,

The reordered order IDs are being investigated. :)

This should be addressed in the next patch.

-Ramius


Thank you so much for the response!
No luck with War3 on my Mac, even with solution provided =(
No luck here as well.
Nope still same crap, doesn't work. Because they came out with a "quick fix" with that w3k crap. It seems now it will take a while to fix the actually problem and they just don't care about it.
The launcher for 1.28 is just completely broken for TFT on Macs. There is no fix until the Classic team puts out new installers on the account management page. I tried out all of the 'fixes' multiple times before there was even an official forum post from a Blizzard Dev. Nothing works. The furthest I was able to get was RoC with 1.28 but when it comes to patching TFT, the launcher just finds my CD Key as invalid or it is unable to find it. I really hope the new installers are released quickly because I've grown impatient at this point. I just want to play ladder games on BNET.

Join the Conversation

Return to Forum