WC3 New Patch: There was an error applying the upgrade

General Discussion
Hi all, when I opened WC3 battle net it downloaded the update but when I click to restart it says "There was an error applying the upgrade"

I've tried as admin and downloading on US, Asia, and Europe server but the same result happens.

Does anyone know whats going on ? or any potential solutions?
Hey man having the same problem and so are all the homies! Anyway to bipass / resolve this or is it on their end?
https://us.battle.net/forums/en/bnet/topic/20753747349?page=2

Hard to search thru the topics that are already made? There is a blue response there.

It seems the servers are still in maintenence.

Tho it would have been better if they actually told us "Now we started the maintenance.", but whatever.
They havent annonced that is completed yet, watch the other thread.
We have already been told that we wait for them to let us know why they are working on it. We just have to wait patiently ^^ or sleep and see tomorrow how it goes xD
I was trying to download the update while server's were still under maintenance and was getting the "There was an error applying the upgrade", now that my friends can get on I tried "Run as Administrator" and now I get a bit further, but now get "Something went wrong while downloading a required update. Please check your internet connection and try again." and get sent to this page...
http://nydus.battle.net/App/enUS/setup/error/BLZBNTBTS0000004A
:/ anyone have the same problem?
still getting error applying patch. they said server is live so something is up.
nvm ran as admin and it worked. new patch installer is installing something.
So long update) seems its rebuild *.mpq game files

Join the Conversation

Return to Forum