Warcraft 3 install stuck @ "Updating Warcraft 3" 69%

Mac Technical Support
I purchased WC3 today, downloaded the game client, and opened "Warcraft 3 Launcher". I was away from my computer for some time, and returned to find it stuck at 65%. After restarting the launcher a couple of times, the install progressed to 69%, but its been stuck there for several hours after several restarts. Please help!
I'm having the exact same issue, except I have had the game installed on my computer for some time now. I tried to install an update for it and then it would not let me start the game because I didn't have the disc, even though I have a digital copy. So I tried to uninstall then reinstall the game but then ran into this issue.
I am in the same situation and followed the step to try to fix the problem provide by this website. Please Help!!!!!
Hey all,

I do have some steps you all can try that can help get Warcraft III fully updated. There are several things that could cause it to get stuck on updating like this. A common one is the profile on the Mac not being set as the administrator.

• Please make sure the profile on Mac is set as theAdministrator .

• It is possible another program could be interfering with {game}. To see if this is the case please run your computer with login items disabled.
• To be on the safe side make sure operating system and the drivers in the computer are up to date.

• Please power cycle the network equipment and flush the DNS.

• Wireless connections are not the most stable thing in the world. Anything from a cellphone to a microwave oven can disrupt the signal. If the computer is on a wireless connection, see if using a wired connection improves the connection

• Make sure the Firewall in the computer and router is set up correctly.

• I have seen some security programs cause this to happen before. Temporarily disable any security program.
Am currently having the same issue, bought the game and the expansion and it wont install. Hangs at 9 percent on initial install then when u cancel it after hours sitting there and try it over it hangs at 68 percent updating. That's as far as i am able to get it. Tried every thing in the blue post and nothing happens. At this point i would just like a refund.
Bumo. Same issue. Please look into installer links
ive tried it all I'm having the same issue. I'm stuck @ 65% for the last week. I had it goto 72% but then my computer decided to restart itself in the middle of the night . When I reopened in the morning .....again back down to 65% and stuck..
same problem. anybody have a idea how fix it?
Here on PC with the install stuck at 65%
Stuck at 65% on Mac ... This is a known issue -why are you still selling this game? I'm just out $20??
My issue is different, it downloads. Restarts. Window comes up and you have to agree to TOS then continue button lights up but clicking continue does absolutely nothing...
@NightRaven same here!!!! Hope it's just a temporary problem
NightRaven and Trident, please install the Battle.net app from here (https://www.blizzard.com/en-us/apps/battle.net/desktop) and then login + install updates. Once that is done retry running the War3 installer.
Nothing works. After reinstalled tboth Chaois and Frozen throne, i dl the laucher form blizzard but always in 65%. Could play up tp yesterday now nothing . I love this game but nothing works . Anyne solved this issue?
Ho if i try to run battlenet, dls the update and then says it is already running....
Why all this trouble to play a game i have been using the last 15 years?
Hey, ak2! Have you tried clearing the cache and tools files yet? It will ask for the CD Keys and reinstall properly if there's any issues with the agent files.
The way I fixed this was by going into the battle.net settings under game install/update and setting Latest update and future patch data to 1000000000. Seem to fix the problem as soon as I did it. Hopes this helps.
i have an issue with logging into battle.net, the game is downloaded but when it asks to restart after the bnet download, a small window pops up saying Warcraft 3 is already running and it keeps repeating itself
Hey there! The Warcraft III already running is a separate issue from this thread. There's a few steps that can help with this issue.

If the already running error continues, please create a new thread or locate a relevant thread for the already running error.

Join the Conversation

Return to Forum