Battle.net keeps requesting admin password

Mac Technical Support
Prev 1 4 5 6
And btw. the certificate is used indeed from the agent for logging into Blizzards website as the TLS extension from the certificate is telling us:

X509v3 extensions:
X509v3 Extended Key Usage:
TLS Web Server Authentication
Guess what I had today... an admin pw request and a new certificate.
03/04/2018 03:46 AMPosted by Garex42
Guess what I had today... an admin pw request and a new certificate.

While on El Capitan, 10.11.4; I had LOTS of these... Now that I've Upgraded to 10.11.6 I have fewer of them, but they still Popup from time to time...

Supposedly, Sierra and High Sierra DON'T get them.

TL
My Mac is on El Capitan 10.11.6 latest security patch. Got that popup twice today, thrice now.
Ok, got this request now down to once a day. But it wants to install another certificate, which I am denying with the ESC key.

Blizzard guys, this is really really annoying - any fixes on that on sight?
I installed my MacPro now on Sierra 10.12.6. I still get this admin request. It seems, Windows Users are the better users, according to the frequency of the blue posts in this thread, provocatively spoken.

Supposedly, Sierra and High Sierra DON'T get them.

[/quote]
I'm running High Sierra 10.13.3 and occasionally still see this.
@Garex and @DaneBrammage,

Thanks for the update on this... While I hate to see this damned thing continue like it is, it's nice to know that us El Capitan Users are NOT alone...

All I can say is that since Updating to 10.11.6 from 10.11.4 has diminished the frequency of these Popups for me. I wish Blizzard would commit more resources to this issue and clean up their Certificate Processes.

ALSO, I'm STILL getting "Download Failed" for Game Settings since two or three Blizzard Updates ago. NOW, I have to go into the Game Menu for Options EVERY game, and reset my Game Settings. (Turn off Sound following to Desktop from "Command - Tab" to switch out of game... ...and other settings.)

TL
03/11/2018 08:00 AMPosted by DaneBrammage
...


I'm running High Sierra 10.13.3 and occasionally still see this.[/quote]

I haven't seen this on High Sierra until today. Now it's every couple of minutes. And looking back at the date of this thread, it doesn't look it's going to be resolved soon.
4-13-2018 at 3:33 PM - PDT

Updated Battle.net App to Latest Update, and SC:R to 1.21.5.3899: STILL GETTING "Admin Password" Requests INTERMITTENTLY! ONLY happening within the Battle.net App during Update Process on ANY of the games I have installed. I currently have SC:R, SC II, Hearthstone, and Heroes of the Storm. In trying to Update ANY of them, OR ALL of them, EACH Update Pops Up the "Admin Password" Request!!!

COME ON BLIZZARD!!!!!

NO changes to my system from last Specs posted in this Thread; system still on MacOS X, 10.11.6.

ALSO, STILL GETTING "Download Failed" for Downloading Game Settings at Launch of SC:R from within Battle.net App. At Main Game Menu screen: "Download Failed"!!!!!

TL
Hi folks,

Joining this thread. Hope to see another blue response. Was pointed here by GM Clarveesia.

Is this strictly a 10.11.x issue? From the thread, it doesn't seem like updating is a guaranteed fix. Unfortunately, upgrading is not an option available to me on this 4,1 Mac Pro.

I'm fairly tech savvy and willing to help troubleshoot, if Blizzard needs. More logs?

Battle.net version: 1.11.2.10016
Agent version: 2.14.0.6155
Hi everyone. I don't know if this message is in the right thread, but the story begins with this issue, that I have also.

I tried deleting caches, battle.net files, then battle.net app and reinstall it. I didn't thought of reinstalling agent (no comments please :-)
All I got was a total freeze of battle.net,I was ingame and had no choice but to force reboot my mac. As I play diablo3 in hardcore mode, happily I was in a set dungeon and so couldn't die... Then afterwards each time I tried to launch battle.net, my computer freezed after a variable time, from 30 seconds to 5 minutes.
So I can't play anymore d3, I will work more efficiently perhaps...
But that's not the worst : it seems that it had also affected my graphic card, as today, after a 5-th trial to launch bnet, my screen has vertical stripes (with red values at max). Maybe that's the cause of the freeze and not a consequence, I don't know, but it wasn't here before this last trial.

So be careful !

Imac end of 2009
OsX.11.6
Battle.Net 1.11.3.10047
Agent
I've had Battle.net from a long time ago (blue-ish icon) and after I updated it recently to install Diablo 3, Agent requires password to make changes ~5 times a day.

El Capitan, here.
OS X 10.11.6, I get this dialog requesting admin password every time I start the Battle.net application. Is there a way to just start Hearthstone directly, as I have no need for the battle.net thing.

Join the Conversation

Return to Forum