OS X 10.9 "not supported" or... "blocked" ?

Mac Technical Support
I heard Mac OS X 10.9 is not supported anymore.

On my iPhone, when I download an app that requires the latest iOS, I see e message like <<You are attempting to download a version of the app that requires a more recent version of iOS. Would you like to download a previous version of the app instead?>>

Do you get my point? Why did you force us, users of Mac OS X 10.9, to update to a version that does not work anymore? Why did you break our files? Couldn't you just give us the option?

"OS X 10.9 Not Supported Anymore" means the developers will no longer resolve issues on OS X 10.9. It does not mean that they will WILLINGLY create ones!

You are willingly, purposefully creating issues, blocking us, the moment you force us to update.

Just before I updated my Battle.net the day I updated it, my "out-dated" Battle.net version was working perfectly. I could see videos, and most importantly I could launch my games. It was working perfectly fine even though it was by definition an out-dated version (since the update was already out, and I was downloading it)

In other words.. ..the previous version is working perfectly fine. It's working.

Why not allow users of Mac OS X 10.9 to keep using that version (which is working) and be able to play Blizzard games?

Let me help you, here is the message you cold give to Mac OS X 10.9 :

<<You are currently using an out-dated version of the Battle.net App. This version is not supported, its security may not be up to date and you are using it at your own risk. To update to the latest supported version please upgrade your OS to OS X 10.10 or later.>>

Easy.
yes, you can replace the battle.net app and the battle.net folder under Library/Application Support with an old backup from time machine and is working on mac 10.9
Is there no other solution for this? I'm on 10.9 and don't want to update... and dont have time machine backups...
derRichter,
can you please send me the old files? I don't have time machine... I am powerless.

If yes then I'll give you my email or whatever is easiest for you
i hope this is legal :D
can you check the folder /Users/<Usersname>/Library/Application Support/Battle.net/Versions
is there a old Version from Dezember 2017?

When is for Blizzard no problem?! then give me a address...

this is so boring from blizzard ...
I see several versions ! They do not look like apps, they look like folders. What do I do next !? :D
the folders only contains frameworks, in the root of the version-folder i have the old "battle.net.app"
I only have framework files... except one app, which is the one that requires OS X 10.10

Oh dear...

this is it, this is how it ends.

Bye bye Blizzard, it was nice having you in my life since my childhood. Farewell my friend.
Hello,
I also need the "Battle.net" agent running on OS 10.9.5.
I don't see any reason for this "little agent" to require an entire operating system update while the games are running fine.
Best wishes
This is [removed]. There is nothing wrong with 10.9 and just ending support like that is ridiculous. More signs to stick with something else
blizzard. i just decided to give starcraft another go after being disappointed with u for being so greedy and controlling. the first thing I have to contend with is this. I stopped for 4 years. and now - this. wow. this is soooo lame.

U are aware that there are plenty of companies out there who don't treat us like income providers, but actual human beings, like gamers? They will inherit your fanbase. Over the years your business and legacy will be so much more dust in the desert. jeez.
I updated to High Sierra like they wanted (and I strongly didn't want to). Heroes of the Storm ran great at High settings for me on 10.9, but in High Sierra I am struggling to keep the game running smoothly at all on lowest settings......

I would downgrade in a hot second if it was possible.... cause the game ran WAY better on 10.9 and 10.9 looks better than all the newer MacOS crap.... and didn't beak some of my apps..
There you have it lads, Blizzards and Apples way of 'thanking' you for both loyalty and your hard earned cash.

Clearly Blizzard don't want us to use their products anymore. So thats the end of that, moving on to Steam and indulging in Dota2. Which will be the only thing still playable on my 2011 macbook pro.
since i payed for it (plus the extensions) back then in the shop in a carton-box and a cd, it has a min. and max . system and a os preference printed on.. but NOW what? im forced to buy a newer computer? my mbp2011 works perfectly on mavericks but not on sierra!
i know smartphone and mobile app providers do such things, but game developer now too? oh [Removed].. where are we going..
02/03/2018 01:35 PMPosted by G3kko
oh [Removed].. where are we going..

HAhahaha, a blizzard employee has "[Removed]" part of your post G3kko, but they won't give an answer to why they made that choice to forcefully BLOCK some users, hence blocking some money income to blizzard.

:) Go figure, there is no polite way to put it :)
Or are they just too ashamed to say anything? I would, cause there are no "good" reasons for it. (plenty of bad ones though)
I know this is an old thread, but i want to post this for anyone who is searching for Mavericks 10.9 support, and understand why it is not supported.

If you download the latest client and run the setup directly, you will get an interesting error message. Assuming it is in the Downloads directory, the command would be:
sudo ~/Downloads/Battle.net-Setup-enUS.app/Contents/MacOS/Battle.net\ Setup
The output is in two parts. Part 1:
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
</body></html>

I am not sure what the 404 is, but its quite the odd message. Nonetheless, the prompt returns (meaning the original executable exited and gave control back to the console, even though something (else) is still running). After the prompt returns the message is:
dyld: lazy symbol binding failed: Symbol not found: _OSAtomicIncrement32
Referenced from: /Users/Shared/Battle.net/Setup/bna_2/Battle.net-Setup.app/Contents/MacOS/Battle.net-Setup
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _OSAtomicIncrement32
Referenced from: /Users/Shared/Battle.net/Setup/bna_2/Battle.net-Setup.app/Contents/MacOS/Battle.net-Setup
Expected in: /usr/lib/libSystem.B.dylib

Symbol not found means the app cannot resolve something and thus fails, which is why it will not run. Searching google for the error message shows people saying that anything compiled with 10.10+ will fail with this message on 10.9.

What this seems to mean is that Apple changed something in their OS and compilers which broke backwards compatibility with anything before 10.10. So, as Blizzard and other companies move forward, they are unable to continue supporting 10.9 without compiling a separate executable, or perhaps having old options put in.

While i do wish Blizzard would help us out by supporting 10.9 somehow, i do not think we can blame them for compiling for the latest version of OSX (or whatever they want to call it now) which is what most people are running.

Anyway, i hope this helps anyone wondering if the latest executable can be finagled to run on 10.9. Without some form of emulation, i seriously doubt it. :(
Thanks for providing that info chacham!

Going to be closing this thread as its over a year old.

Join the Conversation

Return to Forum