"Battle.net Launcher.exe" has generic white icon in Windows 10 taskbar

Bug Report
@Lukko worked for me man thanks!!!
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


This worked for me. Thank you! MVP!!!
@Lukko you da man!! worked to me as well. Thank you!!
Well, different fix for me.
The Shortcut on Desktop, also when i checked it @ panel, it had the same behavior:
I sent a shortcut to desktop, checked the shortcuts paths and they were correctly:
"G:\Games\Battle.net\Battle.net Launcher.exe"
when starting the shortcut, the panel will always show a white-default-win10-icon.
checking the paths again showed:
"G:\Games\Blizzard App\Battle.net Launcher.exe"

Maybe sth. is wrong with my Registry?

Whatever, my fix was: simply rename my "Battle.net" Folder to "Blizzard App"
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


This worked for me !
maybe this will help,
(for windows 10 users)
run battle.net

the white page icon shows on taskbar - right click the white page (battle.net app)

should show a window with dark listed options in window on the bottom;
-Blizzard Battlenet app
-Unpin from taskbar
-close all windows

(at this point hover over -[blizzard battlenet app]) - right click

another window pops up - select >(properties)
battlenet app properties window pops up
click general tab
look under location : (location find the folder ImplicitAppShorcuts)

Example on my comp:

(C:\Users\***youruser***\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\*********ImplicitAppShortcuts***** <-------------- this folder delete

*Note*
(****youruser****)=your user account will be different

*********ImplicitAppShortcut*****<--- delete this folder

after folder removal

close program and run it
should now display the icon correctly and re-pin to taskbar
05/13/2018 03:42 PMPosted by Hellbender
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


Finally!

Blizzard, reward this person, this is the correct answer.


Holy moly you are a god! Ty so much :D
06/26/2018 10:37 AMPosted by VeloFlex
nothing worked, still shows the white imagine, i cant open battlenet over the taskbar in general :/

im on windows 7 btw

time to upgrade to windows 10
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


Thank you this has worked for me! :D cheers -x hanafyy
If you have more than one storage device, try checking where battle.net is being saved. This changes the path to where the computer gets the shortcut image.
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


Ty so much!
Worked perfectly for me! Thanks much, was bothering me so much!
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


Man you're awesome. Thanks.
04/28/2018 10:01 PMPosted by Lukko
So this happened when I moved my Battle.net to a new drive without a fresh install.

How I fixed it on Windows 10
1. Right click on the blank Battle.net icon
2. You should see from the bottom Close window -> Pin to taskbar - > Battlenet with the blank icon as well
3. Click on this blank icon you will be met with the "shortcut not found, delete?" message
4. Say Yes then right click and close out of battle.net on the taskbar (fully not minimize)
5. Reopen then voila.

This si what worked for me and I'm glad to be done with that. Super annoying bug lol


This happened to me. Your post was perfect and fixed the job for me. Funny how simple it was and we didn't figure it out ourselves. :D

Join the Conversation

Return to Forum