Workaround for custom keys not working on 1.29 PTR

General Discussion
Like many others, I use my own custom keybinds for items because clicking is inefficient. Warkeys does not work on the PTR as it only is active when Wc3 is up, but the PTR client is not recognized as Wc3, so I have a workaround that I'd like to share with everyone. All you have to do is make an AutoHotkey script that manually binds your preferred keys to the Numpad.

Here's my keybinds for reference - https://pastebin.com/NSvCBEpt

Q = Num7 (top left, always TP. This way if I need to TP I just hit QQ quickly) alt Q = Num8 (top right) alt S = Num4 (middle left) alt W = Num5 (middle right) alt D = Num1 (bottom left) alt E = Num2 (bottom right)

Here is a useful link to some of the shortcuts you can use when writing your scripts (! = alt, ^ = ctrl , etc) - https://autohotkey.com/docs/Hotkeys.htm

NOTE- Depending on what keys you use, if you want to chat normally or type something, you might have to disable the script and re-enable when you enter a game. For example, since my script binds Q to Num7, if I type "question" it comes out as "7uestion."

Hope this helps!
i just did the custom keys with warkeys for my normal wc3 version a while ago and just copyd them into the ptr version folder , its all working fine got all my hotkeys working (: try that

Join the Conversation

Return to Forum