Cant play wc3 arranged team with friends

Support
blizzard what is going on with this?
Have they admitted this being a common problem?
Similiar issue. Have forwarded eveything. However, it works sometimes. The rest of the time we just get "Unknown error - Team disbanded". We haven't been able to pinpoint what we're doing differently when it works.

Most of the time we just keep trying, just remember to restart the game after a couple of tries, or you'll get ip-restricted for about 10 minutes where you're disconnected from Bnet and can't rejoin until the restriction expires.

Considering it sometimes works, and that the same setup worked years ago, I'll have to conclude there's something wrong with the new patch, which needs to be fixed.
Do you think both mine and my friend's ports need to be open?
Is 6112 one enough?

EDit Update: We both set a static IP, opened 6112 port, we checked if its open using sites/tools... it says its open, and still same problem, cant play AT
04/15/2018 12:26 AMPosted by BFG
Have they admitted this being a common problem?

They do not admit to anything,yet!
Ok, update:

Me any my friend managed to make it work, BUT it works like randomly. I can invite him once, then if we disband the party or play one game, it doesnt work anymore. Then we have to close wc3, re-open ports on router (even though we actually change nothing, just re-apply the same changes)

Then other times, he can invite and i cant... it just shows its bugged.
Earth to Blizzard!
We still can't play AT . . .
Same !@#$.. Lost 1 hour already, then I read this..

Please fix
* I want this post on top in order to get recognized * Thanks
Same here, pls hear us :D
Please respond Blizzard! Please!
Any help from Blizz?
Same issue here - Cannot AT. Would appreciate an answer Blizz :)
Anyone had any luck with this? There was some patch but i dont think they fixed it ?
same :(
04/14/2018 10:31 AMPosted by Mat
I got an update for all people interestes in AT:
1. Some people can invite
=> that means, it works! . . . somehow at least!
2. I asked them, how they did it!
=> They replied: We only opened ports
3. I asked them about their router/firewall settings
=> I made EXACTLY what they did!!!!
4. I still can't invite...
=> DEAR BLIZZARD: PLEASE FIX THIS PROBLEM!

THANK YOU!


click on warcraft 3 options in main menu, then click on gameplay and then set the game port to 6112 (for me it was reading as 6126 after patch 1.29) and press okay. Restart the game and give it a try :).

This should allow you to host games assuming you have already opened up your ports on your internet connection. If you have not done so, you can go to:

https://portforward.com/

Once there, choose your router, choose warcraft III as the game you want to open ports for and follow through the tutorials on how to do it on the site. It will also show you how to set up a static ip, so you dont have to keep redoing it every time your pc ip changes.

You may also want to visit https://us.battle.net/support/en/article/20457 for further troubleshooting.

Also make sure you have allowed your games through windows firewall.

Hope this works, or helps someone!! good luck
04/25/2018 03:13 PMPosted by ShadowDeath
04/14/2018 10:31 AMPosted by Mat
I got an update for all people interestes in AT:
1. Some people can invite
=> that means, it works! . . . somehow at least!
2. I asked them, how they did it!
=> They replied: We only opened ports
3. I asked them about their router/firewall settings
=> I made EXACTLY what they did!!!!
4. I still can't invite...
=> DEAR BLIZZARD: PLEASE FIX THIS PROBLEM!

THANK YOU!


click on warcraft 3 options in main menu, then click on gameplay and then set the game port to 6112 (for me it was reading as 6126 after patch 1.29) and press okay. Restart the game and give it a try :).

This should allow you to host games assuming you have already opened up your ports on your internet connection. If you have not done so, you can go to:

https://portforward.com/

Once there, choose your router, choose warcraft III as the game you want to open ports for and follow through the tutorials on how to do it on the site. It will also show you how to set up a static ip, so you dont have to keep redoing it every time your pc ip changes.

You may also want to visit https://us.battle.net/support/en/article/20457 for further troubleshooting.

Also make sure you have allowed your games through windows firewall.

Hope this works, or helps someone!! good luck


Thank You for your work! But I am like 99% sure that the problem is my Provider/Router of my Provider... I fixed another Router from a mate of mine and now he can invite... I still cannot invite by the way! But thank you very much for your nice explanation!
Maybe you fixed for your friend, but i doubt it will always work. My friend can invite for like 1 game, then the same error "unknown, the game has disbanded"

So, what exactly is problem here when you can invite for 1 game, then suddenly it doesnt work anymore
Dude we are in LAN with friends to play warcraft 3 like we did 15 years ago, the only weekend we finally manage to meet and play there is this bug!!! You must be kiddinnnnng !!!!!!!!!!!!! Sadness over 90000000000
Same Problem here. Plz fix it already!

Join the Conversation

Return to Forum