[WC3] Frame rate drop after Windows 10 update (version 1803)

General Discussion
After updating Windows 10 a few weeks ago I experienced a significant drop in frame rate. I used to be able to run the game on my laptop in the native frame rate of 3840x2160 at 60fps (would drop a bit during large battles) but now it fluctuates between 24-30fps. Dropping the game resolution to 1980x1080 does not make a difference.

I have tried all of the compatibility settings and using the -opengl modifier on the exe file with no luck. I have also tried disabling the Focus Assist function in Windows.

Has anyone had any luck dealing with this problem?

Windows 10 version 1803
Core i5-6300HQ
16 gb ram
Geforce GTX 960M 2gb
try turning off the game bar in the windows system settings.
also try turning off vsync for wc3.
Try clean installing your graphic drivers. Windows 10 likes to reinstall them without warning and do so in a buggy way. After every major update I find myself having to download the latest drivers from NVidia and clean installing them over the bugged ones Windows 10 update installed.
Some AMD graphics cards have an issue with low fps in the game.

I run an html5 example video in my browser on loop to get stable fps (60) in wc3. This forces the graphics card into a more intensive state and wc3 fps benefits from it.

https://www.w3.org/2010/05/video/mediaevents.html
Thank you for the suggestions.. I tried turning off all the of the game bar settings and vsync. No Change. Same with fully reinstalling the Nvidia drivers.

I completely turned off Dell Premier Color which seemed to have a memory leak in it and the frame rate seems to have stabilized around 30fps.
05/23/2018 04:15 PMPosted by cracklebet
Some AMD graphics cards have an issue with low fps in the game.

I run an html5 example video in my browser on loop to get stable fps (60) in wc3. This forces the graphics card into a more intensive state and wc3 fps benefits from it.

https://www.w3.org/2010/05/video/mediaevents.html


playing this video in the background drops the fps to 22-23fps, but I think you're onto something with forcing the graphic card's intensity..

If I open the performance monitor in the Task Manager and view it during a test game, the onboard Intel HD Graphics 530 is running at about 90% and the Geforce 960M is only running at about 40%
adding -nativefullscr modifier to the exe in the shortcut made a significant difference, up to 45fps!

"C:\Program Files (x86)\Warcraft III\Warcraft III.exe" -nativefullscr
Just when im about to switch to win10 from win7 for a try on my modern ryzen system i meet such topics, meh :)
There are two settings in the wc3 registry that could help.

"Lockfb" and "refreshrate"

Check out this post

https://us.battle.net/forums/en/bnet/topic/20762157992#post-3

A good thing to check is ur windows display-> advanced-> monitor settings. See if the monitor refreshrate is set to 60 there,

Join the Conversation

Return to Forum